Bug 90633 - ShadowFB broken output corrupted
Summary: ShadowFB broken output corrupted
Status: RESOLVED MOVED
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/savage (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-05-25 23:00 UTC by Riccardo Mottola
Modified: 2018-08-10 20:46 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Riccardo Mottola 2015-05-25 23:00:05 UTC
savage driver: 2.3.8 on Savage4
xorg-server: 1.17.1

On linux Gentoo

Enabling ShadowFB, even with NoAccel = true (which has other problems) and DRi disabled, will result in a corrupted display. Apparently the image is drawn with some kind of wrong offset/line size: the effect is that icons, moouse pointers seem drawn in pieces several times, becoming unreadable. The screen looks reactive, one can try to click, move the mouse.


X.Org X Server 1.17.1
Release Date: 2015-02-10
[  1966.368] X Protocol Version 11, Revision 0
[  1966.368] Build Operating System: Linux 4.0.0-gentoo i686 Gentoo
[  1966.368] Current Operating System: Linux think 4.0.2-gentoo #1 Wed May 13 00
:15:34 CEST 2015 i686
[  1966.368] Kernel command line: root=/dev/sda5 
[  1966.368] Build Date: 24 April 2015  09:44:22AM
[  1966.368]  
[  1966.368] Current version of pixman: 0.32.6
[  1966.368]    Before reporting problems, check http://wiki.x.org


[  1966.780] (II) Module ABI versions:
[  1966.780]    X.Org ANSI C Emulation: 0.4
[  1966.780]    X.Org Video Driver: 19.0
[  1966.780]    X.Org XInput driver : 21.0
[  1966.780]    X.Org Server Extension : 9.0


[  1967.576]    ABI class: X.Org Video Driver, version 19.0
[  1967.576] (II) SAVAGE(0): initializing int10
[  1967.576] (EE) SAVAGE(0): Cannot read int vect
[  1967.576] (--) SAVAGE(0): Chip: id 8c2e, "SuperSavage/IXC 64"
[  1967.576] (--) SAVAGE(0): Engine: "SuperSavage"
[  1967.576] (--) SAVAGE(0): AGP card detected
[  1967.576] (==) SAVAGE(0): Using AGP DMA
[  1967.576] (WW) SAVAGE(0): DMA is not supported on SuperSavages.
[  1967.577] (**) SAVAGE(0): DMA disabled
[  1967.577] (==) SAVAGE(0): Using AGP 1x mode
[  1967.577] (==) SAVAGE(0): Using 16 MB AGP aperture
[  1967.579] (==) SAVAGE(0): Using gamma correction (1.0, 1.0, 1.0)
[  1967.579] (--) SAVAGE(0): probed videoram:  16384k
Comment 1 GitLab Migration User 2018-08-10 20:46:21 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/xorg/driver/xf86-video-savage/issues/6.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.