Bug 92324 - [Intel-gfx] [PATCH] fixup! drm/i915/skl: Eliminate usage of pipe_wm_parameters from SKL-style WM (v3) [regression][bisected]
Summary: [Intel-gfx] [PATCH] fixup! drm/i915/skl: Eliminate usage of pipe_wm_parameter...
Status: CLOSED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: x86-64 (AMD64) Linux (All)
: highest blocker
Assignee: Matt Roper
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-10-07 02:17 UTC by Jairo Miramontes
Modified: 2016-01-12 16:39 UTC (History)
1 user (show)

See Also:
i915 platform: SKL
i915 features: display/atomic


Attachments

Description Jairo Miramontes 2015-10-07 02:17:28 UTC
>> Paulo, I'm not positive that this is the cause of the issues you're
>> seeing, but
>> I did find this unwanted behavior change while re-reading all the SKL
>> watermark
>> code.  Could you give this a try and see if it improves your
>> situation at all?
>
> Thanks for the patch, but unfortunately this doesn't solve the problems
> I'm seeing.
>
> For my normal work activities I'm carrying a patch that reverts the
> following commits:
>
> drm/i915: Calculate watermark configuration during atomic check (v2)
> drm/i915: Don't set plane visible during HW readout if CRTC is off
> drm/i915: Calculate ILK-style watermarks during atomic check (v3)
> drm/i915: Calculate pipe watermarks into CRTC state (v3)
> drm/i915: Refactor ilk_update_wm (v3)
> drm/i915: Drop intel_update_sprite_watermarks
>
> So I guess the sprite update thing is very likely the first bad commit.
> I'm also noticing that the screen stays black for _way_ too much time
> during boot, but I'm not sure it's caused by the watermark series:
> might be something else on -nightly.
>
> Thanks,
> Paulo
>
>>
>>  drivers/gpu/drm/i915/intel_pm.c | 3 +++
>>  1 file changed, 3 insertions(+)
>>
>> diff --git a/drivers/gpu/drm/i915/intel_pm.c
>> b/drivers/gpu/drm/i915/intel_pm.c
>> index 3857592..22c97f2 100644
>> --- a/drivers/gpu/drm/i915/intel_pm.c
>> +++ b/drivers/gpu/drm/i915/intel_pm.c
>> @@ -2951,6 +2951,9 @@ skl_get_total_relative_data_rate(const struct
>> intel_crtc_state *cstate)
>>               if (pstate->fb == NULL)
>>                       continue;
>>
>> +             if (intel_plane->base.type == DRM_PLANE_TYPE_CURSOR)
>> +                     continue;
>> +
>>               /* packed/uv */
>>               total_data_rate +=
>> skl_plane_relative_data_rate(cstate,
>>                                                               psta
>> te,
Comment 1 Jairo Miramontes 2015-10-07 02:21:34 UTC
This bug was created for tracking purposes, this bug was raised on Intel-gfx mailing list, on the following link http://lists.freedesktop.org/archives/intel-gfx/2015-October/077298.html
Comment 2 Matt Roper 2015-10-23 20:22:57 UTC
This was fixed by Paulo's revert here:

    commit 2791a16ca43302d07ac74cbe7c048e367c4632c4
    Author: Paulo Zanoni <paulo.r.zanoni@intel.com>
    Date:   Fri Oct 9 18:22:43 2015 -0300

        drm/i915: revert a few more watermark commits

We tracked down the cause of the issue and re-pushed a v4 of this commit that fixes the problems in

    commit 024c9045221fe45482863c47c4b4c47d37f97cbf
    Author: Matt Roper <matthew.d.roper@intel.com>
    Date:   Thu Sep 24 15:53:11 2015 -0700

        drm/i915/skl: Eliminate usage of pipe_wm_parameters from SKL-style WM (v4)

Paulo confirmed the new version worked for him and I haven't heard any other regression reports, so I think we should be good now; please re-open if the problems return.
Comment 3 Radhakrishna Sripada 2015-12-03 02:11:04 UTC
I connected a 1920x1080 eDp panel on to skylake RVP. Running drm-intel-nightly: 2015y-12m-02d-16h-11m-34s DMC version 23 - chromium os, I was able to see flickers on eDp when I hover the mouse. The screen goes blank and settles back after 3 seconds or after hitting space bar. 

I donot see the issue when I connect 1366x768 eDp. 
I observed the issue when I was backporting atomic watermark updates onto 3.18 kernel. I was unable to revert the commit 024c904 on top of the drm-intel-nightly branch. I narrowed down by comparing the 024c904 commit and its parent commit.

Without the commit 024c904 I see flicker on eDp when I connect an external monitor over HDMI/DP irrespective of the edp panel's resolution.
Comment 4 Shobhit 2015-12-08 04:49:34 UTC
Is anyone looking into this. I can help if there are some suggestions.
Comment 5 Shobhit 2015-12-08 04:53:11 UTC
I tried a experimentation patch to make wm level 0 as 0xff and all other levels as 0 and all flicker goes away. So seems that there is still some issue in wm update code ?
Comment 6 Daniel Vetter 2015-12-08 09:36:40 UTC
This was a bug report for an issue Paulo reported. Please file new ones since likely you have a different bug.

Thanks, Daniel
Comment 7 Humberto Israel Perez Rodriguez 2015-12-11 17:01:36 UTC
the original issue in this bug is no longer visible or reproducible, i tried with the following configuration :

 --- Hardware information ---
Motherboard model             : Skylake Client platform
Motherboard type              : Skylake Y LPDDR3 RVP3 Laptop
Motherboard manufacturer      : Intel Corporation
CPU information               : Intel(R) Core(TM) m5-6Y57 CPU @ 1.10GHz
GPU Card : Intel Corporation Sky Lake Integrated Graphics (rev 07) (prog-if 00 [VGA controller])


 --- Software information ---

Linux distribution: Ubuntu 15.10 LTS 64 bits
Bios : SKLSE2R1.R00.B104.B01.1511110114)
xorg-server-1.18.0 from http://cgit.freedesktop.org/xorg/xserver
libdrm-2.4.65 from http://cgit.freedesktop.org/mesa/drm/
xf86-video-intel 2.99.917 from http://cgit.freedesktop.org/xorg/driver/xf86-video-intel/
mesa-11.0.4 from http://cgit.freedesktop.org/mesa/mesa/
libva-1.6.2.pre1 from http://cgit.freedesktop.org/libva/
vaapi-intel-driver 1.6.2.pre1 from http://cgit.freedesktop.org/vaapi/intel-driver
cairo 1.14.4 from http://cgit.freedesktop.org/cairo
Rendercheck 1.5 from http://cgit.freedesktop.org/xorg/app/rendercheck
DMC 1.23 and GUC 4.3 firmware from https://01.org/linuxgraphics/intel-linux-graphics-firmwares
KSC  : 1.15


 --- Kernel information ---
Kernel: drm-intel-nightly: 2015y-12m-10d-19h-15m-29s from : git://anongit.freedesktop.org/drm-intel

commit be04e4e814b295b6941f5aed12835f6595c41c18
Author: Rodrigo Vivi <rodrigo.vivi@intel.com>
Date:   Thu Dec 10 11:15:40 2015 -0800



This are the panels that was used in order to reproduce this bug :

-eDP panel with native resolution 3200x1800 @60.00
Resolution :  1920x1080     @60.00  = i did not see any flickers on eDP panel 
Resolution :  1368x768      @60.00  = i did not see any flickers on eDP panel 
Resolution :  1368x768      @59.00  = i did not see any flickers on eDP panel 

-eDP panel resolution 1920x1080 @60.00
Resolution : 1920x1080     @60.00 = i did not see any flickers on eDP panel 

-eDP panel with native resolution 1366x768 @60.00
Resolution : 1366x768      @60.00 = i did not see any flickers on eDP panel 
Resolution : 1366x768      @59.00 = i did not see any flickers on eDP panel 


Note : as comment Radhakrishna Sripada i too saw flickering when i did hotplug/hotunplug HDMI/DP on SKL-Y in eDP panel, irrespective of the edp panel's resolution
Comment 8 cprigent 2016-01-12 16:39:11 UTC
The conclusion was: “Increasing DDB allocation size for Cursor solves the issue”
We did another verification on a SKL Laptop available on the market, with last setup it is not reproduced.

Hardware
Motherboard model Inspiron: 15-7568
Motherboard type: 02HK88 Laptop
Motherboard manufacturer: Dell Inc.
CPU family:  Core i7
CPU information: Intel(R) Core(TM) i7-6500U CPU @ 2.50GHz
GPU Card: Intel Corporation Sky Lake Integrated Graphics (rev 07) (prog-if 00 [VGA controller])
Memory ram: 8 GB
eDP resolution: 1920x1080 @60Hz
Panel as HDMI: ASUS 4K
Software
Linux distribution: Ubuntu 15.10 64 bits
Bios version: 1.0
Kernel: drm-intel-nightly 4.4.0-rc8 8834392 from http://vanaheimr.fr.intel.com/shared/out/kernels/drm-intel-nightly/WW02.1_4.4.0-rc8_8834392/
libdrm-2.4.66 from http://cgit.freedesktop.org/mesa/drm/
xf86-video-intel 2.99.917 from http://cgit.freedesktop.org/xorg/driver/xf86-video-intel/
mesa-11.0.8 from http://cgit.freedesktop.org/mesa/mesa/
libva-1.6.2 from http://cgit.freedesktop.org/libva/
intel-driver 1.6.2 from http://cgit.freedesktop.org/vaapi/intel-driver
cairo 1.15.2 from http://cgit.freedesktop.org/cairo
IGT master 1.13 cd658a7c6bca74eb897a8ae87751029793f0c4f4 from http://cgit.freedesktop.org/xorg/app/intel-gpu-tools/
DMC and GUC firmware from https://01.org/linuxgraphics/intel-linux-graphics-firmwares
GuC: 4.3 and DMC 1.23 from https://01.org/linuxgraphics/intel-linux-graphics-firmwares

So closed. Fill free to reopen if needed.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.