Bug 92531 - GPU HANG on Intel Iris Pro 6200 (i5-5675C CPU)
Summary: GPU HANG on Intel Iris Pro 6200 (i5-5675C CPU)
Status: CLOSED DUPLICATE of bug 89360
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-10-19 09:49 UTC by bugs.fdo
Modified: 2017-07-24 22:44 UTC (History)
1 user (show)

See Also:
i915 platform: BDW
i915 features:


Attachments
/sys/class/drm/card0/error output (220.56 KB, text/plain)
2015-10-19 09:49 UTC, bugs.fdo
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description bugs.fdo 2015-10-19 09:49:02 UTC
Created attachment 118975 [details]
/sys/class/drm/card0/error output

I am occasionally experiencing GPU hangs on my computer. The configuration is a PC with an Intel i5-5675C (non-overclocked) running Gentoo Linux with a 4.2.3 kernel.
The hangs seem to occur randomly, sometimes when running an OpenGL game, sometimes when just sitting at the desktop idleing.
This causes the desktop to freeze for a few seconds. After the GPU has been reset, it is back to normal.

dmesg output:

[147443.830208] DMAR: DRHD: handling fault status reg 3
[147443.830213] DMAR: DMAR:[DMA Read] Request device [00:02.0] fault addr 21f9e000 
                DMAR:[fault reason 05] PTE Write access is not set
[147443.830219] DMAR: DRHD: handling fault status reg 3
[147443.830221] DMAR: DMAR:[DMA Read] Request device [00:02.0] fault addr 21fad000 
                DMAR:[fault reason 05] PTE Write access is not set
[147443.830399] DMAR: DRHD: handling fault status reg 3
[147443.830401] DMAR: DMAR:[DMA Write] Request device [00:02.0] fault addr 21f9e000 
                DMAR:[fault reason 23] Unknown
[147449.741936] [drm] stuck on render ring
[147449.742725] [drm] GPU HANG: ecode 8:0:0x85dffffb, in X [5694], reason: Ring hung, action: reset
[147449.742726] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
[147449.742727] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
[147449.742728] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
[147449.742728] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
[147449.742729] [drm] GPU crash dump saved to /sys/class/drm/card0/error
[147449.743906] drm/i915: Resetting chip after gpu hang
[147449.753533] DMAR: DRHD: handling fault status reg 3
[147449.753536] DMAR: DMAR:[DMA Read] Request device [00:02.0] fault addr 21f9e000 
                DMAR:[fault reason 05] PTE Write access is not set
[147449.753642] DMAR: DRHD: handling fault status reg 3
[147449.753644] DMAR: DMAR:[DMA Write] Request device [00:02.0] fault addr 21f9e000 
                DMAR:[fault reason 23] Unknown
[147455.738289] [drm] stuck on render ring
[147455.739157] [drm] GPU HANG: ecode 8:0:0x85dffffb, in X [5694], reason: Ring hung, action: reset
[147455.739212] [drm:i915_set_reset_status] *ERROR* gpu hanging too fast, banning!
[147455.740301] drm/i915: Resetting chip after gpu hang
Comment 1 Chris Wilson 2015-10-19 10:14:47 UTC

*** This bug has been marked as a duplicate of bug 89360 ***
Comment 2 bugs.fdo 2015-10-21 12:04:38 UTC
The description of the bug of which this one is supposed to be a duplicate, does not sound very similar - in case of this bug the system does not crash or freeze entirely.  It freezes for a moment until the GPU is being reset. Maybe it has the same cause though, I don't know. I assume you know why you set it as a duplicate.

One thing I noticed is that OpenGL applications do no longer work after that bug and the GPU is being reset fairly often afterwards until I restart the machine.
Comment 3 Chris Wilson 2015-10-21 12:07:09 UTC
Your bug relates to an invalid PTE either detected by DMAR or caused by it. Symptoms may vary wildly, but ultimately until the DMAR issue is resolved you will not whether you have any other genuine bug because of DMAR underpinning everything.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.