Bug 92726 - kexts at 20%
Summary: kexts at 20%
Status: RESOLVED INVALID
Alias: None
Product: XQuartz
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 2.7.8 (xserver-1.16.4)
Hardware: Other All
: medium normal
Assignee: Jeremy Huddleston Sequoia
QA Contact: Jeremy Huddleston Sequoia
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-10-29 15:55 UTC by Burkhard Militzer
Modified: 2015-11-02 16:25 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
attachment-21284-0.html (2.39 KB, text/html)
2015-11-02 16:25 UTC, Burkhard Militzer
Details

Description Burkhard Militzer 2015-10-29 15:55:42 UTC
I recently upgraded to XQuartz 2.7.8. and later on to OSX El Capitan. Now I have a system that is somewhat sluggish and according to 'top' the 'kexts' process constantly takes up 20% of the CPU time. 

When I boot the machine with Shift key pressed, the problem is solved and 'kexts' takes up no CPU time at all. However, XQuartz does not launch (error: cannot establish listening socket.) This is the reason why I believe XQuartz 2.7.8. could be the culprit  and the reason why I am submitting this report.

Thank you,

Burkhard Militzer
Comment 1 Jeremy Huddleston Sequoia 2015-10-29 18:43:59 UTC
The 'error: cannot establish listening socket.' error is likely because you've eitehr disabled the org.macosforge.xquartz.privileged_startx LaunchDaemon, deleted /tmp, or messed with the permissions on /tmp.

XQuartz does not have anything to do with your kexts.
Comment 2 Jeremy Huddleston Sequoia 2015-10-29 18:45:40 UTC
You should take a sysdiagnose when encountering the problem and look at the spindump to see what this kexts process is doing.
Comment 3 Burkhard Militzer 2015-11-02 16:25:51 UTC
Created attachment 119351 [details]
attachment-21284-0.html

Thank you. The problem was eventually resolved by disabling the system
integrity protection following:

http://www.imore.com/el-capitan-system-integrity-protection-helps-keep-malwa
re-away


Best wishes,


Burkhard

On Thu, Oct 29, 2015 at 2:45 PM, <bugzilla-daemon@freedesktop.org> wrote:

> *Comment # 2 <https://bugs.freedesktop.org/show_bug.cgi?id=92726#c2> on
> bug 92726 <https://bugs.freedesktop.org/show_bug.cgi?id=92726> from Jeremy
> Huddleston Sequoia <jeremyhu@freedesktop.org> *
>
> You should take a sysdiagnose when encountering the problem and look at the
> spindump to see what this kexts process is doing.
>
> ------------------------------
> You are receiving this mail because:
>
>    - You reported the bug.
>
>


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.