Bug 92790 - Radeon.mst error
Summary: Radeon.mst error
Status: NEW
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Radeon (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: highest major
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-11-03 10:21 UTC by Adrian
Modified: 2017-11-03 16:03 UTC (History)
5 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Adrian 2015-11-03 10:21:34 UTC
Details have been been submitted here: https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/1509997

Today (3.11.2015) I have tried with the newest version from ppa:xorg-edgers/ppa and even with apparently the newest version of the Radeon driver, the problem still exists (the same symptoms) and all screens switch to the standby mode. 

The only error message I have managed to spot is:
 [drm:radeon_mst_encoder_dpms [radeon]] *ERROR* DPMS OFF 0
Comment 1 Paul FitzPatrick 2015-11-03 14:16:33 UTC
This affects my setup and is (I think) the only blocker keeping me from using the open source drivers (which I would prefer). Right now I need to use fglrx to support my 6 monitor setup, 4 of which are daisy-chained on DisplayPort with the last member of the chain using a DisplayPort to DVI adapter.

If there are any proposed fixes, I would be happy to try them out.
Comment 2 Adrian 2015-11-05 18:30:45 UTC
I have tried to run the newest kernel 4.3.0 (http://ubuntuhandbook.org/index.php/2015/11/linux-kernel-4-3-released/) and got exactly the same issues.
Comment 3 aello 2016-02-03 17:44:52 UTC
I have tried with arch kernel 4.4.1, also same issue
Comment 4 Mike E 2016-03-20 06:48:08 UTC
I believe I am seeing the same issue. I posted a thread on the Arch Linux forums for guidance, it contains all the details, it is here: https://bbs.archlinux.org/viewtopic.php?id=210338

I am using Linux 4.2.5-1
Comment 5 Adrian 2017-11-03 16:03:35 UTC
It still doesn't work on Ubuntu 17.10 (4.13.0-16-lowlatency).


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.