Bug 9307 - [965g]: Consistent crashes in any GL application with DRI enabled
Summary: [965g]: Consistent crashes in any GL application with DRI enabled
Status: RESOLVED WORKSFORME
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: 6.5
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Eric Anholt
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-12-11 17:42 UTC by Jack Lloyd
Modified: 2007-08-27 18:51 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
My X logfile (49.16 KB, text/plain)
2006-12-11 17:43 UTC, Jack Lloyd
Details
My Xorg config (1.51 KB, text/plain)
2006-12-11 17:43 UTC, Jack Lloyd
Details
glxinfo output (4.86 KB, text/plain)
2006-12-11 17:43 UTC, Jack Lloyd
Details
X Log (35.26 KB, text/plain)
2007-07-23 19:45 UTC, Wagner Macedo
Details
X Log with error (37.84 KB, text/plain)
2007-07-23 19:50 UTC, Wagner Macedo
Details
X Log with error (37.84 KB, text/plain)
2007-07-23 19:50 UTC, Wagner Macedo
Details
X Log with debug mode (63.10 KB, text/plain)
2007-07-31 10:32 UTC, Wagner Macedo
Details

Description Jack Lloyd 2006-12-11 17:42:33 UTC
With Mesa 6.5.2, running a GL application (such as glxgears or mplayer -vo gl)
results in the application segmentation faulting immediately. This only occurs
when DRI is enabled. I cannot get a backtrace; running within gdb locks up X
entirely and seems to screw up the video hardware state, requiring a reboot.

Currently I'm using Xorg 7.1 w/the latest modesetting branch of the Intel X
driver. It looks like Xorg 7.2 isn't yet official, I will see if this still
occurs with 7.2 as soon as packages hit my distro (probably within a week).

I will note that this is a major improvement over Mesa 6.5.1, where GL
applications would crash with or without DRI enabled. :/ So at least it has gone
from non-working to working but slow.
Comment 1 Jack Lloyd 2006-12-11 17:43:05 UTC
Created attachment 8064 [details]
My X logfile
Comment 2 Jack Lloyd 2006-12-11 17:43:22 UTC
Created attachment 8065 [details]
My Xorg config
Comment 3 Jack Lloyd 2006-12-11 17:43:42 UTC
Created attachment 8066 [details]
glxinfo output
Comment 4 Michel Dänzer 2006-12-30 02:41:00 UTC
(In reply to comment #0)
> With Mesa 6.5.2, running a GL application (such as glxgears or mplayer -vo gl)
> results in the application segmentation faulting immediately. This only occurs
> when DRI is enabled. 

Are you making sure that Mesa builds with -fno-strict-aliasing?

> I cannot get a backtrace; running within gdb locks up X entirely and seems to
> screw up the video hardware state, requiring a reboot.

Yes, you can't debug an X server from within itself, because gdb stops execution
of the X server, which is what provides interaction with gdb... it should work
from a remote login though.
Comment 5 Jack Lloyd 2006-12-30 13:04:42 UTC
Yes, I'm using the Mesa ebuild from Gentoo, which appends -fno-strict-aliasing
to the set of flags (so the full CFLAGS when Mesa is built is '-march=nocona -O2
-momit-leaf-frame-pointer -fno-strict-aliasing').

I'll see if I can get a backtrace using a remote login.
Comment 6 Gordon Jin 2007-03-14 19:38:23 UTC
The bug priority was upgraded (P2->high) with the bugzilla configuration change.
I'm Changing the priority back to the normal one.
Sorry for the spam.
Comment 7 Wagner Macedo 2007-07-23 19:45:19 UTC
Created attachment 10862 [details]
X Log

With me, happens the same, I tested with Ubuntu Feisty and Ubuntu Gutsy (Alpha Version)
Comment 8 Wagner Macedo 2007-07-23 19:50:10 UTC
Created attachment 10863 [details]
X Log with error

Sorry, in my other attachment, I sent the wrong file, now I'm sending the right.
Comment 9 Wagner Macedo 2007-07-23 19:50:23 UTC
Created attachment 10864 [details]
X Log with error

Sorry, in my other attachment, I sent the wrong file, now I'm sending the right.
Comment 10 Wagner Macedo 2007-07-31 10:32:03 UTC
Created attachment 10928 [details]
X Log with debug mode

What more info is needed on this topic? I have an Intel MB DG965SS with Core 2 Duo that I bought less than 3 months and I realy can't use it. I'm having problems that this topic describes well. I decided to buy Intel because this MB is marked as compatible on the site and the open source drivers.

And more, it is not relative to this topic: my sound card don't work microphone. I'm very disappointed with Intel.
Comment 11 Gordon Jin 2007-08-13 19:57:58 UTC
I'm not seeing this problem with upstream driver.

Jack, could you try newer driver?

Wagner, did you report this problem to Ubuntu? I believe Ubuntu has validated on 965. 
Comment 12 Wagner Macedo 2007-08-25 15:43:59 UTC
> Wagner, did you report this problem to Ubuntu? I believe Ubuntu has validated
> on 965. 
>
I tested with Ubuntu Feisty, then Gutsy Tribe 5 arrive in August, 23, so I tested too and I have the same result. So, I report today to Ubuntu.

But if you can test, It's easy to reproduce in Ubuntu (could be Live Tribe 5). In the screensaver preferences, try Endgame, just need less than 5 minutes to crash.
Comment 13 Gordon Jin 2007-08-25 19:03:54 UTC
Wagner, the original reporter says it happens for "any GL application". Are you also in this status? e.g. running "glxgears" will also crash?
Comment 14 Wagner Macedo 2007-08-27 08:07:21 UTC
(In reply to comment #13)
> Wagner, the original reporter says it happens for "any GL application". Are you
> also in this status? e.g. running "glxgears" will also crash?
> 

Thinking about, Gordon, I'm not in this status. Here it happens for some GL applications, not for "any". I run glxgears and don't crash.

Sorry for the inconvenience.

What should I do now? Report a new bug?
Comment 15 Gordon Jin 2007-08-27 18:22:36 UTC
Yes, Wagner, please open a new bug.
Comment 16 Gordon Jin 2007-08-27 18:26:06 UTC
I'm closing as I can't reproduce it and no feedback from the original reporter for long time.

Jack, please reopen if you can reproduce it with the latest driver.
Comment 17 Jack Lloyd 2007-08-27 18:51:04 UTC
I can confirm as fixed with kernel 2.6.22.1, xf86-video-intel 2.1.1, mesa 7.0.1, xorg-server 1.3.0

At first glance, things seem stable and reasonably fast. Thanks for your efforts.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.