Bug 93179 - Dependency on autoconf-archive
Summary: Dependency on autoconf-archive
Status: RESOLVED FIXED
Alias: None
Product: PackageKit
Classification: Unclassified
Component: General (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Richard Hughes
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-11-30 19:52 UTC by Emmanuele Bassi (:ebassi)
Modified: 2015-12-22 15:49 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Emmanuele Bassi (:ebassi) 2015-11-30 19:52:01 UTC
Since commit f7b41b0e89faec60f06d31efb895f885a562b4b7, PackageKit added a dependency on the AX_CXX_COMPILE_STDCXX_11 m4 macro, which is part of the autoconf-archive. This has made autobuilders like gnome-continuous, or build environments like jhbuild, sad.

It would be great if the macro could be copied in tree, while we figure out a way to include autoconf-archive in those build systems.
Comment 1 Emmanuele Bassi (:ebassi) 2015-11-30 19:53:12 UTC
In the meantime, I've tagged PackageKit in gnome-continuous; once the issue is solved, this commit:

  https://git.gnome.org/browse/gnome-continuous/commit/?id=5583f373363e2db6cb49a2950fab4057f02b3339

should be reverted.
Comment 2 Kalev Lember 2015-11-30 22:08:25 UTC
https://github.com/desrt/m4-common/pull/3 should fix it by making the macro available in gnome-continuous.
Comment 3 Emmanuele Bassi (:ebassi) 2015-12-11 17:11:33 UTC
Ryan wanted to move m4-common to git.gnome.org to avoid blocking on this kind of issues, so I guess this is a good place as any to do that.
Comment 4 Javier Jardón 2015-12-22 15:49:23 UTC
m4-common has been moved to git.gnome.org and the required macro is now part of it; I've untagged PackageKit now


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.