Bug 9326 - Rendering errors with Clearlooks theme engine
Summary: Rendering errors with Clearlooks theme engine
Status: RESOLVED INVALID
Alias: None
Product: cairo
Classification: Unclassified
Component: xlib backend (show other bugs)
Version: 1.3.6
Hardware: x86 (IA32) Linux (All)
: high normal
Assignee: Carl Worth
QA Contact: cairo-bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-12-13 04:31 UTC by Ross Burton
Modified: 2008-10-14 16:20 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Screenshot (22.91 KB, image/png)
2006-12-13 04:33 UTC, Ross Burton
Details

Description Ross Burton 2006-12-13 04:31:43 UTC
I just upgraded our OpenEmbedded based distribution to Cairo 1.3.6 and GTK+
2.10, and saw some interesting rendering errors.  Attaching a PNG.
Comment 1 Ross Burton 2006-12-13 04:33:15 UTC
Created attachment 8088 [details]
Screenshot

1) the highlighted selection on the label on the upper right diagonally chops
the text
2) the underlines on the buttons extend too far to the left

Feel free to insult me if these are likely bugs in Clearlooks... :)
Comment 2 Ross Burton 2006-12-13 04:40:02 UTC
It has come to my attention that the areas with rendering problems are not
rendered by this theme engine, so this is being exposed with GTK+ 2.10.6.

The system is a Sharp Zaurus, which is ARM based.
Comment 3 Carl Worth 2006-12-13 09:25:18 UTC
(In reply to comment #2)
> It has come to my attention that the areas with rendering problems are not
> rendered by this theme engine, so this is being exposed with GTK+ 2.10.6.

Do you know what code _is_ rendering these?

This looks like a pair of nasty little bugs that I'd like to fix right away in
cairo. The best thing to help us do that would be to extract a minimal example
that reproduces the bug, (say a little code snippet and the correct input values
needed to trigger the bug).

Have you found the code of interest here and could you point us to it?

Thanks,

-Carl
Comment 4 Chris Wilson 2008-10-14 16:20:46 UTC
It's unclear as to the cause of the rendering artifacts - the bugs could be anywhere in the rendering stack, with the most likely suspects cairo and the theme. Without a test case or feedback in the two years and 3 major releases since the initial report, it's impossible to confirm whether the bug still exists.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.