Bug 93302 - Error about non-existing command starting with a period hidden by PackageKit
Summary: Error about non-existing command starting with a period hidden by PackageKit
Status: RESOLVED NOTABUG
Alias: None
Product: PackageKit
Classification: Unclassified
Component: General (show other bugs)
Version: unspecified
Hardware: Other Linux (All)
: medium normal
Assignee: Richard Hughes
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-12-09 09:19 UTC by Albert ARIBAUD (3ADEV)
Modified: 2018-08-21 15:53 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Albert ARIBAUD (3ADEV) 2015-12-09 09:19:12 UTC
On a Fedora 21 system under Bash, trying to execute a non-existing command starting with a period results in a return to the prompt without any error message:

$ .thisfiledoesnotexist
$ 

More specifically, it silently returns to the prompt with a failure code:

$ if .thisfiledoesnotexist ; then echo OK; else echo KO; fi
KO
$

Under bash --norc, the same command fails properly:

$ bash --norc
bash-4.3$ .thisfiledoesnotexist
bash: .thisfiledoesnotexist: command not found
bash-4.3$ exit
exit
$

The cause can be narrowed down to PackageKit:

$ bash --norc
bash-4.3$ .thisfiledoesnotexist
bash: .thisfiledoesnotexist: command not found
bash-4.3$ source /etc/profile.d/PackageKit.sh 
bash-4.3$ .thisfiledoesnotexist
bash-4.3$ exit
exit
$
Comment 1 Richard Hughes 2018-08-21 15:53:03 UTC
We moved the upstream bugtracker to GitHub a long time ago. If this issue still affects you please re-create the issue here: https://github.com/hughsie/PackageKit/issues
 
Sorry for the impersonal message, and fingers crossed your issue no longer happens. Thanks.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.