Bug 9415 - [965] lockup playing torcs
Summary: [965] lockup playing torcs
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: medium critical
Assignee: Zou Nan hai
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords: NEEDINFO
Depends on:
Blocks:
 
Reported: 2006-12-21 07:45 UTC by Sami Farin
Modified: 2008-02-13 23:23 UTC (History)
9 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sami Farin 2006-12-21 07:45:00 UTC
Using GLX programs quickly results into server lockup,
for example with torcs:

Error in I830WaitLpRing(), now is -1530087407, start is -1530089408
pgetbl_ctl: 0x3ef80001 pgetbl_err: 0x40000
ipeir: 0 iphdr: 0
LP ring tail: 147f8 head: 10c40 len: 1f001 start 0
eir: 0 esr: 11 emr: ffdf
instdone: 0 instpm: 0
memmode: 0 instps: 0
hwstam: dffe ier: 82 imr: 0 iir: 0
space: 115776 wanted 131064
(II) I810(0): [drm] removed 1 reserved context for kernel
(II) I810(0): [drm] unmapping 8192 bytes of SAREA 0xf8d2c000 at 0xb7f32000

Fatal server error:
lockup

...

this is what I got when I tried to restart...
but it failed and I had to reboot to recover.

ask for the logs if you need them.

I have today's i810 modesetting drivers.

(II) I810(0): [drm] removed 1 reserved context for kernel
(II) I810(0): [drm] unmapping 8192 bytes of SAREA 0xf8d2c000 at 0xb7fe9000
Error in I830WaitLpRing(), now is -1529983671, start is -1529985672
pgetbl_ctl: 0x3ef80001 pgetbl_err: 0x40000
ipeir: 0 iphdr: 0
LP ring tail: 18 head: 0 len: 1f001 start 0
eir: 0 esr: 11 emr: ffdf
instdone: 0 instpm: 0
memmode: 0 instps: 0
hwstam: dfff ier: 0 imr: dfff iir: 0
space: 131040 wanted 131064

Fatal server error:
lockup


Backtrace:
0: X(xf86SigHandler+0x85) [0x80c2afd]

FatalError re-entered, aborting
Caught signal 11.  Server aborting
Comment 1 Eric Anholt 2007-01-11 12:57:23 UTC
OK, I've reproduced this with torcs, about 30 seconds in.
Comment 2 Daniel Stone 2007-02-27 01:35:17 UTC
Sorry about the phenomenal bug spam, guys.  Adding xorg-team@ to the QA contact so bugs don't get lost in future.
Comment 3 Gordon Jin 2007-03-14 19:42:56 UTC
The bug priority was upgraded (P2->high) with the bugzilla configuration change.
I'm Changing the priority back to the normal one.
Sorry for the spam.
Comment 4 Christian Henz 2007-04-03 04:05:52 UTC
Any news on this? I may have a similar problem (#10506)
Comment 5 Paolo Ornati 2007-04-14 02:17:41 UTC
I'm having this problem too and I've also noticed a message from the kernel:

[drm:i915_wait_irq] *ERROR* i915_wait_irq: EBUSY -- rec: 1082162 emitted: 1082676

This is with a 2.6.21-rc6-gd791d413.

Xorg log:
Error in I830WaitLpRing(), now is -279590193, start is -279592194
pgetbl_ctl: 0x3ef80001 pgetbl_err: 0x0
ipeir: 0 iphdr: 0
LP ring tail: 48 head: 0 len: 1f001 start 0
eir: 0 esr: 1 emr: ffdf
instdone: 0 instpm: 0
memmode: 0 instps: 0
hwstam: dffe ier: 82 imr: 0 iir: 20
space: 130992 wanted 131064
(II) I810(0): [drm] removed 1 reserved context for kernel
(II) I810(0): [drm] unmapping 8192 bytes of SAREA 0x1efff000 at 0x2b0862876000

Fatal server error:
lockup

Error in I830WaitLpRing(), now is -279587190, start is -279589191
pgetbl_ctl: 0x3ef80001 pgetbl_err: 0x0
ipeir: 0 iphdr: 0
LP ring tail: 50 head: 0 len: 1f001 start 0
eir: 0 esr: 1 emr: ffdf
instdone: 0 instpm: 0
memmode: 0 instps: 0
hwstam: dfff ier: 0 imr: dfff iir: 20
space: 130984 wanted 131064

FatalError re-entered, aborting
lockup
Comment 6 Lieven Buts 2007-05-21 07:41:19 UTC
I am getting the same error message on a Dell OptiPlex 745 system 
with dual Pentium D processors and Intel 965Q on-board graphics. The
X server freezes completely at unpredictable times while running 
software-based or hardware-accelerated OpenGL applications. I can
still log in via SSH and reboot, though.

Running git sources (21-May-2007) for the X.org server, xf86-video-intel 
driver (modesetting branch), Mesa, libdrm, i915_drm.so and the 915 and drm
kernel modules on an x86_64 mixed 32/64-bit OpenSuSE 10.2 system
with Novell-patched 2.6.18.8 or vanilla 2.6.21.1 kernels.

Problem may be related to trouble with switching virtual terminals.

Full log file and xorg.conf at 
http://ultr23.vub.ac.be/~lieven/965/Xorg.0.log-3
http://ultr23.vub.ac.be/~lieven/965/xorg.conf-1
Comment 7 Lieven Buts 2007-05-23 08:50:43 UTC
Updated xf86-video-intel to git sources on 23-May-2007. Still freezes
after a while, but with a different error message:
------------------------------------------------------------
Error in I830WaitLpRing(), timeout for 2 seconds
pgetbl_ctl: 0x3ff80001 pgetbl_err: 0x0
ipeir: 0 iphdr: 80200004
LP ring tail: e9b0 head: 4028 len: 1f001 start 0
Err ID (eir): 0 Err Status (esr): 1 Err Mask (emr): ffffffdf
instdone: ffe5fafd instdone_1: fffff
instpm: 0
memmode: 0 instps: 8001e022
HW Status mask (hwstam): fffecffe
IRQ enable (ier): 82 imr: fffe0000 iir: 1040
acthd: 1000ce08 dma_fadd_p: 1000cf00
ecoskpd: 307 excc: 0
cache_mode: 6800/180
mi_arb_state: 44
IA_VERTICES_COUNT_QW 0/0
IA_PRIMITIVES_COUNT_QW 0/0
VS_INVOCATION_COUNT_QW 0/0
GS_INVOCATION_COUNT_QW 0/0
GS_PRIMITIVES_COUNT_QW 0/0
CL_INVOCATION_COUNT_QW 0/0
CL_PRIMITIVES_COUNT_QW 0/0
PS_INVOCATION_COUNT_QW 0/0
PS_DEPTH_COUNT_QW 0/0
WIZ_CTL 0
TS_CTL 0  TS_DEBUG_DATA fdd3f7dd
TD_CTL 0 / 0
space: 87664 wanted 131064

FatalError re-entered, aborting
lockup
------------------------------------------------------------
Comment 8 Paolo Ornati 2007-05-23 09:09:18 UTC
(In reply to comment #7)
> Updated xf86-video-intel to git sources on 23-May-2007. Still freezes
> after a while, but with a different error message:

just a note: the different error message is due to commit "8db28aeaa6e908017b40bd9180f144a2972f6278": Fix ring debug code

[...]
-	 ErrorF("Error in I830WaitLpRing(), now is %d, start is %d\n", now,
-		start);
-	 i830_dump_error_state(pScrn);
+	 ErrorF("Error in I830WaitLpRing(), timeout for %d seconds\n",
+		timeout_millis/1000);
+	 if (IS_I965G(pI830))
+	     i965_dump_error_state(pScrn);
+	 else
+	     i830_dump_error_state(pScrn);
[...]


I hope that this new message helps debugging.
Comment 9 Wei Tang 2007-05-27 20:13:39 UTC
xserver: <6a870992d81a6bacfa9d313c15784fdb281d474f>
xf86_video_intel: <ff8c8cb869a3c780dbd826f7c94f06e4f3fda6af>
mesa <1fc08251eece0cd1d859592ab03e775e971dca63>

On our q965 test machine, we got the following error log:
[root@x-q965 ~]# torcs -d
GNU gdb Red Hat Linux (6.3.0.0-1.122rh)
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux-gnu"...Using host libthread_db library "/lib/libthread_db.so.1".

(gdb) Starting program: /usr/local/lib/torcs/torcs-bin -l /root/.torcs -L /usr/local/lib/torcs -D /usr/local/share/games/torcs
Reading symbols from shared object read from target memory...done.
Loaded system supplied DSO at 0xffffe000
[Thread debugging using libthread_db enabled]
[New Thread -1215838544 (LWP 12854)]
Visual Properties Report
------------------------
Compatibility mode, properties unknown.
libGL warning: 3D driver claims to not support visual 0x79
WARNING: ssgLoadTexture: Cannot determine file type for './(null)'
GfParmCheckHandle: parameter "Front Wing/angle" out of bounds: min:0 max:0.20944 val:0.261799 in ("NASCAR RWD" - "drivers/lliaw/tracksdata/car_g-track-3.xml")
GfParmCheckHandle: parameter "Rear Right Suspension/packers" out of bounds: min:0 max:0.01 val:0.02 in ("Tanhoj" - "drivers/tanhoj/tracksdata/car_g-track-3.xml")
GfParmCheckHandle: parameter "Rear Left Suspension/packers" out of bounds: min:0 max:0.01 val:0.02 in ("Tanhoj" - "drivers/tanhoj/tracksdata/car_g-track-3.xml")
GfParmCheckHandle: parameter "Front Wing/angle" out of bounds: min:0 max:0.20944 val:0.523599 in ("Tanhoj" - "drivers/tita/tracksdata/car_g-track-3.xml")
open /dev/[sound/]dsp: No such file or directory
terminate called after throwing an instance of 'char const*'

Program received signal SIGABRT, Aborted.
[Switching to Thread -1215838544 (LWP 12854)]
0xffffe410 in __kernel_vsyscall ()
(gdb) #0  0xffffe410 in __kernel_vsyscall ()
#1  0x4694c159 in raise () from /lib/libc.so.6
#2  0x4694d6e3 in abort () from /lib/libc.so.6
#3  0x46de2550 in __gnu_cxx::__verbose_terminate_handler () from /usr/lib/libstdc++.so.6
#4  0x46ddff75 in std::set_unexpected () from /usr/lib/libstdc++.so.6
#5  0x46ddffb2 in std::terminate () from /usr/lib/libstdc++.so.6
#6  0x46de00ea in __cxa_throw () from /usr/lib/libstdc++.so.6
#7  0xb40779d1 in OpenalSoundInterface (this=0x9544810, sampling_rate=44100, n_channels=32) at OpenalSoundInterface.cpp:49
#8  0xb4078081 in grInitSound (s=0x86cdeb0, ncars=5) at grsound.cpp:75
#9  0xb40485d8 in initCars (s=0x86cdeb0) at grmain.cpp:396
#10 0xb7f699a6 in reRaceRealStart () at racemain.cpp:260
#11 0xb7f6b29a in ReStateManage () at racestate.cpp:90
#12 0xb7f6887c in ReStartNewRace () at raceinit.cpp:136
#13 0xb7f9ef81 in gfuiButtonAction (action=1) at guibutton.cpp:577
#14 0xb7f9e1bd in gfuiMouseAction (vaction=0x1) at guiobject.cpp:458
#15 0xb7f9c75b in gfuiMouse (button=0, state=1, x=336, y=86) at gui.cpp:405
#16 0xb7b6492a in processEventsAndTimeouts () at glut_event.c:468
#17 0xb7b64fd3 in glutMainLoop () at glut_event.c:959
#18 0x08048dfb in main (argc=7, argv=0xbfdade44) at main.cpp:110
Comment 10 Eric Anholt 2007-05-29 15:01:12 UTC
Wei Tang: Please report different bugs in separate reports, with the appropriate projects (in your case, OpenAL).
Comment 11 Wei Tang 2007-05-29 19:34:33 UTC
The phenomenon described in comment#9 was caused by incompatible sound driver.
I have fixed the issue. Then I reproduced the bug.

[root@x-q965 ~]# torcs -d
GNU gdb Red Hat Linux (6.3.0.0-1.122rh)
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux-gnu"...Using host libthread_db library "/lib/libthread_db.so.1".

(gdb) Starting program: /usr/local/lib/torcs/torcs-bin -l /root/.torcs -L /usr/local/lib/torcs -D /usr/local/share/games/torcs
Reading symbols from shared object read from target memory...done.
Loaded system supplied DSO at 0xffffe000
[Thread debugging using libthread_db enabled]
[New Thread -1215912272 (LWP 3275)]
Visual Properties Report
------------------------
Compatibility mode, properties unknown.
libGL warning: 3D driver claims to not support visual 0x5b
WARNING: ssgLoadTexture: Cannot determine file type for './(null)'
GfParmCheckHandle: parameter "Front Wing/angle" out of bounds: min:0 max:0.20944 val:0.261799 in ("NASCAR RWD" - "drivers/lliaw/tracksdata/car_g-track-3.xml")
GfParmCheckHandle: parameter "Rear Right Suspension/packers" out of bounds: min:0 max:0.01 val:0.02 in ("Tanhoj" - "drivers/tanhoj/tracksdata/car_g-track-3.xml")
GfParmCheckHandle: parameter "Rear Left Suspension/packers" out of bounds: min:0 max:0.01 val:0.02 in ("Tanhoj" - "drivers/tanhoj/tracksdata/car_g-track-3.xml")
GfParmCheckHandle: parameter "Front Wing/angle" out of bounds: min:0 max:0.20944 val:0.523599 in ("Tanhoj" - "drivers/tita/tracksdata/car_g-track-3.xml")
[New Thread -1301910624 (LWP 3278)]
OpenAL backend info:
  Vendor: OpenAL Community
  Renderer: Software
  Version: 1.1
  Available sources: 1024 or more
  Available buffers: 1024 or more
  Dynamic Sources: requested: 1003, created: 1003
  #static sources: 21
  #dyn sources   : 1003
intelWaitIrq: drmI830IrqWait: -16

Program exited with code 01.
(gdb) No stack.
(gdb) [root@x-q965 ~]# Error in I830WaitLpRing(), timeout for 2 seconds
pgetbl_ctl: 0x3ff80001 pgetbl_err: 0x0
ipeir: 0 iphdr: 60020100
LP ring tail: 74d0 head: 1f590 len: 1f001 start 0
Err ID (eir): 0 Err Status (esr): 1 Err Mask (emr): ffffffdf
instdone: ffe5fafd instdone_1: fffd3
instpm: 0
memmode: 0 instps: 409f02e
HW Status mask (hwstam): fffedfff
IRQ enable (ier): 0 imr: fffedfff iir: c0
acthd: 1488488 dma_fadd_p: 1488488
ecoskpd: 307 excc: 0
cache_mode: 6800/180
mi_arb_state: 44
IA_VERTICES_COUNT_QW 0/0
IA_PRIMITIVES_COUNT_QW 0/0
VS_INVOCATION_COUNT_QW 0/0
GS_INVOCATION_COUNT_QW 0/0
GS_PRIMITIVES_COUNT_QW 0/0
CL_INVOCATION_COUNT_QW 0/0
CL_PRIMITIVES_COUNT_QW 0/0
PS_INVOCATION_COUNT_QW 0/0
PS_DEPTH_COUNT_QW 0/0
WIZ_CTL 0
TS_CTL 0  TS_DEBUG_DATA 74bfcc58
TD_CTL 0 / 0
space: 98488 wanted 131064

Fatal server error:
lockup


Backtrace:
0: X(xf86SigHandler+0x7e) [0x80b1f3e]
1: [0xffffe420]
2: X(AbortDDX+0x85) [0x809f865]
3: X(AbortServer+0x28) [0x81afe38]
4: X(FatalError+0x66) [0x81b0346]
5: /opt/X11R7/lib/xorg/modules/drivers//i810_drv.so(I830WaitLpRing+0x15b) [0xb7d4ef5b]
6: /opt/X11R7/lib/xorg/modules/drivers//i810_drv.so(I830Sync+0xfd) [0xb7d4f19d]
7: /opt/X11R7/lib/xorg/modules/drivers//i810_drv.so [0xb7d567f7]
8: /opt/X11R7/lib/xorg/modules/drivers//i810_drv.so [0xb7d56900]
9: /opt/X11R7/lib/xorg/modules/drivers//i810_drv.so [0xb7d56d03]
10: X [0x81590f7]
11: X [0x80ce5c9]
12: X [0x8132bf8]
13: X [0x81569ab]
14: X [0x80f76c5]
15: X(main+0x51c) [0x806d5ac]
16: /lib/libc.so.6(__libc_start_main+0xdc) [0x469397e4]
17: X(FontFileCompleteXLFD+0xa5) [0x806c851]

FatalError re-entered, aborting
Caught signal 11.  Server aborting
Comment 12 haihao 2007-08-28 19:38:27 UTC
fixed in git. mesa commit 410d8f7cdb40889e66f5c6794878ad9a5f572ee7.  
(Frankly it still crashes X occasionally, but I can't reproduce it. Anyway now you can enjoy this game and I mark this bug as fixed. Open a new bug/reopen it if you can reproduce it) 
Comment 13 Sami Farin 2007-09-18 17:06:04 UTC
I upgraded Xorg and kernel to 64bit (x86_64).
Seems like something is not compatible with 32bit mode apps.

simple ones like glxgears work.

starting 32bit torcs and 64bit these...:
xorg-server-1.3.99.0-269-g547ad21
xf86-video-intel-2.1.0-88-gbda3c69
mesa_6_5_3-712-ge21d2c6

tossed event which came in late
mieqEnequeue: out-of-order valuator event; dropping.

this goes for thosands of lines.

when I try to restart Xorg:


AUDIT: Wed Sep 19 01:46:31 2007: 28618 X: client 1 connected from local host (uid 500, gid 509)
AUDIT: Wed Sep 19 01:46:31 2007: 28618 X: client 2 connected from local host (uid 500, gid 509)
AUDIT: Wed Sep 19 01:46:31 2007: 28618 X: client 2 disconnected
AUDIT: Wed Sep 19 01:46:31 2007: 28618 X: client 2 connected from local host (uid 500, gid 509)
AUDIT: Wed Sep 19 01:46:31 2007: 28618 X: client 3 connected from local host (uid 500, gid 509)
AUDIT: Wed Sep 19 01:46:31 2007: 28618 X: client 4 connected from local host (uid 500, gid 509)
AUDIT: Wed Sep 19 01:46:31 2007: 28618 X: client 5 connected from local host (uid 500, gid 509)
AUDIT: Wed Sep 19 01:46:31 2007: 28618 X: client 6 connected from local host (uid 500, gid 509)
AUDIT: Wed Sep 19 01:46:31 2007: 28618 X: client 6 disconnected
AUDIT: Wed Sep 19 01:46:31 2007: 28618 X: client 6 connected from local host (uid 500, gid 509)
Error in I830WaitLpRing(), timeout for 2 seconds
pgetbl_ctl: 0x3ef80001 pgetbl_err: 0x0
ipeir: 0 iphdr: 60020100
LP ring tail: b20 head: 0 len: 1f001 start 0
Err ID (eir): 0 Err Status (esr): 1 Err Mask (emr): ffffffdf
instdone: ff65fafd instdone_1: fffd9
instpm: 0
memmode: 0 instps: 401f02e
HW Status mask (hwstam): fffedffe
IRQ enable (ier): 2 imr: fffe0000 iir: 80
acthd: 26c4320 dma_fadd_p: 26c4320
ecoskpd: 307 excc: 0
cache_mode: 6800/180
mi_arb_state: 44
IA_VERTICES_COUNT_QW 0/0
IA_PRIMITIVES_COUNT_QW 0/0
VS_INVOCATION_COUNT_QW 0/0
GS_INVOCATION_COUNT_QW 0/0
GS_PRIMITIVES_COUNT_QW 0/0
CL_INVOCATION_COUNT_QW 0/0
CL_PRIMITIVES_COUNT_QW 1/0
PS_INVOCATION_COUNT_QW b0/0
PS_DEPTH_COUNT_QW f0e/0
WIZ_CTL 0
TS_CTL 0  TS_DEBUG_DATA 3cdfff81
TD_CTL 0 / 0
space: 128216 wanted 131064
(II) intel(0): [drm] removed 1 reserved context for kernel
(II) intel(0): [drm] unmapping 8192 bytes of SAREA 0x1efff000 at 0x7fe0d3e02000
(II) intel(0): [drm] Closed DRM master.

Fatal server error:
lockup

(II) Habu-usb-0000:00:1d.1-1/input1: Off
(II) UnloadModule: "evdev"
(II) Habu-usb-0000:00:1d.1-1/input0: Off
(II) UnloadModule: "evdev"
(II) AIGLX: Suspending AIGLX clients for VT switch
Error in I830WaitLpRing(), timeout for 2 seconds
pgetbl_ctl: 0x3ef80001 pgetbl_err: 0x0
ipeir: 0 iphdr: 60020100
LP ring tail: b28 head: 0 len: 1f001 start 0
Err ID (eir): 0 Err Status (esr): 1 Err Mask (emr): ffffffdf
instdone: ff65fafd instdone_1: fffd9
instpm: 0
memmode: 0 instps: 401f02e
HW Status mask (hwstam): fffedffe
IRQ enable (ier): 2 imr: fffe0000 iir: 80
acthd: 26c4320 dma_fadd_p: 26c4320
ecoskpd: 307 excc: 0
cache_mode: 6800/180
mi_arb_state: 44
IA_VERTICES_COUNT_QW 0/0
IA_PRIMITIVES_COUNT_QW 0/0
VS_INVOCATION_COUNT_QW 0/0
GS_INVOCATION_COUNT_QW 0/0
GS_PRIMITIVES_COUNT_QW 0/0
CL_INVOCATION_COUNT_QW 0/0
CL_PRIMITIVES_COUNT_QW 1/0
PS_INVOCATION_COUNT_QW b0/0
PS_DEPTH_COUNT_QW f0e/0
WIZ_CTL 0
TS_CTL 0  TS_DEBUG_DATA 3cdfff81
TD_CTL 0 / 0
space: 128208 wanted 131064

FatalError re-entered, aborting
lockup


Comment 14 haihao 2007-09-18 17:51:06 UTC
(In reply to comment #13)
> I upgraded Xorg and kernel to 64bit (x86_64).
> Seems like something is not compatible with 32bit mode apps.
> 
> simple ones like glxgears work.
> 
> starting 32bit torcs and 64bit these...:
> xorg-server-1.3.99.0-269-g547ad21
> xf86-video-intel-2.1.0-88-gbda3c69
> mesa_6_5_3-712-ge21d2c6

Is your mesa from mesa-git?
Comment 15 Sami Farin 2007-09-18 17:57:17 UTC
(In reply to comment #14)
> Is your mesa from mesa-git?

Yes.  I even added -fno-strict-aliasing to ARCH_FLAGS to work around your broken i965 code.
Comment 16 haihao 2007-09-18 18:29:21 UTC
(In reply to comment #15)
> (In reply to comment #14)
> > Is your mesa from mesa-git?
> 
> Yes.  I even added -fno-strict-aliasing to ARCH_FLAGS to work around your
> broken i965 code.
Is your drm module also from git? BTW why your mesa is 6_5_3?

Comment 17 Sami Farin 2007-09-19 03:58:45 UTC
(In reply to comment #16)
> > > Is your mesa from mesa-git?
> > 
> > Yes.  I even added -fno-strict-aliasing to ARCH_FLAGS to work around your
> > broken i965 code.
> Is your drm module also from git? BTW why your mesa is 6_5_3?
 
libdrm is v2.3.0 compiled by Redhat.
Are there some changes in drm since v2.3.0?
I now installed git version of drm..

I don't know why "git describe" says 6_5_3, glxinfo says

OpenGL renderer string: Mesa DRI Intel(R) 965Q 4.1.3002
OpenGL version string: 1.4 Mesa 7.1
Comment 18 Sami Farin 2007-09-19 08:40:34 UTC
I take back my previous comment.
Two glxgears is too much.

I tried with latest git libdrm, two glxgears resulted into pink screen.
I could exit Xorg and restart again, but it was all pink.
During reboot I got segfaults in quotaoff etc., so I'd guess xorg/dri/drm/glx/whatever wrote into wrong locations.

Also, I do not like the casting of void* (8 bytes) to int (4 bytes)
in libdrm (drm_handle_t).  Is it always true on Linux that
max value of drm_handle_t is 0xffffffff ?
If yes, please add comment(s).

(II) intel(0): [drm] removed 1 reserved context for kernel
(II) intel(0): [drm] unmapping 8192 bytes of SAREA 0x2efff000 at 0x7f0bdfc30000
(II) intel(0): [drm] Closed DRM master.
(EE) intel(0): I830 Vblank Pipe Setup Failed 0
(EE) intel(0): I830 Vblank Pipe Setup Failed 0
(EE) intel(0): I830 Vblank Pipe Setup Failed 0
Comment 19 Paolo Ornati 2007-09-20 04:05:01 UTC
(In reply to comment #18)
> 
> I tried with latest git libdrm, two glxgears resulted into pink screen.
> I could exit Xorg and restart again, but it was all pink.
> During reboot I got segfaults in quotaoff etc., so I'd guess
> xorg/dri/drm/glx/whatever wrote into wrong locations.
> 

[OT?] I'm suffering of sporadic ext3 FS corruption (RAM seems to be good
according to memtest86+) and it seems to go away by just disabling dri
(commenting Load "dri" in xorg.conf).

What component (dri/drm...) can potentially cause this?

I'm using "stable" versions, currently (Gentoo):
media-libs/mesa-6.5.2-r1
x11-drivers/xf86-video-i810-2.1.1
x11-base/xorg-x11-7.2

and an up to date kernel (currently an almost 2.6.23-rc7 git snapshot).

I'm on x86-64 (core2 duo) / integrated graphic (G965 Express chipset).
Comment 20 haihao 2007-09-21 00:08:10 UTC
(In reply to comment #18)
> I take back my previous comment.
> Two glxgears is too much.
> 
> I tried with latest git libdrm, two glxgears resulted into pink screen.
> I could exit Xorg and restart again, but it was all pink.
I can't reprodue it. All components are from git.
Comment 21 Sami Farin 2007-09-21 15:30:17 UTC
two or three glxgears worked in beginning of September on IA-32 arch,
and torcs was smooth and nice, but now on x86_64 and latest *.* ,
parts of the scenery and cars flicker (i.e., contain holes, parts of cars disappear),
and as a bonus I get several of these a second:
torcs refresh: ssgCullAndDraw invalid operation
And sometimes screen redraw rate goes to 1fps.

Does profile look normal?
24.4% of CPU time in copy_array_to_vbo_array
(in copy_strided_array, copying one byte at a time)?

CPU: P4 / Xeon, speed 2797.2 MHz (estimated)
Counted GLOBAL_POWER_EVENTS events (time during which processor is not stopped) with a unit mask of 0x01 (mandatory) count 45000
Counted FSB_DATA_ACTIVITY events (DRDY or DBSY events on the front side bus) with a unit mask of 0x03 (multiple flags) count 45000
Counted BRANCH_RETIRED events (retired branches) with a unit mask of 0x05 (multiple flags) count 45000
Counted BRANCH_RETIRED events (retired branches) with a unit mask of 0x0a (multiple flags) count 45000
samples  %        samples  %        samples  %        samples  %        image name               app name                 symbol name
631314   24.4567  11060    37.4953  8913      6.4173  100       2.7886  i965_dri.so              i965_dri.so              copy_array_to_vbo_array
173498    6.7212  308       1.0442  26959    19.4102  14        0.3904  libglx.so                libglx.so                get_decode_index
107269    4.1555  470       1.5934  6467      4.6562  11        0.3067  libc-2.6.90.so           libc-2.6.90.so           memcpy
79422     3.0768  245       0.8306  7419      5.3416  316       8.8120  libGL.so.1.2             libGL.so.1.2             emit_element_none
73639     2.8527  929       3.1495  1406      1.0123  6         0.1673  libpthread-2.6.90.so     libpthread-2.6.90.so     pthread_mutex_lock
50917     1.9725  135       0.4577  3056      2.2003  10        0.2789  libc-2.6.90.so           libc-2.6.90.so           memset
47249     1.8304  2518      8.5365  597       0.4298  19        0.5298  vmlinux                  vmlinux                  copy_user_generic_unrolled
44893     1.7391  713       2.4172  582       0.4190  30        0.8366  libc-2.6.90.so           libc-2.6.90.so           memcpy
41295     1.5997  202       0.6848  915       0.6588  7         0.1952  libopenal.so.0.0.0       libopenal.so.0.0.0       alf_tpitch
40253     1.5594  429       1.4544  4813      3.4653  90        2.5098  oprofiled                oprofiled                (no symbols)
32855     1.2728  10        0.0339  897       0.6458  3         0.0837  libm-2.6.90.so           libm-2.6.90.so           atan2
32592     1.2626  99        0.3356  2076      1.4947  260       7.2504  libglx.so                libglx.so                DoRender
31465     1.2189  191       0.6475  520       0.3744  16        0.4462  i965_dri.so              i965_dri.so              brw_search_cache
30669     1.1881  19        0.0644  967       0.6962  0              0  libm-2.6.90.so           libm-2.6.90.so           sinf
26685     1.0338  7         0.0237  544       0.3917  4         0.1115  libm-2.6.90.so           libm-2.6.90.so           cosf
24314     0.9419  1593      5.4005  748       0.5386  33        0.9202  libc-2.6.90.so           libc-2.6.90.so           memset
19192     0.7435  47        0.1593  1719      1.2377  1         0.0279  libpthread-2.6.90.so     libpthread-2.6.90.so     __pthread_mutex_unlock_usercnt
17452     0.6761  15        0.0509  873       0.6286  39        1.0876  librobottools.so         librobottools.so         RtTrackGlobal2Local(trackSeg*, float, float, tTrkLocPos*, int)
16804     0.6510  313       1.0611  69        0.0497  0              0  libpixman-1.so.0.9.5     libpixman-1.so.0.9.5     pixman_fill_mmx
16412     0.6358  12        0.0407  4031      2.9023  186       5.1868  libGL.so.1.2             libGL.so.1.2             get_array_entry
16351     0.6334  79        0.2678  353       0.2542  26        0.7250  i965_dri.so              i965_dri.so              brw_cached_batch_struct
15772     0.6110  32        0.1085  2516      1.8115  8         0.2231  libglx.so                libglx.so                __glXGetProtocolSizeData
15075     0.5840  91        0.3085  51        0.0367  0              0  vmlinux                  vmlinux                  read_hpet
15015     0.5817  21        0.0712  3550      2.5560  80        2.2309  i965_dri.so              i965_dri.so              vbo_exec_fixup_vertex
14804     0.5735  41        0.1390  1573      1.1325  10        0.2789  i965_dri.so              i965_dri.so              vbo_Vertex3fv
12946     0.5015  7         0.0237  250       0.1800  2         0.0558  libm-2.6.90.so           libm-2.6.90.so           sin
11758     0.4555  26        0.0881  687       0.4946  52        1.4501  i965_dri.so              i965_dri.so              brw_upload_vertices
11667     0.4520  40        0.1356  533       0.3838  17        0.4741  i965_dri.so              i965_dri.so              _mesa_UpdateTexEnvProgram
11331     0.4390  54        0.1831  325       0.2340  3         0.0837  i965_dri.so              i965_dri.so              bmBufferOffset
Comment 22 Paolo Ornati 2007-09-23 00:46:03 UTC
(In reply to comment #19)
> 
> [OT?] I'm suffering of sporadic ext3 FS corruption (RAM seems to be good
> according to memtest86+) and it seems to go away by just disabling dri
> (commenting Load "dri" in xorg.conf).
> 

I was wrong, today another "root FS fixed - reboot needed" ;)

Sorry for the noise.
Comment 23 Jesse Barnes 2007-10-31 12:25:07 UTC
Haihao, is this really a Mesa driver bug and not a 2D driver bug?  If so, please reclassify it, I'm trying to put together a bug list for the next 2D driver release and I'm not sure if this one belongs there.

Thanks,
Jesse
Comment 24 Sascha Hlusiak 2007-12-01 02:17:08 UTC
I'm suffering from occasional lockups on Intel 855gm with xf86-video-intel-2.2.0, mesa-7.0.2, libdrm-2.3.0, xorg-server-1.4. This happens when using multiple glx apps (tested with multiple glxgears) or xv apps the same time. I'm unable to recover the machine and need to coldreboot. This bug seems to be related to bug #5774 for me, which is a WONTFIX. 

Error in I830WaitLpRing(), timeout for 2 seconds
pgetbl_ctl: 0x1ffe0001 pgetbl_err: 0x0
ipeir: 0 iphdr: 7f00031d
LP ring tail: 1fe98 head: 166d0 len: 1f001 start 0
eir: 0 esr: 1 emr: ffff
instdone: ffc1 instpm: 0
memmode: 108 instps: 20
hwstam: ffff ier: a2 imr: 9 iir: 0
Ring at virtual 0xaf9d9000 head 0x166d0 tail 0x1fe98 count 9714
        00016650: 3f75e6f6
        00016654: ff00290a
        00016658: 4339c67d
        0001665c: 4343405b
        00016660: 3f772310
        00016664: ff00290a
        00016668: 4346835d
        0001666c: 435ba624
        00016670: 3f75e6f6
        00016674: ff00290a
        00016678: 433372ed
        0001667c: 434ed22c
        00016680: 3f7726d0
        00016684: ff00290a
        00016688: 4339c67d
        0001668c: 4343405b
        00016690: 3f772310
        00016694: ff00290a
        00016698: 4350f1a2
        0001669c: 434eb296
        000166a0: 3f75fbcc
        000166a4: ff00290a
        000166a8: 434d1843
        000166ac: 434fa2a0
        000166b0: 3f75e2ec
        000166b4: ff00290a
        000166b8: 433d88ea
        000166bc: 4342622a
        000166c0: 3f773a1d
        000166c4: ff00290a
        000166c8: 434d1843
        000166cc: 434fa2a0
        000166d0: 3f75e2ec
Ring end
space: 92208 wanted 131064

Fatal server error:
lockup
Comment 25 Jiri Slaby 2008-01-09 11:56:19 UTC
Occasionally happens here too (I suspect upgrade to the git version of the driver). Until I use the fedora one (xorg-x11-drv-i810-2.1.1-7.fc8), everything was OK.

ProcXCloseDevice to close or not ?
Error in I830WaitLpRing(), timeout for 2 seconds
pgetbl_ctl: 0x1 pgetbl_err: 0x0
ipeir: 0 iphdr: 54f00006
LP ring tail: 11480 head: 1137c len: 1f001 start 0
eir: 0 esr: 0 emr: ffff
instdone: fa41 instpm: 0
memmode: 306 instps: 80007806
hwstam: effe ier: 2 imr: 0 iir: 10c0
Ring at virtual 0x677ab000 head 0x1137c tail 0x11480 count 65
        000112fc: 03cc0460
        00011300: 000100f2
        00011304: 00150104
        00011308: 0207c4c0
        0001130c: 00000000
        00011310: 00000050
        00011314: 0202ff90
        00011318: 54f00006
        0001131c: 03cc0040
        00011320: 00000000
        00011324: 00010001
        00011328: 0200de70
        0001132c: 00000000
        00011330: 00000010
        00011334: 02001b40
        00011338: 54f00006
        0001133c: 03cc0040
        00011340: 00000001
        00011344: 00010002
        00011348: 0200de70
        0001134c: 00000000
        00011350: 00000040
        00011354: 0200de70
        00011358: 54f00006
        0001135c: 03cc0040
        00011360: 00000002
        00011364: 00010004
        00011368: 0200de70
        0001136c: 00000000
        00011370: 00000040
        00011374: 0200de70
        00011378: 54f00006
        0001137c: 03cc0040
Ring end
space: 130804 wanted 131064
(II) intel(0): [drm] removed 1 reserved context for kernel
(II) intel(0): [drm] unmapping 8192 bytes of SAREA 0x1efff000 at 0x7fa179ccf000
(II) intel(0): [drm] Closed DRM master.

Fatal server error:
lockup

(II) AIGLX: Suspending AIGLX clients for VT switch
Error in I830WaitLpRing(), timeout for 2 seconds
pgetbl_ctl: 0x1 pgetbl_err: 0x0
ipeir: 0 iphdr: 54f00006
LP ring tail: 11488 head: 1137c len: 1f001 start 0
eir: 0 esr: 0 emr: ffff
instdone: fa41 instpm: 0
memmode: 306 instps: 80007806
hwstam: effe ier: 2 imr: 0 iir: 10c0
Ring at virtual 0x677ab000 head 0x1137c tail 0x11488 count 67
        000112fc: 00000460
        00011300: 000000f2
        00011304: 00000104
        00011308: 0000c4c0
        0001130c: 00000000
        00011310: 00000050
        00011314: 0000ff90
        00011318: 00000006
        0001131c: 00000040
        00011320: 00000000
        00011324: 00000001
        00011328: 0000de70
        0001132c: 00000000
        00011330: 00000010
        00011334: 00001b40
        00011338: 00000006
        0001133c: 00000040
        00011340: 00000001
        00011344: 00000002
        00011348: 0000de70
        0001134c: 00000000
        00011350: 00000040
        00011354: 0000de70
        00011358: 00000006
        0001135c: 00000040
        00011360: 00000002
        00011364: 00000004
        00011368: 0000de70
        0001136c: 00000000
        00011370: 00000040
        00011374: 0000de70
        00011378: 00000006
        0001137c: 00000040
Ring end
space: 130796 wanted 131064

FatalError re-entered, aborting
lockup
Comment 26 Zou Nan hai 2008-02-13 20:54:05 UTC
Please retest on latest version of mesa and drm.
I can not reproduce it here
Comment 27 Michael Fu 2008-02-13 23:23:18 UTC
this bug has been messed up with many different-but-look-similar bug report. we've verified torcs works fine.

bug reporter/commenters, please open separate new bugs for your issue that you still can reproduce. thanks.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.