Bug 94490 - bin/bufferstorage-persistent read client-storage piglit test fails intermittently
Summary: bin/bufferstorage-persistent read client-storage piglit test fails intermitte...
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
: 95006 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-03-11 11:45 UTC by Samuel Iglesias Gonsálvez
Modified: 2019-09-25 18:56 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Samuel Iglesias Gonsálvez 2016-03-11 11:45:23 UTC
Hello,

"bufferstorage-persistent read client-storage" piglit test fails intermittently with a very low fail-to-pass ratio in Mesa master.

When running "bufferstorage-persistent read client-storage" piglit test during 20/30 minutes in an infinite loop on a Haswell laptop, I got the following error:

$ while (true); do (bin/bufferstorage-persistent read client-storage -auto -fbo | grep -v pass); done
Probe [0] failed. Expected: 17.000000  Observed: 0.000000
Probe [1] failed. Expected: 13.000000  Observed: 0.000000
Probe [3] failed. Expected: 17.000000  Observed: 0.000000
Probe [4] failed. Expected: 18.000000  Observed: 0.000000
Probe [6] failed. Expected: 12.000000  Observed: 0.000000
Probe [7] failed. Expected: 13.000000  Observed: 0.000000
Probe [9] failed. Expected: 12.000000  Observed: 0.000000
Probe [10] failed. Expected: 18.000000  Observed: 0.000000
Probe [12] failed. Expected: 27.000000  Observed: 0.000000
Probe [13] failed. Expected: 13.000000  Observed: 0.000000
Probe [15] failed. Expected: 27.000000  Observed: 0.000000
Probe [16] failed. Expected: 18.000000  Observed: 0.000000
Probe [18] failed. Expected: 22.000000  Observed: 0.000000
Probe [19] failed. Expected: 13.000000  Observed: 0.000000
Probe [21] failed. Expected: 22.000000  Observed: 0.000000
Probe [22] failed. Expected: 18.000000  Observed: 0.000000
Probe [24] failed. Expected: 37.000000  Observed: 0.000000
Probe [25] failed. Expected: 13.000000  Observed: 0.000000
Probe [27] failed. Expected: 37.000000  Observed: 0.000000
Probe [28] failed. Expected: 18.000000  Observed: 0.000000
Probe [30] failed. Expected: 32.000000  Observed: 0.000000
Probe [31] failed. Expected: 13.000000  Observed: 0.000000
Probe [33] failed. Expected: 32.000000  Observed: 0.000000
Probe [34] failed. Expected: 18.000000  Observed: 0.000000
Probe [36] failed. Expected: 47.000000  Observed: 0.000000
Probe [37] failed. Expected: 13.000000  Observed: 0.000000
Probe [39] failed. Expected: 47.000000  Observed: 0.000000
Probe [40] failed. Expected: 18.000000  Observed: 0.000000
Probe [42] failed. Expected: 42.000000  Observed: 0.000000
Probe [43] failed. Expected: 13.000000  Observed: 0.000000
Probe [45] failed. Expected: 42.000000  Observed: 0.000000
Probe [46] failed. Expected: 18.000000  Observed: 0.000000
PIGLIT: {"result": "fail" }

HW/SW info
---

CPU: Intel(R) Core(TM) i5-4210M CPU
GPU: Intel® HD Graphics 4600, Intel Haswell Mobile (GT2)
Linux kernel version: 4.2.0-30-generic (Ubuntu 15.10)
Mesa HEAD: f8ea98e4ec4078924f79b0aadd2754726b835f5c
Piglit HEAD: 1d83558d4bef6e0cd05b1cf167c2bf63ac6b3b92


How to reproduce it
---

* Run the following command:

$ while (true); do (bin/bufferstorage-persistent read client-storage -auto -fbo | grep -v pass); done

* Wait between 30 minutes to see the errors in the output.
Comment 1 Samuel Iglesias Gonsálvez 2016-03-11 12:08:18 UTC
(In reply to Samuel Iglesias from comment #0)

> * Wait between 30 minutes to see the errors in the output.

Wait between 20 and 30 minutes...
Comment 2 Mark Janes 2016-03-11 22:04:32 UTC
I occasionally see these failures in the CI also.
Comment 3 Mark Janes 2016-04-18 23:14:06 UTC
*** Bug 95006 has been marked as a duplicate of this bug. ***
Comment 4 GitLab Migration User 2019-09-25 18:56:38 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/1519.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.