Bug 94886 - ZSnes segfault in clone_load_const
Summary: ZSnes segfault in clone_load_const
Status: RESOLVED INVALID
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: 11.2
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-04-11 00:54 UTC by Dmitry Osipenko
Modified: 2016-04-17 15:29 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitry Osipenko 2016-04-11 00:54:09 UTC
Intel HD4000 (IVB) ZSnes (Super Nintendo emulator) worked fine with mesa 11.1, now crashes on start with the following backtrace:

#0  0xf5974a4f in clone_load_const (lc=0x8c80c34, state=0xffffb074)
    at /var/tmp/portage/media-libs/mesa-11.2.0/work/mesa-11.2.0/src/compiler/nir/nir_clone.c:320
#1  clone_instr (instr=0x8c80c34, state=0xffffb074)
    at /var/tmp/portage/media-libs/mesa-11.2.0/work/mesa-11.2.0/src/compiler/nir/nir_clone.c:448
#2  clone_block (blk=0x8c7665c, cf_list=0x8c78988, state=0xffffb074)
    at /var/tmp/portage/media-libs/mesa-11.2.0/work/mesa-11.2.0/src/compiler/nir/nir_clone.c:491
#3  clone_cf_list (state=state@entry=0xffffb074, dst=dst@entry=0x8c78988, list=0x8c76600)
    at /var/tmp/portage/media-libs/mesa-11.2.0/work/mesa-11.2.0/src/compiler/nir/nir_clone.c:538
#4  0xf597509d in clone_function_impl (nfxn=<optimized out>, fi=0x8c765ec, state=<optimized out>)
    at /var/tmp/portage/media-libs/mesa-11.2.0/work/mesa-11.2.0/src/compiler/nir/nir_clone.c:571
#5  nir_shader_clone (mem_ctx=0x8c78224, s=0x8c7dd14)
    at /var/tmp/portage/media-libs/mesa-11.2.0/work/mesa-11.2.0/src/compiler/nir/nir_clone.c:645
#6  0xf5a3cc9a in brw_compile_fs (compiler=0x899de6c, log_data=0xf607601c, mem_ctx=0x8c78224, key=0xffffc770, 
    prog_data=0xffffc5b4, src_shader=0x8c7dd14, prog=0x8c80da0, shader_time_index8=-1, shader_time_index16=-1, 
    use_rep_send=false, final_assembly_size=0xffffc5ac, error_str=0xffffc5b0)
    at /var/tmp/portage/media-libs/mesa-11.2.0/work/mesa-11.2.0/src/mesa/drivers/dri/i965/brw_fs.cpp:5610
#7  0xf59e7d66 in brw_codegen_wm_prog (brw=0xf607601c, prog=0x8ce71ac, fp=0x8c80da0, key=0xffffc770)
    at /var/tmp/portage/media-libs/mesa-11.2.0/work/mesa-11.2.0/src/mesa/drivers/dri/i965/brw_wm.c:137
#8  0xf59e8b27 in brw_fs_precompile (ctx=0xf607601c, shader_prog=0x8ce71ac, prog=0x8c80da0)
    at /var/tmp/portage/media-libs/mesa-11.2.0/work/mesa-11.2.0/src/mesa/drivers/dri/i965/brw_wm.c:638
#9  0xf59cec22 in brw_shader_precompile (sh_prog=0x8ce71ac, ctx=0xf607601c)
    at /var/tmp/portage/media-libs/mesa-11.2.0/work/mesa-11.2.0/src/mesa/drivers/dri/i965/brw_link.cpp:51
#10 brw_link_shader (ctx=0xf607601c, shProg=0x8ce71ac)
    at /var/tmp/portage/media-libs/mesa-11.2.0/work/mesa-11.2.0/src/mesa/drivers/dri/i965/brw_link.cpp:260
#11 0xf58a517b in _mesa_glsl_link_shader (ctx=0xf607601c, prog=0x8ce71ac)
    at /var/tmp/portage/media-libs/mesa-11.2.0/work/mesa-11.2.0/src/mesa/program/ir_to_mesa.cpp:3040
#12 0xf571020d in create_new_program (key=0xffffc9fc, ctx=0xf607601c)
    at /var/tmp/portage/media-libs/mesa-11.2.0/work/mesa-11.2.0/src/mesa/main/ff_fragment_shader.cpp:1265
#13 _mesa_get_fixed_func_fragment_program (ctx=0xf607601c)
    at /var/tmp/portage/media-libs/mesa-11.2.0/work/mesa-11.2.0/src/mesa/main/ff_fragment_shader.cpp:1295
#14 0xf57b58a1 in update_program (ctx=0xf607601c)
    at /var/tmp/portage/media-libs/mesa-11.2.0/work/mesa-11.2.0/src/mesa/main/state.c:157
#15 _mesa_update_state_locked (ctx=0xf607601c)
    at /var/tmp/portage/media-libs/mesa-11.2.0/work/mesa-11.2.0/src/mesa/main/state.c:473
#16 0xf57b5972 in _mesa_update_state (ctx=0xf607601c)
    at /var/tmp/portage/media-libs/mesa-11.2.0/work/mesa-11.2.0/src/mesa/main/state.c:504
#17 0xf56e0839 in _mesa_Clear (mask=16384)
    at /var/tmp/portage/media-libs/mesa-11.2.0/work/mesa-11.2.0/src/mesa/main/clear.c:172
#18 0x08313a3d in gl_clearwin () at linux/gl_draw.c:145
#19 0x08312805 in clearwin () at linux/sdllink.c:1195
#20 0x08312b9a in initwinvideo () at linux/sdllink.c:1073
#21 0x08310263 in initvideo ()
#22 0x088bd45c in regptwa ()
#23 0x083a0ef0 in SA1tableG ()
#24 0xffffcd28 in ?? ()
#25 0xf7a70447 in __libc_start_main (main=0x1, argc=134531267, argv=0x0, init=0x804c8e4 <_start+33>, 
    fini=0x804c850 <main>, rtld_fini=0x1, stack_end=0xffffcdd4) at libc-start.c:289
#26 0xf7ffcfd8 in _DYNAMIC () from /lib/ld-linux.so.2
#27 0x00000001 in ?? ()
#28 0x0804c8c3 in sem_StartTicks () at linux/sdllink.c:1299
#29 0x00000000 in ?? ()
Comment 1 Dmitry Osipenko 2016-04-17 15:29:18 UTC
After performing system update, I couldn't reproduce the issue. Now valgrind suggests that there is memory corruption made by ZSnes. So it's likely not a mesa issue, hence closing the bug.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.