Bug 94959 - Booting Intel HD Graphics 5500 without intel_iommu=igfx_off is unworkable.
Summary: Booting Intel HD Graphics 5500 without intel_iommu=igfx_off is unworkable.
Status: RESOLVED DUPLICATE of bug 89360
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: 7.4 (2008.09)
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Chris Wilson
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-04-16 01:01 UTC by Jeff
Modified: 2016-04-16 05:45 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
gpu dump. (529.61 KB, text/plain)
2016-04-16 01:01 UTC, Jeff
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jeff 2016-04-16 01:01:18 UTC
Created attachment 122982 [details]
gpu dump.

According to the document Documentation/Intel-IOMMU.txt a bug report is needed if the intel_iommu=igfx_off kernel parameter fixes and issues. Well, it did on my machine.  Specs:

 lspci
00:00.0 Host bridge: Intel Corporation Broadwell-U Host Bridge -OPI (rev 09)
00:02.0 VGA compatible controller: Intel Corporation Broadwell-U Integrated Graphics (rev 09)

...

00:1c.0 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #1 (rev e3)
00:1c.2 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #3 (rev e3)
00:1c.3 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #4 (rev e3)

...

00:1f.0 ISA bridge: Intel Corporation Wildcat Point-LP LPC Controller (rev 03)
00:1f.3 SMBus: Intel Corporation Wildcat Point-LP SMBus Controller (rev 03)
00:1f.6 Signal processing controller: Intel Corporation Wildcat Point-LP Thermal Management Controller (rev 03)

Graphics stack:
X.Org X Server 1.18.3
Release Date: 2016-04-04
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.2.0-35-lowlatency x86_64 Gentoo
Current Operating System: Linux gentoo-laptop 4.4.6-gentoo #1 SMP Fri Apr 15 18:09:05 CDT 2016 x86_64
Kernel command line: BOOT_IMAGE=/kernel-genkernel-x86_64-4.4.6-gentoo intel_iommu=igfx_off i915.preliminary_hw_support=0 dolvm real_root=/dev/ubuntu-studio-vg/lv_gentoo_root init=/usr/lib/systemd/systemd ro rootfsype=ext4
Build Date: 15 April 2016  07:16:47PM
 
Current version of pixman: 0.32.8
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.

** (Happens on older versions also)

Kernel:
linux-4.4.6 x86_64 Intel(R) Core(TM) i3-5010U CPU @ 2.10GHz GenuineIntel 

** (Happened on 4.1.15 also)
Problems:
With IOMMU turned on:
1. bad modesetting (wrong modes, maybe confused contexts also)
2. random 'stuck on render ring' errors 
3. freezes (sometimes at the DM level, other times after the WM has started and an app is attempted to be opened)
4. outright crashes occur. (sometimes as early as Plymouth, sometimes at DM level, Sometimes as a WM starts)

Happens with only the laptop display or with an external monitor hooked to DP1.

I will attach a gpu core dump I managed to capture from one when either starting X or maybe even at Plymouth (yeah, plymouth doesn't even work reliably without this parameter). However, i think the actually dump was from an older version setup, but the results were the same with this version.....

I would also be happy to reboot with IOMMU turned on and do whatever and pull which ever logs will help.
Comment 1 Chris Wilson 2016-04-16 05:45:47 UTC

*** This bug has been marked as a duplicate of bug 89360 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.