Bug 95493 - [bug] no connection issue
Summary: [bug] no connection issue
Status: RESOLVED FIXED
Alias: None
Product: GeoClue
Classification: Unclassified
Component: service (show other bugs)
Version: unspecified
Hardware: Other All
: medium major
Assignee: Geoclue Bugs
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-05-19 15:12 UTC by mattia.b89
Modified: 2016-09-09 13:52 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mattia.b89 2016-05-19 15:12:04 UTC
geoclue doesn't work if a connection is established after the geoclue.service is started.

Step to reproduce it:
- power on the pc without a wireless connection available
- make a wireless connection available
- check geoclue location

Additional info:
- Arch Linux x86_64
- geoclue2 2.4.3-1
Comment 1 mattia.b89 2016-05-19 15:12:51 UTC
manually restarting the service solves the problem
Comment 2 Zeeshan Ali 2016-05-19 23:30:07 UTC
I just pushed these patches that should help with this situation. At least they seem to help on my machine in my limited testing:

commit: c5d13936dec0676f6b30d17600f7b3fd33099ce0

    web-source: Mark unused arg as such

commit: 4c011afc5b1516a7e5d9631fca06975f6f48d50d

    web-source: Check for full internet availability
    
    Instead of just checking if some network is available, let's check if we
    are fully connected to internet or not.
    
    If glib >= 2.44 is available, we make use the new API added in that
    version to check for connectivity but if it's not, we check if Mozilla
    Location Services hostname is reachable.
Comment 3 mattia.b89 2016-05-21 07:17:05 UTC
Ok, when package will be updated I'll report you a new feedback.
In the meantime, I performed a test with an Ethernet connection (with the actual version) and the result is the same, that is the issue is present even with an Ethernet connection... as I expected....

WITHOUT CONNECTION, systemctl status geoclue.service:
May 21 08:41:38 arch-xps systemd[1]: Starting Location Lookup Service...
May 21 08:41:38 arch-xps geoclue[2299]: (geoclue:2299): Geoclue-WARNING **: Failed to connect to avahi service: Daemon not running
May 21 08:41:38 arch-xps systemd[1]: Started Location Lookup Service.
May 21 08:42:54 arch-xps geoclue[2299]: (geoclue:2299): Geoclue-WARNING **: Failed to connect to avahi service: Daemon not running

WITH CONNECTION (service has been restarted with systemctl restart geoclue.service), systemctl status geoclue.service:
May 21 08:45:19 arch-xps systemd[1]: Starting Location Lookup Service...
May 21 08:45:19 arch-xps geoclue[2940]: (geoclue:2940): Geoclue-WARNING **: Failed to connect to avahi service: Daemon not running
May 21 08:45:19 arch-xps systemd[1]: Started Location Lookup Service.
Comment 4 mattia.b89 2016-09-02 10:49:07 UTC
please, push out a new stable version so I can try it out and finally check the issue
Comment 5 mattia.b89 2016-09-09 13:52:47 UTC
I confirm the fix!
good work


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.