Bug 97902 - BioShock 1 (wine) crashes on level load
Summary: BioShock 1 (wine) crashes on level load
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
Depends on:
Reported: 2016-09-23 05:16 UTC by bartos.petr
Modified: 2019-09-25 18:58 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Description bartos.petr 2016-09-23 05:16:59 UTC
on Intel HD Graphics 5500 (Broadwell GT2) with with git version of mesa (installed from https://copr.fedorainfracloud.org/coprs/griever/mesa-git/) I found problem with BioShock 1. Game starts, I can navigate menus, however game crashes on loading screen. In console I see many:

CPU mapping a busy MapBufferRange BO stalled and took 1.792 ms.
Stalling on the GPU for mapping a busy buffer object


SIMD16 shader failed to compile: FS compile failed: Failure to register allocate.  Reduce number of live scalar values to avoid this.

There are no errors in dmesg.

I did not play this game for some time, but I know for sure it was working on my machine before with same graphics setting. I found I can start new game (intro level with plane crash is working) but It crashes whenever some level inside Rapture is loaded. So it might be triggerred by some effect/shader/whatever which is used only further in game.
Comment 1 Eero Tamminen 2016-09-26 10:03:20 UTC
Could you install debug symbols for Mesa and once the game is running, attach to it with Gdb:
  gdb <path to game binary> <game PID>

After the crash, provide "bt" command output from Gdb.

Note: If game is running as windowed, you can run Gdb from another terminal window.  However, if game is running as fullscreen, it's better to run Gdb through ssh from another machine (most likely your GUI will freeze when Gdb pauses the game, because fullscreened games typically have requested pointer & keyboard lock from X server).
Comment 2 bartos.petr 2016-12-15 20:30:14 UTC
Sorry for late reply, I didn't have much time for gaming lately. I've not yet tried the debug thing, however I tried to install older packages of mesa from previous Fedora versions and switch them via LD_LIBRARY_PATH/LIBGL_DRIVERS_PATH.
Bioshock does not load at all with 10.5.4 and 11.2.1. With 10.6.9 and 11.0.3 it loads but crashes almost immediatelly (after some freezes, so probably shader compilation). The most stable it is with 11.1.0 however it is also crashing especially with areas with lots of water. It also does not load with 13.1.0-devel (git-da3389a) which I am using as primary now.
Comment 3 Eero Tamminen 2016-12-19 10:37:42 UTC
(In reply to Eero Tamminen from comment #1)
> Could you install debug symbols for Mesa and once the game is running,
> attach to it with Gdb:
>   gdb <path to game binary> <game PID>

path to game binary you can see with:
  ls -l /proc/<game PID>/exe

> After the crash, provide "bt" command output from Gdb.

To be exact, this command:
  thread apply all bt
Comment 4 GitLab Migration User 2019-09-25 18:58:18 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/1541.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.