Bug 98014 - Debian package missing gschema files
Summary: Debian package missing gschema files
Status: RESOLVED FIXED
Alias: None
Product: SyncEvolution
Classification: Unclassified
Component: ActiveSync (show other bugs)
Version: 1.5.2
Hardware: Other All
: medium normal
Assignee: Patrick Ohly
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-10-02 10:16 UTC by Graham Cobb
Modified: 2018-01-09 16:32 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Description Graham Cobb 2016-10-02 10:16:15 UTC
The Debian packaging (downloads.syncevolution.org experimental repos) for activesyncd is missing the GSettings schema files.  Activesyncd crashes (with a Trace trap in my testing) when trying to load settings.

Copying org.meego.activesyncd.* to /usr/share/glib-2.0/schemas/ and then running glib-compile-schemas /usr/share/glib-2.0/schemas/ fixes this particular problem for me.

I do not know if there are any standard Debian packaging guidelines for installing GSettings schema files.
Comment 1 Patrick Ohly 2016-10-07 13:26:38 UTC
Will be fixed in next release candidate.
Comment 2 Patrick Ohly 2016-10-10 18:42:55 UTC
The current solution doesn't work - it captures the files created during installation, which includes the build systems /usr/share/glib-2.0/schemas/gschemas.compiled.

That's wrong, that file must not be included in the package. Instead, it needs to be updated by calling glib-compile-schemas in a post[un]inst script.
Comment 3 Graham Cobb 2017-04-04 07:45:27 UTC
I just set up a minimal debian system (using debian stable) and installed activesyncd. The installation gave the following error (retyped by hand, so may not be completely correct):

/var/lib/dpkg/info/activesyncd-jessie.postinst: 3: /var/lib/dpkg/info/activesyncd-jessie.postinst:/usr/bin/glib-compile-schemas: not found

The problem is that libglib2.0-bin is missing as a dependency for activesyncd-jessie. Installing libglib2.0-bin allowed the installation to complete.

activesyncd-jessie      0.92+20161108+SE+a15dc2d-1
Comment 4 Patrick Ohly 2018-01-09 16:32:30 UTC
Fixed in the 1.5.3 binaries.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.