Bug 98094 - Enabling repo_gpgcheck in entry in /etc/yum.repos.d breaks offline update
Summary: Enabling repo_gpgcheck in entry in /etc/yum.repos.d breaks offline update
Status: RESOLVED FIXED
Alias: None
Product: PackageKit
Classification: Unclassified
Component: backend-yum (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Richard Hughes
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-10-05 11:46 UTC by lpugoy
Modified: 2017-01-01 12:41 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
packagekitd verbose trace (41.57 KB, application/gzip)
2016-10-05 11:46 UTC, lpugoy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description lpugoy 2016-10-05 11:46:26 UTC
Created attachment 127026 [details]
packagekitd verbose trace

The version of packagekit installed:
$ /usr/libexec/packagekitd --version
Version 1.1.3

The installation method you used (i.e. f19 RPM, tarball):
Included with system installation

Your distribution and version:
Fedora 24 64-bit

The verbose trace from packagekitd:
Attached packagekitd.log.gz

Any other information that may be relevant:
I added Google Chrome's repo to /etc/yum.repos.d. Its contents are:


[google-chrome]
name=google-chrome
baseurl=http://dl.google.com/linux/chrome/rpm/stable/x86_64
enabled=1
gpgcheck=1
gpgkey=https://dl.google.com/linux/linux_signing_key.pub


I added "repo_gpgcheck=1" to the end. Running "sudo dnf makecache" succeeded.

Running gnome-software shows that there were pending updates, so I restarted the system with the "Install pending software updates" option checked. When the system restarted the updates were not installed.

I ran packagekitd with verbose tracing enabled using the steps here: https://www.freedesktop.org/software/PackageKit/pk-bugs.html. In a separate terminal I ran gnome-software with "killall gnome-software" and "gnome-software --verbose" and rechecked for updates. In gnome-software's terminal there is the following output:

(gnome-software:1926): Gs-WARNING **: failed to call gs_plugin_add_updates_historical on packagekit-offline: Curl error (6): Couldn't resolve host name for https://dl.google.com/linux/linux_signing_key.pub [Could not resolve host: dl.google.com]

Removing the "repo_gpgcheck=1" line from Google Chrome's entry in /etc/yum.repos.d and retrying the offline update worked.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.