Bug 9846 - Ignore glyph-not-found kind of errors
Summary: Ignore glyph-not-found kind of errors
Status: RESOLVED FIXED
Alias: None
Product: cairo
Classification: Unclassified
Component: general (show other bugs)
Version: 1.4.10
Hardware: Other All
: medium normal
Assignee: poppler-bugs
QA Contact:
URL: http://www.abm.uu.se/evahw/coupon.pdf
Whiteboard:
Keywords:
: 10401 11298 11462 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-02-02 01:38 UTC by Pablo Rodríguez
Modified: 2008-07-27 03:12 UTC (History)
5 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pablo Rodríguez 2007-02-02 01:38:36 UTC
poppler 0.5.4 (plus cairo-1.3.12) are not able to properly display http://www.abm.uu.se/evahw/coupon.pdf.

xpdf and Adobe 7 display it fine.
Comment 1 Carlos Garcia Campos 2007-07-27 03:16:26 UTC
What's wrong? It seems to work for me with poppler cvs head. I can see an error message in stdout though

Error: Unknown character collection Adobe-Identity
Comment 2 Pablo Rodríguez 2007-08-25 13:46:34 UTC
The problem is that no text is displayed unless selected (using poppler-0.5.91).
Comment 3 Pablo Rodríguez 2007-08-25 13:53:39 UTC
The problem is that no text is displayed unless selected (using poppler-0.5.91).
Comment 4 Behdad Esfahbod 2007-09-07 12:45:41 UTC
*** Bug 10401 has been marked as a duplicate of this bug. ***
Comment 5 Behdad Esfahbod 2007-09-07 12:46:38 UTC
*** Bug 11298 has been marked as a duplicate of this bug. ***
Comment 6 Behdad Esfahbod 2007-09-07 12:47:09 UTC
See analysis here:

http://bugzilla.gnome.org/show_bug.cgi?id=472087
Comment 7 Pablo Rodríguez 2007-09-09 02:33:19 UTC
Behdad,

thanks for your analysis.

As far as I can understand, this is not a poppler bug. The issue is caused by cairo.

In that case, the question is whether there will be a cairo release in the 1.4 series that fixes this problem.

Thanks for your excellent work,


Pablo
Comment 8 Behdad Esfahbod 2007-09-11 12:49:01 UTC
(In reply to comment #7)
> Behdad,
> 
> thanks for your analysis.
> 
> As far as I can understand, this is not a poppler bug. The issue is caused by
> cairo.
> 
> In that case, the question is whether there will be a cairo release in the 1.4
> series that fixes this problem.

Working on it:

http://lists.freedesktop.org/archives/cairo/2007-September/011395.html


> Thanks for your excellent work,
> 
> 
> Pablo
> 

Comment 9 Behdad Esfahbod 2007-09-17 18:12:22 UTC
commit 79d975f84bcc32e91db517d71a7312e2e1d653d4
Author: Behdad Esfahbod <behdad@behdad.org>
Date:   Wed Sep 12 17:45:11 2007 -0400

    [cairo-ft-font] Ignore FT_Load_Glyph errors other than out-of-memory
    Same for FT_Render_Glyph.
    
    When the user asks us to render a glyph that is not available in the font,
    it's mostly an unavoidable kind of error for them, as in, they can't
    avoid such a call.  So it's not nice to put cairo_t in an error state and
    refuse any further drawying.
    
    Many PDF files are created using buggy software and cause such glpyh-not-found
    errors for CID 0 for example.
    
    Eventually we should propagate these kind of errors up and return it from
    the function call causing it, but that needs API change to add return value
    to all text functions, so for now we just ignore these errors.

Comment 10 Sebastien Bacher 2007-09-28 05:08:57 UTC
The patch fixes the rendering of several pdf but the bug description example is still buggy, reopening
Comment 11 Jeff Muizelaar 2007-11-30 20:42:46 UTC
Are you sure? coupon.pdf shows text fine for me.
Comment 12 Sebastien Bacher 2007-12-01 05:17:06 UTC
what libcairo version do you use?
Comment 13 Sebastien Bacher 2007-12-01 06:08:11 UTC
That's fixed using the new libcairo
Comment 14 Jeff Muizelaar 2007-12-02 19:37:55 UTC
*** Bug 11462 has been marked as a duplicate of this bug. ***
Comment 15 Carlos Garcia Campos 2008-07-27 03:12:52 UTC
Here is a document where the problem is still reproducible witht current poppler and cairo 1.6.5:

http://www.physco.com/evince/SP07_National_Satellite_P12.pdf

"The missing text in the attached PDF starts at the table on page 4, and runs to
the end of the document on page 11."

Originally reported here: http://bugzilla.gnome.org/show_bug.cgi?id=502806

I don't know whether it's the same problem or not. 


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.