Bug 98728 - gpu will hang arbitrarily and repeatedly (no 3d, just 2d)
Summary: gpu will hang arbitrarily and repeatedly (no 3d, just 2d)
Status: CLOSED DUPLICATE of bug 89360
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-11-14 22:18 UTC by null
Modified: 2017-07-24 22:40 UTC (History)
1 user (show)

See Also:
i915 platform: BDW
i915 features: GPU hang


Attachments
contents of /sys/class/drm/card0/error (17.42 KB, application/gzip)
2016-11-14 22:18 UTC, null
no flags Details
dmesg from boot to error (14.63 KB, application/gzip)
2016-11-15 07:53 UTC, null
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description null 2016-11-14 22:18:03 UTC
Created attachment 127968 [details]
contents of /sys/class/drm/card0/error

Nov 14 22:02:50 zephyr kernel: [42515.310739] ------------[ cut here ]------------
Nov 14 22:02:50 zephyr kernel: [42515.310747] WARNING: CPU: 0 PID: 0 at drivers/gpu/drm/i915/intel_lrc.c:506 execlists_check_remove_request+0x5e/0x120
Nov 14 22:02:50 zephyr kernel: [42515.310747] WARN_ON(!head_req || (head_req->ctx_hw_id != ctx_id))
Nov 14 22:02:50 zephyr kernel: [42515.310750] CPU: 0 PID: 0 Comm: swapper/0 Not tainted 4.8.6-zephyr #20
Nov 14 22:02:50 zephyr kernel: [42515.310751] Hardware name: LENOVO 20BSCTO1WW/20BSCTO1WW, BIOS N14ET32W (1.10 ) 08/13/2015
Nov 14 22:02:50 zephyr kernel: [42515.310752]  0000000000000000 ffffffff813e49c8 ffff88024dc03e20 0000000000000000
Nov 14 22:02:50 zephyr kernel: [42515.310755]  ffffffff8110b07f ffff880243643b38 ffff88024dc03e70 ffff88024dc03ea8
Nov 14 22:02:50 zephyr kernel: [42515.310758]  0000000000000008 0000000000000000 ffff88024dc03ea8 ffffffff8110b0ea
Nov 14 22:02:50 zephyr kernel: [42515.310761] Call Trace:
Nov 14 22:02:50 zephyr kernel: [42515.310761]  <IRQ>  [<ffffffff813e49c8>] ? dump_stack+0x46/0x5e
Nov 14 22:02:50 zephyr kernel: [42515.310769]  [<ffffffff8110b07f>] ? __warn+0xaf/0xd0
Nov 14 22:02:50 zephyr kernel: [42515.310771]  [<ffffffff8110b0ea>] ? warn_slowpath_fmt+0x4a/0x50
Nov 14 22:02:50 zephyr kernel: [42515.310773]  [<ffffffff8153cd4e>] ? execlists_check_remove_request+0x5e/0x120
Nov 14 22:02:50 zephyr kernel: [42515.310774]  [<ffffffff8153d8f6>] ? intel_lrc_irq_handler+0x166/0x270
Nov 14 22:02:50 zephyr kernel: [42515.310777]  [<ffffffff8110eb7b>] ? tasklet_action+0x4b/0xa0
Nov 14 22:02:50 zephyr kernel: [42515.310779]  [<ffffffff8110ef07>] ? __do_softirq+0xf7/0x200
Nov 14 22:02:50 zephyr kernel: [42515.310781]  [<ffffffff8110f140>] ? irq_exit+0x90/0xa0
Nov 14 22:02:50 zephyr kernel: [42515.310784]  [<ffffffff8105a5ba>] ? do_IRQ+0x4a/0xc0
Nov 14 22:02:50 zephyr kernel: [42515.310787]  [<ffffffff8193b249>] ? common_interrupt+0x89/0x89
Nov 14 22:02:50 zephyr kernel: [42515.310787]  <EOI>  [<ffffffff817118dd>] ? cpuidle_enter_state+0x13d/0x1f0
Nov 14 22:02:50 zephyr kernel: [42515.310793]  [<ffffffff817118d9>] ? cpuidle_enter_state+0x139/0x1f0
Nov 14 22:02:50 zephyr kernel: [42515.310795]  [<ffffffff8114032a>] ? cpu_startup_entry+0x1ba/0x250
Nov 14 22:02:50 zephyr kernel: [42515.310798]  [<ffffffff820c0ea6>] ? start_kernel+0x38b/0x393
Nov 14 22:02:50 zephyr kernel: [42515.310800] ---[ end trace f2dd8b513381f3b4 ]---
Comment 1 Chris Wilson 2016-11-14 22:45:47 UTC
The full dmesg would be nice, since it is a strange error. The error will be different with v4.9 (and different again in v4.10!), so getting feedback on changes there will be very useful. My first hunch is that this is going to be intel_iommu=igfx_off related.
Comment 2 null 2016-11-15 07:53:42 UTC
Created attachment 127974 [details]
dmesg from boot to error
Comment 3 null 2016-11-15 08:04:05 UTC
i have had this error from the first time i ran X on the machine. every kernel i have ever built on it and all X drivers i have tried, over the course of about a year and a half exhibits this behavior. i don't recall having a problem when i disabled sna acceleration, but i use off-screen compositing for my window manager [e16, with opacity effects] and those are unusably slow with uxa.
Comment 4 Chris Wilson 2016-11-15 08:05:22 UTC

*** This bug has been marked as a duplicate of bug 89360 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.