Bug 99171 - Using a remote font server problems
Summary: Using a remote font server problems
Status: RESOLVED MOVED
Alias: None
Product: XQuartz
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 2.7.11 (xserver-1.18.4)
Hardware: Other All
: medium normal
Assignee: Jeremy Huddleston Sequoia
QA Contact: Jeremy Huddleston Sequoia
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-12-21 20:15 UTC by Mark Buechler
Modified: 2019-05-23 18:31 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Description Mark Buechler 2016-12-21 20:15:31 UTC
I recently upgraded Xquartz to fix a problem with it listening for remote connections. That's fix, however, if I prepend a remote fontserver, clients hang trying to retrieve fonts and eventually fail. I downgraded Xquartx to 2.7.8 to temporarily resolve my issue.
Comment 1 Jeremy Huddleston Sequoia 2016-12-22 06:42:14 UTC
Please attach a spindump focused on the server when in the hung state.
Comment 2 karl.burgess 2019-05-22 17:16:59 UTC
I've seen this in a custom Xserver on Linux, built with libXfont 1.5.4.

Looks like the cause is this change: 
https://cgit.freedesktop.org/xorg/lib/libXfont/commit/?id=6972ea08ee5b2ef1cfbdc2fcaf14f06bbd391561

I think authlen needs rounding up in the calculation for crac.length.

Something like:  
        crac.length = (sizeof (fsCreateACReq) + ((authlen + 3) & ~0x3)) >> 2;
Comment 3 GitLab Migration User 2019-05-23 18:31:39 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/xorg/xserver/issues/779.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.