Bug 104285

Summary: Euro Truck Simulator 2 and American Truck Simulator artifacts (Mesa 17.3, AMD R9 280X)
Product: Mesa Reporter: Alex Vorobyev <avvorobyev95>
Component: Drivers/Gallium/radeonsiAssignee: Default DRI bug account <dri-devel>
Status: NEW --- QA Contact: Default DRI bug account <dri-devel>
Severity: normal    
Priority: medium    
Version: 17.3   
Hardware: x86-64 (AMD64)   
OS: Linux (All)   
Whiteboard:
i915 platform: i915 features:
Attachments: Example screenshot, showing artifacts in game.
glxinfo

Description Alex Vorobyev 2017-12-16 09:00:43 UTC
Created attachment 136213 [details]
Example screenshot, showing artifacts in game.

After updating Mesa from 17.2.6 to 17.3.0 (using packages from Solus distribution) both ETS2 and ATS started glitching (artifacts around the objects, see attached screenshot as example).

Software: Linux 4.14.5, Mesa 17.3.0, LLVM 5.0.0.
Videocard: MSI Radeon R9 280X (using amdgpu kernel module).
Comment 1 Alex Vorobyev 2017-12-16 09:01:48 UTC
Created attachment 136214 [details]
glxinfo

My glxinfo.
Comment 2 Alex Vorobyev 2018-01-04 11:24:44 UTC
Just did some research - this issue still persists in 17.3.1 and it's only visible if shadows enabled. If I set "Shadow quality" in the in-game settings to "Disabled", artifacts disappear.
Comment 3 Vladimir Usikov 2018-01-07 15:15:11 UTC
I can confirm this bug.

Radeon HD 7950 (amdgpu kernel module)

kernel 4.14.0-4.14.11
mesa 17.3.0-17.3.0
LLVM 5.0.0-5.0.1
Comment 4 Gregor M√ľnch 2018-01-08 18:34:39 UTC
Cant confirm with Radeon HD 7970 on mesa git and llvm git from today.
ATS with shadows to high.
Maybe its LLVM?
Comment 5 megaphantomx 2018-01-14 10:17:47 UTC
Confirmed:

Radeon HD 7850
kernel 4.14.13
mesa 17.3.2
LLVM 4.0.1
Comment 6 Alex Vorobyev 2018-02-18 07:06:42 UTC
Solus started shipping Linux 4.15.3 and Mesa 18.0 RC4, but unfortunately the problem is still there. After comment #4 I wonder if LLVM 6.0 will make the difference...

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.