Bug 105241

Summary: Hard system hang on login screen
Product: Mesa Reporter: mrattatrol
Component: Drivers/DRI/i965Assignee: Intel 3D Bugs Mailing List <intel-3d-bugs>
Status: RESOLVED INVALID QA Contact: Intel 3D Bugs Mailing List <intel-3d-bugs>
Severity: blocker    
Priority: medium    
Version: git   
Hardware: x86-64 (AMD64)   
OS: Linux (All)   
i915 platform: i915 features:
Attachments: boot logs
Boot logs with missed breadcrumb error
Screen photos

Description mrattatrol 2018-02-25 15:19:14 UTC
Created attachment 137592 [details]
boot logs

Every time i try to start without nomodeset system hangs several seconds after login screen is show. There is no reaction on magic sysrq keys, no kernel dump, no gpu dump, no error in logs.

I experienced the problem for every distro i tried:
Fedora 23 and 27,
Ubuntu 15.10, 16.04, 16.10, 17.04, 17.10, 18.04alpha

There is no certain moment when crash occures, sometimes it is possible to enter a password and proceed to desktop. I also tried every recipe from arch wiki with no success.

HW: Thinkpad T560 (model without discrete video card)

kernel: 4.16.0-rc2+ (drm-tips from 01.org)
mesa: 18.1
cairo: 1.14.10
libdrm: 2.4.10
xserver-xorg-video-intel: 2.99.917

However there was a single non-reproducible boot when i regained control after freeze and managed to save boot log with gpu hang error.

There are 3 examples of a boot log in the attachment: when system freezes, when i switch to tty and reboot and one where gpu hang takes place.
Comment 1 mrattatrol 2018-02-28 22:52:12 UTC
Created attachment 137706 [details]
Boot logs with missed breadcrumb error

Sometimes system is responds to magic sysrq keys after hang. So i managed to sync logs, all of then end with the same error:

>kernel: missed_breadcrumb rcs0 missed breadcrumb at intel_breadcrumbs_hangcheck
Comment 2 mrattatrol 2018-02-28 23:01:59 UTC
Created attachment 137707 [details]
Screen photos

Usually after hang there is nothing unusual on the screen, however there were 2 instances with artifacts:
1. In one boot i had enough time to launch Firefox. It immediately hanged, but i got window filled with black with white rectangle in the corner.
2. Immediately after hang i moved mouse to the left and part of ubuntu iconbar vanished. After thas system became unresponsive.
Comment 3 Mark Janes 2018-02-28 23:29:29 UTC
based on the fact that so many versions of distros can't boot your machine, I think you probably have a hardware issue.  Skylake graphics are working for everyone else...

Maybe run ramtest?

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.