Bug 105857

Summary: Autospawn fails on macOS 10.13 (High Sierra)
Product: PulseAudio Reporter: brackeen
Component: daemonAssignee: pulseaudio-bugs
Status: RESOLVED MOVED QA Contact: pulseaudio-bugs
Severity: normal    
Priority: medium CC: lennart
Version: unspecified   
Hardware: Other   
OS: Mac OS X (All)   
Whiteboard:
i915 platform: i915 features:

Description brackeen 2018-04-03 02:41:09 UTC
macOS 10.13 changed some rules around forking, which causes PulseAudio's autospawn to fail. 

Reproduction:
Assuming the daemon is not running, this will fail with "Connection refused":
$ pactl stat

Workaround: 
Set the environment variable OBJC_DISABLE_INITIALIZE_FORK_SAFETY to YES
$ export OBJC_DISABLE_INITIALIZE_FORK_SAFETY=YES
$ pactl stat

Tested with 11.1 compiled for High Sierra from Homebrew.

Found the workaround here: http://sealiesoftware.com/blog/index.html
Comment 1 Tanu Kaskinen 2018-04-07 15:48:49 UTC
Since I don't use macOS myself, and probably there's nobody else either who would follow the bug tracker and use macOS, I decided to ask for help from some past contributors on the mailing list:
https://lists.freedesktop.org/archives/pulseaudio-discuss/2018-April/029749.html

Let's see if anything comes out of that.
Comment 2 GitLab Migration User 2018-07-30 10:20:08 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/pulseaudio/pulseaudio/issues/353.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.