Bug 106410

Summary: Xorg server 1.19.6 crashes with nouveau or modsetting driver with Mesa 18.0.x while works fine with proprietary nvidia driver 390.42
Product: xorg Reporter: Qurban Ullah <qurbanullah>
Component: Driver/nouveauAssignee: Nouveau Project <nouveau>
Status: RESOLVED MOVED QA Contact: Xorg Project Team <xorg-team>
Severity: critical    
Priority: medium    
Version: unspecified   
Hardware: x86-64 (AMD64)   
OS: other   
i915 platform: i915 features:
Description Flags
Xorg crash log file
xorg server config log
xf86-video-nouveau config log
Xorg crash log with nouveau driver none

Description Qurban Ullah 2018-05-05 15:15:17 UTC
Created attachment 139370 [details]
Xorg crash log file

The Xorg server crashes with builtin modsetting driver and nouveau driver. while works fine with proprietary nvidia driver 390.42

Xorg server = 1.19.6
Mesa = 18.0.x
Nvidia driver = 390.42
Hardware =  NVIDIA Corporation GF108 [GeForce GT 430] (rev a1)
Comment 1 Qurban Ullah 2018-05-05 15:23:01 UTC
Created attachment 139371 [details]
xorg server config log
Comment 2 Qurban Ullah 2018-05-05 15:24:25 UTC
Created attachment 139372 [details]
xf86-video-nouveau config log
Comment 3 Qurban Ullah 2018-05-05 15:27:32 UTC
I am working on my own distro (avouch.org) and compile all packages myself. Compile config log have been attached. Tried with hardening flag ON and OFF both return same crash. Moreover, using ld.gold as default linker.
Comment 4 Ilia Mirkin 2018-05-05 15:44:15 UTC
Does it work if you use nouveau instead of modesetting? [I see no log file indicating you've tried that.]

I'd say there's something wrong with your installation of mesa. At the very least, try not using gold.
Comment 5 Qurban Ullah 2018-05-05 15:56:59 UTC
Created attachment 139373 [details]
Xorg crash log with nouveau driver
Comment 6 Qurban Ullah 2018-05-05 15:57:11 UTC
Same issue with nouveau driver log file is attached.
Comment 7 Ilia Mirkin 2018-05-06 00:13:46 UTC
Right. So even with xf86-video-nouveau you still get it to die in nouveau_drm_screen_create -- something's wrong in nouveau_dri.so. There are oodles of tricks used in mesa for loading stuff -- could you try not using the experimental gold linker?
Comment 8 Qurban Ullah 2018-05-06 05:56:36 UTC
Thanks sir, the problem was with the mesa as you figured out.

When I compile the mesa with meson build system it contributed to xorg-server crash; could not figure out why. When compile with configure the problem resolved.

So where to file the Mesa meson build bug.
Comment 9 Ilia Mirkin 2018-05-06 13:43:00 UTC
Probably Mesa -> Core.

Note that the meson build system is experimental.
Comment 10 Martin Peres 2019-12-04 09:39:19 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/xorg/driver/xf86-video-nouveau/issues/431.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.