Bug 107504

Summary: Xorg segmentation fault at RRProviderAutoConfigGpuScreen
Product: xorg Reporter: Loenh <961123325>
Component: Driver/nouveauAssignee: Nouveau Project <nouveau>
Status: NEW --- QA Contact: Xorg Project Team <xorg-team>
Severity: major    
Priority: medium    
Version: unspecified   
Hardware: x86-64 (AMD64)   
OS: Linux (All)   
Whiteboard:
i915 platform: i915 features:

Description Loenh 2018-08-07 06:23:26 UTC
Description of problem:
starting installation with gui mode failed
and Xorg segmentation fault

Steps to Reproduce:
1.install CentOS7.4 on the machine with the nvidia GPU

Actual results:
starting installation with gui mode failed

Expected results:
start installation with gui mode successfully

Additional info:
the following versions are OK
CnetOS 7.3 7.2

the following versions have this problem
CentOS 7.4 rhel 7.5

adding  "modprobe.blacklist=nouveau" to the grub commandline will avoid this failure
Comment 1 tianhang 2018-09-03 08:14:33 UTC
Xorg segmentation fault at RRProviderAutoConfigGpuScreen
this problem has also occured on on my machine with nvidia cards(GM204GL [Tesla M60])

does the nouveau driver support this nvidia card(GM204GL [Tesla M60]) ?
https://nouveau.freedesktop.org/wiki/CodeNames/ there is no infomation about GM204GL or Telsa M60

OS version :centos 7.4
nvidia card :
# lspci -k -s 06:00.0
06:00.0 VGA compatible controller: NVIDIA Corporation GM204GL [Tesla M60] (rev a1)
        Subsystem: Huawei Corporation Device 2060
        Kernel modules: nouveau

Look forward to your reply

thanks

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.