Bug 111336

Summary: [CI][BAT] igt@gem_exec_suspend@basic-s3 -dmesg-warn - i915 raw-wakerefs=1 wakelocks=1 on cleanup
Product: DRI Reporter: Lakshmi <lakshminarayana.vudum>
Component: DRM/IntelAssignee: Intel GFX Bugs mailing list <intel-gfx-bugs>
Status: RESOLVED MOVED QA Contact: Intel GFX Bugs mailing list <intel-gfx-bugs>
Severity: normal    
Priority: high CC: intel-gfx-bugs
Version: DRI git   
Hardware: Other   
OS: All   
Whiteboard: ReadyForDev
i915 platform: ILK i915 features: power/runtime PM

Description Lakshmi 2019-08-09 09:34:16 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_6658/fi-ilk-m540/igt@gem_exec_suspend@basic-s3.html

------------[ cut here ]------------
<4> [81.161689] i915 raw-wakerefs=1 wakelocks=1 on cleanup
<4> [81.161805] WARNING: CPU: 1 PID: 177 at drivers/gpu/drm/i915/intel_runtime_pm.c:603 intel_runtime_pm_driver_release+0x27/0x40 [i915]
<4> [81.161809] Modules linked in: vgem snd_hda_codec_hdmi snd_hda_codec_generic i915 coretemp crct10dif_pclmul crc32_pclmul ghash_clmulni_intel snd_hda_intel snd_intel_nhlt snd_hda_codec intel_ips snd_hwdep snd_hda_core snd_pcm e1000e mei_me ptp pps_core lpc_ich mei prime_numbers
<4> [81.161837] CPU: 1 PID: 177 Comm: kworker/u16:2 Tainted: G     U            5.3.0-rc3-CI-CI_DRM_6658+ #1
<4> [81.161840] Hardware name: Hewlett-Packard HP EliteBook 8440p/172A, BIOS 68CCU Ver. F.24 09/13/2013
<4> [81.161849] Workqueue: events_unbound async_run_entry_fn
<4> [81.161915] RIP: 0010:intel_runtime_pm_driver_release+0x27/0x40 [i915]
<4> [81.161920] Code: 1f 40 00 53 8b 37 48 89 fb 85 f6 75 09 48 89 df 5b e9 bd f9 ff ff 89 f2 48 c7 c7 30 22 2f a0 0f b7 f6 c1 fa 10 e8 19 c7 f4 e0 <0f> 0b 48 89 df 5b e9 9e f9 ff ff 0f 1f 40 00 66 2e 0f 1f 84 00 00
<4> [81.161923] RSP: 0018:ffffc9000135fd80 EFLAGS: 00010282
<4> [81.161928] RAX: 0000000000000000 RBX: ffff888119edbb30 RCX: 0000000000000001
<4> [81.161931] RDX: 0000000080000001 RSI: ffff888130ac2f30 RDI: 00000000ffffffff
<4> [81.161934] RBP: ffff8881331dc548 R08: ffff888130ac2f30 R09: 0000000000000000
<4> [81.161937] R10: 0000000000000000 R11: 0000000000000000 R12: 0000000000000000
<4> [81.161940] R13: ffff888119edbb30 R14: 0000000000000000 R15: 0000000000000000
<4> [81.161944] FS:  0000000000000000(0000) GS:ffff888133a80000(0000) knlGS:0000000000000000
<4> [81.161947] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
<4> [81.161951] CR2: 00007f38c91ba778 CR3: 0000000002210000 CR4: 00000000000006e0
<4> [81.161954] Call Trace:
<4> [81.162018]  i915_drm_suspend_late+0xa4/0x130 [i915]
<4> [81.162029]  ? pci_pm_poweroff_late+0x30/0x30
<4> [81.162037]  dpm_run_callback+0x64/0x280
<4> [81.162045]  __device_suspend_late+0xad/0x140
<4> [81.162053]  async_suspend_late+0x15/0x90
<4> [81.162059]  async_run_entry_fn+0x34/0x160
<4> [81.162069]  process_one_work+0x245/0x610
<4> [81.162083]  worker_thread+0x37/0x380
<4> [81.162091]  ? process_one_work+0x610/0x610
<4> [81.162096]  kthread+0x119/0x130
<4> [81.162102]  ? kthread_park+0xa0/0xa0
<4> [81.162113]  ret_from_fork+0x3a/0x50
<4> [81.162133] irq event stamp: 1664
<4> [81.162138] hardirqs last  enabled at (1663): [<ffffffff8112dfd5>] vprintk_emit+0x315/0x340
<4> [81.162143] hardirqs last disabled at (1664): [<ffffffff810019ea>] trace_hardirqs_off_thunk+0x1a/0x20
<4> [81.162148] softirqs last  enabled at (1086): [<ffffffff81c0033e>] __do_softirq+0x33e/0x4ae
<4> [81.162152] softirqs last disabled at (1077): [<ffffffff810b80d9>] irq_exit+0xa9/0xc0
<4> [81.162218] WARNING: CPU: 1 PID: 177 at drivers/gpu/drm/i915/intel_runtime_pm.c:603 intel_runtime_pm_driver_release+0x27/0x40 [i915]
<4> [81.162221] ---[ end trace f4855e61963180c7 ]---

Not sure bug if this is a duplicate of Bug 111012.
Comment 1 CI Bug Log 2019-08-09 09:35:36 UTC
The CI Bug Log issue associated to this bug has been updated.

### New filters associated

* ILK: [CI][BAT] igt@gem_exec_suspend@basic-s3 -dmesg-warn - i915 raw-wakerefs=1 wakelocks=1 on cleanup
  - https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_6658/fi-ilk-m540/igt@gem_exec_suspend@basic-s3.html
Comment 2 Chris Wilson 2019-08-09 10:17:55 UTC
That's before 

commit c7302f204490f3eb4ef839bec228315bcd3ba43f
Author: Chris Wilson <chris@chris-wilson.co.uk>
Date:   Thu Aug 8 21:27:58 2019 +0100

    drm/i915: Defer final intel_wakeref_put to process context

so I don't think it's GEM. (That patch is the most recent tweak along pm + suspend and the most likely candidate for a bug.)
Comment 3 Francesco Balestrieri 2019-08-12 14:47:44 UTC
Lowering to High since it's not happening continuously and it's on ILK...
Comment 4 CI Bug Log 2019-11-04 11:57:00 UTC
A CI Bug Log filter associated to this bug has been updated:

{- ILK: [CI][BAT] igt@gem_exec_suspend@basic-s3 -dmesg-warn - i915 raw-wakerefs=1 wakelocks=1 on cleanup -}
{+ ILK: [CI][BAT] igt@gem_exec_suspend@basic-(s0|s3) -dmesg-warn - i915 raw-wakerefs=1 wakelocks=1 on cleanup +}

New failures caught by the filter:

  * https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_7240/fi-ilk-m540/igt@gem_exec_suspend@basic-s0.html
Comment 5 Martin Peres 2019-11-29 19:22:28 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/drm/intel/issues/362.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.