Bug 112124

Summary: Kingdom Come: Deliverance (DXVK) - kernel performance regression [Navi] [RADV/ACO]
Product: DRI Reporter: Andrew Sheldon <asheldon55>
Component: DRM/AMDgpuAssignee: Default DRI bug account <dri-devel>
Status: RESOLVED MOVED QA Contact:
Severity: not set    
Priority: not set CC: witold.baryluk+freedesktop
Version: DRI git   
Hardware: x86-64 (AMD64)   
OS: Linux (All)   
Whiteboard:
i915 platform: i915 features:

Description Andrew Sheldon 2019-10-25 01:39:38 UTC
Kingdom Come: Deliverance (DXVK) has regressed in performance due to the following kernel commit, with aco-navi:

commit 828d6fde7f574d74b0a6a591345d3c42b62d5e21
Author: Tianci.Yin <tianci.yin@amd.com>
Date:   Mon Aug 19 15:30:22 2019 +0800

    drm/amdgpu/psp: move TMR to cpu invisible vram region
    
    so that more visible vram can be available for umd.
    
    Reviewed-by: Christian K├Ânig <christian.koenig@amd.com>.
    Signed-off-by: Tianci.Yin <tianci.yin@amd.com>
    Signed-off-by: Alex Deucher <alexander.deucher@amd.com>

With 828d6fde7f57 (62 fps/79% GPU usage):

https://camo.githubusercontent.com/4608d45738a5174f64daee0604d9f5d7146aee68/68747470733a2f2f692e696d6775722e636f6d2f757356306d33412e6a7067

With 828d6fde7f57 reverted (79 fps, 100% GPU usage):
https://camo.githubusercontent.com/77a505f85b75db0d2062aa4d8319b6007ba524fe/68747470733a2f2f692e696d6775722e636f6d2f394366695270452e6a7067

Tests were with aco-navi branch: https://gitlab.freedesktop.org/Venemo/mesa/tree/aco-navi

Performance with LLVM is comparable with the commit reverted or not, however. Slightly better with the commit since GPU usage is lower for the same performance:

With 828d6fde7f57 (61.4 fps/88% GPU usage):
https://i.imgur.com/kJgvRbq.jpg

Without 8d6fde7f57 (61.2 fps/100% GPU usage):
https://i.imgur.com/AemAss1.jpg

System:

linux-5.4-rc4 (also tested amd-staging-drm-next)
Mesa aco-navi (e641024) and Mesa git (8dadef2ec54)
MSI Evoke 5700 XT
Comment 1 Martin Peres 2019-11-19 09:58:50 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/drm/amd/issues/942.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.