Bug 112253

Summary: PSR1 not activated on boot but activates on susend-resume
Product: DRI Reporter: s.zharkoff
Component: DRM/IntelAssignee: Jose Roberto de Souza <jose.souza>
Status: RESOLVED MOVED QA Contact: Intel GFX Bugs mailing list <intel-gfx-bugs>
Severity: normal    
Priority: medium CC: imre.deak, intel-gfx-bugs, james.ausmus, jose.souza
Version: DRI git   
Hardware: x86-64 (AMD64)   
OS: Linux (All)   
Whiteboard: Triaged, ReadyForDev
i915 platform: KBL i915 features: display/PSR
Description Flags
dmesg on boot none

Description s.zharkoff 2019-11-12 09:03:52 UTC

Comment 1 s.zharkoff 2019-11-12 09:04:57 UTC
Created attachment 145940 [details]
dmesg on boot
Comment 2 s.zharkoff 2019-11-12 09:10:33 UTC
LG Gram 13Z980, KBL hardware. On boot PSR is not enabled, but the debugfs shows it is supported by sink. After-suspend-resume PSR get activated
Comment 3 Lakshmi 2019-11-12 13:27:16 UTC
(In reply to s.zharkoff from comment #2)
> LG Gram 13Z980, KBL hardware. On boot PSR is not enabled, but the debugfs
> shows it is supported by sink. After-suspend-resume PSR get activated

CC'ing Jose and Imre here.
Comment 4 s.zharkoff 2019-11-12 14:13:35 UTC
5.4-rc7 is working OK. PSR1 enabled.
Comment 5 Jose Roberto de Souza 2019-11-12 18:16:35 UTC
What version was you running?

But looks like it is fixed in newer kernel, gonna close it okay?
If it happens again please also try with drm-tip kernel and attach the logs again.

Comment 6 s.zharkoff 2019-11-13 02:25:09 UTC
It is working in 5.4-rc7, but broken in drm-tip tree.
Comment 7 Jose Roberto de Souza 2019-11-13 18:22:56 UTC
The log is from drm-tip?
Comment 8 Jose Roberto de Souza 2019-11-13 18:23:16 UTC
If not can you attach it?
Comment 9 s.zharkoff 2019-11-13 19:45:15 UTC
Yes, the log is from drm-tip. 
The dfference is that intel_psr_enable_locked is not called in drm-tip at the boot time baut called on resume, but on 5.4-rc7 it is called at the boot time. So with drm-tip the system detects that sink is psr1 compatible but somehow skips the activation step. In 5.4-rc7 main tree it activetes psr on initial boot. I tried to find out where it shoud be triggered but my knowledge is not enough for it. I've just tried to comment out all the points where the psr is deactivated due to errors and it is still not enabled after boot until first suspend-resume. So it is not activated and then disabled, it is just not activated.
Comment 10 Jose Roberto de Souza 2019-11-14 00:55:02 UTC
I'm reproducing it too, working on a solution.
Comment 11 Jose Roberto de Souza 2019-11-25 23:40:09 UTC

Here is the fix: https://patchwork.freedesktop.org/series/70000/
Could you test it?

Comment 12 s.zharkoff 2019-11-26 11:00:31 UTC
Tested drm-tip with the patch - work fine, psr activates at boot and continue working after resume from hibernation. So for me bug seems fixed.
Comment 13 Martin Peres 2019-11-29 19:46:56 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/drm/intel/issues/590.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.