Bug 11402

Summary: EXA makes anti-aliased font rendering incorrect
Product: xorg Reporter: Samuel Thibault <samuel.thibault>
Component: Driver/intelAssignee: Wang Zhenyu <zhenyu.z.wang>
Status: VERIFIED FIXED QA Contact: Xorg Project Team <xorg-team>
Severity: normal    
Priority: medium CC: brice.goglin, nian.wu
Version: git   
Hardware: Other   
OS: All   
i915 platform: i915 features:
Bug Depends on:    
Bug Blocks: 13027    
Description Flags
log file
log file
AA font on my 855GM
Non-AA font on my 855GM
X log
configuration file none

Description Samuel Thibault 2007-06-28 05:16:27 UTC
On my i855GM, using EXA makes font rendering incorrect, see attached snapshot. I get the same in other gtk apps, konqueror and freetype-rendered urxvt.

When I disable anti-alias, the rendering is correct.
Comment 1 Samuel Thibault 2007-06-28 05:17:16 UTC
Created attachment 10484 [details]
Comment 2 Samuel Thibault 2007-06-28 05:18:00 UTC
Created attachment 10485 [details]
log file

I forgot to mention that this is with today's git driver.
Comment 3 Wang Zhenyu 2007-10-09 22:59:23 UTC
Should be fixed in current git tip.
Comment 4 Samuel Thibault 2007-10-10 10:26:46 UTC
I updated to your git commit 5faee02e97b7543b41bb1f8e3751558c48802833, but I still get exactly the same result (this is really a deterministic output). 
Comment 5 Wang Zhenyu 2007-10-10 18:23:03 UTC
Could you send me your fontconfig file? My knowledge on it is limited, so may be easy to try with your config.
Comment 6 Wang Zhenyu 2007-10-16 00:02:35 UTC
And what font are you using?
Comment 7 Samuel Thibault 2007-10-17 02:00:40 UTC
Created attachment 12084 [details]

Here is my /etc/fonts. This seems to happen with all fonts, Mono and Sans for instance. Just in case, here are versions:

ii  fontconfig                  2.4.2-1.2
ii  libfreetype6                2.3.5-1+b1
ii  ttf-freefont                20060501cvs-12
Comment 8 Wang Zhenyu 2007-11-14 22:46:51 UTC
I have tried to enable all fonts with antialias, but still can't see this on 855GM here. What about current intel video driver?
Comment 9 Samuel Thibault 2007-11-15 20:36:29 UTC
Still the same :/ 
Comment 10 Wang Zhenyu 2007-11-15 20:49:09 UTC
what's your xserver version? And which font are you using? people reported pcf font bug with current xserver. Could you test with current stable xserver-1.4?
Comment 11 Samuel Thibault 2007-11-15 21:20:25 UTC
Created attachment 12579 [details] [review]
log file

Here is the log file. This is the xserver 1.4 package from debian.  As said previously, this seems to happen with all fonts (I haven't tried the hundreds I have, but a couple of dozens from various packages have the issue). Mono and Sans for instance.
Comment 12 Wang Zhenyu 2007-11-15 22:54:37 UTC
Created attachment 12581 [details]
AA font on my 855GM
Comment 13 Wang Zhenyu 2007-11-15 22:55:08 UTC
Created attachment 12582 [details]
Non-AA font on my 855GM
Comment 14 Wang Zhenyu 2007-11-15 22:57:45 UTC
Here's my two window dumps on my 855GM. The first is from "xterm -fa mono" window, and the second is plain xterm window.

I have upgraded components to master, it seems working fine...so how about your pixman version? we've seen pixman brokenness cause render failure before, not sure
if it's relevant.
Comment 15 Samuel Thibault 2007-11-18 16:34:32 UTC
my pixman is the debian package version 0.9.5-3 
Comment 16 Samuel Thibault 2007-11-18 17:50:53 UTC
I upgraded the xserver-xorg-core package to the recent 2:1.4.1~git20071117-1 package, and now things work fine!
Comment 17 Wang Zhenyu 2007-11-18 18:26:06 UTC
ok, thanks for resolving this!
Comment 18 Samuel Thibault 2007-11-19 03:11:25 UTC
Eergl, talked too fast.  This morning it's not working again, but I'm in a different screen configuration than yesterday evening, I'll dig more this evening.
Comment 19 Samuel Thibault 2007-11-19 18:17:36 UTC
For a yet unknown reason, sometimes it works (and then I can't manage to make it fail again without power cycling), sometimes it fails, and I can't find the way to make it work.

Something that may be related: when I use xrandr --rotate left or any other than normal, I get similar display corruption. This is independant of setting XAA or EXA, however.
Comment 20 Samuel Thibault 2007-11-19 18:26:08 UTC
Upgrading to libpixman 0.9.6 doesn't help

Comment 21 Samuel Thibault 2007-11-19 18:29:31 UTC
Also, the xrandr display corruption can't be dumped through import for instance.
Comment 22 Wang Zhenyu 2007-11-19 18:30:29 UTC
As I can't see this on 855GM here, could you paste your current x logs?
and try to disable fbc by
Option "FramebufferCompression" "FALSE" in Device section.
Comment 23 Samuel Thibault 2007-11-19 18:40:10 UTC
Created attachment 12636 [details]
X log

I had already posted a log, but here is another one, with framebuffer compression disabled. Still produces bogus AA fonts.
Comment 24 Samuel Thibault 2007-11-19 18:42:21 UTC
Created attachment 12637 [details]
configuration file

I realize that I haven't posted my xorg.conf, here it is.
Comment 25 Brice Goglin 2007-11-20 03:24:26 UTC
Could this bug be related to http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=451893 ? These guys get no font at all when EXA is enabled.
Comment 26 Wang Zhenyu 2007-11-28 22:03:35 UTC
On my HP 855GM, I've upgraded to sid with xserver-xorg-core 2:1.4.1~git20071119-1, and intel driver version 2.2.0. Fonts are all ok with me. I've tried to reboot many times, but no broken has been seen.

older xorg-core 2:1.4-3 also works.
Comment 27 Michael Fu 2007-11-29 17:02:52 UTC
it seems we have to mark it as worksforme..
Comment 28 Jesse Barnes 2007-11-29 17:46:14 UTC
Interestingly, the screenshot from bug #13367 looks very similar to the one here, and it's still reproducible.  Maybe something is wrong with how we do render accel save/restore on 8xx...
Comment 29 Wang Zhenyu 2007-11-29 18:02:28 UTC
Jesse, S3 with X works great on my HP compaq nx5000. just echo "mem" > /sys/power/state, I can't see any render broken after resume.
Comment 30 Wang Zhenyu 2007-12-03 23:35:14 UTC
reproduced on one sony vaio, i'll look into this.
Comment 31 Wang Zhenyu 2007-12-07 02:40:24 UTC
Fix patch available on bug #13456
Comment 32 Samuel Thibault 2007-12-09 11:28:24 UTC
A quick test showed no problem, I'll keep testing next week, and hope hence be able to mark this as "verified"! 
Comment 33 Samuel Thibault 2007-12-14 12:27:20 UTC
No problem any more. 

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.