Bug 12049

Summary: Compiz is slow on Xinerama
Product: xorg Reporter: Chris Dragan <chris>
Component: App/compizAssignee: David Reveman <reveman>
Status: RESOLVED WORKSFORME QA Contact: Xorg Project Team <xorg-team>
Severity: normal    
Priority: medium    
Version: unspecified   
Hardware: x86-64 (AMD64)   
OS: Linux (All)   
Whiteboard:
i915 platform: i915 features:

Description Chris Dragan 2007-08-18 01:53:40 UTC
Hi,

I'm using TwinView and 2 LCD monitors with 1280x1024 resolution. Compiz is:
- fast if I disable TwinView,
- slooow if I enable TwinView,
- fast again if I enable TwinView and enable NoTwinViewXineramaInfo in xorg.conf, but then windows open between the screens which is nasty.

This last point indicates that it's not a problem with the driver or TwinView, but with enabling Xinerama, because this NoTwinViewXineramaInfo hack only disables Xinerama info and does nothing else.

Normally Compiz takes almost no CPU time with any operations. Slooow with TwinView and Xinerama means that it starts to take 50% upto 100% CPU time even with simple operations such as moving a window of a medium size (i.e. not fullscreen).

My system is Gentoo 64-bit, kernel 2.6.22, nvidia-drivers-100.14.11, xorg-7.2, compiz-0.5.2, xfce4-4.4.1.

I was encountering exactly the same problem with Beryl 0.1.2.
Comment 1 Kristian LyngstĂžl 2009-02-07 01:52:02 UTC
I can't reproduce this. Please re-open at bugs.opencompositing.org if you're still seeing this sort of slow-down. Sorry for the inconvenience.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.