Bug 1384

Summary: radeon 7200 locks up during booting
Product: xorg Reporter: Jim Cornette <jim-cornette>
Component: Driver/RadeonAssignee: Xorg Project Team <xorg-team>
Severity: normal    
Priority: high CC: mharris
Version: git   
Hardware: x86 (IA32)   
OS: Linux (All)   
i915 platform: i915 features:
Description Flags
this is the log file with the radeon driver tried
lspci output
This is /var/log/messages w/ the radeon card being used
vesa to radeon running configuration tool
This is the xorg.conf file w/ vesa edited to type.
Here is the results w/ a refresh problem using the i810
This is using an older radeon and ati driver
This should be /var/log/messages from trials
Another radeon card failure
This is the messages after the fifo error was encountered
This is the output from lspci -vvv none

Description Jim Cornette 2004-09-14 20:24:22 UTC
I am having trouble w/ an i810 graphics card, so I tried to install a radeon
7200 PCI card to see what this card would do. It crashed during initializing and
seems to lockup the computer. I am currently using the card, but with the vesa
driver to submit the problem. I'll attach the xorg.conf file (radeon is usually
inserted as driver), Xorg.0,log and other data.
Comment 1 Jim Cornette 2004-09-14 20:25:35 UTC
Created attachment 903 [details]
this is the log file with the radeon driver tried
Comment 2 Jim Cornette 2004-09-14 20:26:04 UTC
Created attachment 904 [details]
lspci output
Comment 3 Jim Cornette 2004-09-14 20:27:10 UTC
Created attachment 905 [details]
This is /var/log/messages w/ the radeon card being used
Comment 4 Jim Cornette 2004-09-14 20:29:31 UTC
Created attachment 906 [details]
vesa to radeon running configuration tool

this file is when I launched X usingthe vesa driver, then changed to the radeon
driver and exited. then restarted X.
Comment 5 Jim Cornette 2004-09-14 20:32:23 UTC
Created attachment 907 [details]
This is the xorg.conf file w/ vesa edited to type. 

I changed the display resolution via gnome-display properties. This might have
muddied the radeon settings. The radeon entry was replaced with vesa.
Comment 6 Jim Cornette 2004-09-15 14:38:05 UTC
Talking on another list. I found that bug 1175 has been filed and causes the
similar symptoms.
Comment 7 Jim Cornette 2004-09-15 16:49:42 UTC
Created attachment 919 [details]
Here is the results w/ a refresh problem using the i810

I was having severe problems with the radeon card and decided to choose the 815
card as the main card. These messages are from those trials and was very
botched in a lot of cases.
The machine was brought down quietely when these errors were encountered, I
hope the messages were recorded.
Comment 8 Jim Cornette 2004-09-15 16:53:34 UTC
Created attachment 920 [details]
This is using an older radeon and ati driver

This is mixing versions. I hope the errors lead to figuring out why the radeon
Comment 9 Jim Cornette 2004-09-15 16:56:04 UTC
Created attachment 921 [details]
This should be /var/log/messages from trials
Comment 10 Jim Cornette 2004-09-15 19:14:40 UTC
Playing around with trying an older version of X, before the CVS release, I
found that X with the radeon driver still gives horrible errors.

I believe thatthe problem is related to the kernel and the new udev way of doing
things. I'll try with the older kernel, as described in bug 1175

My theory is that the process for creating devices happens and X is started
after the dev nodes are made. X then tries to create a node and the server does
not know about the node and hangs.

I'll try to install an earlier kernel to verify the issue related to dev nodes
for radeon not having a proper initializing, which hangs the computer .
Comment 11 Jim Cornette 2004-09-16 19:38:25 UTC
I pulled the video card from the computer and put it back inside the box. The
card started to smell like it was burning, plus, it didn't work that well.

It would be great for this card to be working again. I was interested in trying
a dual head installation.
Comment 12 Jim Cornette 2004-09-18 20:43:13 UTC
Created attachment 941 [details]
Another radeon card failure

Testing on another computer that has a radeon card, I encountered a problem
relating to fifo errors. I tried a previous CVS version before and it did not
have this FIFO error.
Attached is the messages from this error. An Xorg.0.log is also available and
will be attached.
Comment 13 Jim Cornette 2004-09-18 20:47:18 UTC
Created attachment 942 [details]
This is the messages after the fifo error was encountered

This is the messages from the failure. The xorg file was attached in the
previous attachment
Comment 14 Jim Cornette 2004-09-18 20:56:05 UTC
Created attachment 943 [details]
This is the output from lspci -vvv

The major trigger for this error seems to be related to running mozilla mail.
The fonts disappear and the system respons for other applications slows down
unbelievably. Also, I had trouble with some fonts being hung over from an
earlier version of xorg-x11. This was from the FC2 version of xorg-x11.
My current version is xorg-x11-6.8.0-4.
I am adding Mike Harris to the cc for his awareness for things needed to fix
before FC3 is released.
Comment 15 Jim Cornette 2004-09-18 21:12:47 UTC
Adding Mike Harris to listing for tracking this bug. This problem is on the same
computer that positive reports were made regarding the first CVS release. 
The problem started when the computer was running FC2 but with a CVS upgrade to
xorg-x11. The only noted problem that I experienced that xorg-font-utils did not
install because of conflicts with some fonts from the FC2 version of X.
I then decided to upgrade the system via CDROM to FC3T2 RC2 and noticed the same
effects regarding the FIFO error.
Regarding the first errors with the 7200 card, it hard locked and is currently
out of the box until a proposed resolution to this bug can be initiated and the
card can be reinserted for further testing.
I hope the two different errors can be corrected.

Comment 16 Jim Cornette 2004-09-18 21:15:32 UTC
Two radeon cards effected. One locks up, another fifo errors
Comment 17 Jim Cornette 2004-09-20 20:10:16 UTC
As additional information regarding this fifo error. I have found that setting
the resolution to a depth that disables DRI (24 in my instance) seems to
accentuate this error.

This error still happens using the 16 depth which allows DRI to be enabled. The
system and X are a lot more stable, but shutting down caused a hard lock when
exiting xorg-x11.
Comment 18 Jim Cornette 2004-10-31 09:31:47 UTC
Just to note that this radeon problem is still a problem. I no longer have the
card and it is now in the dark world of Win ME. (Given away to needy, non-linux

Any Radeon 7200 owners running xorg-x11, good luck!


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.