Bug 13999

Summary: 0.10.9 build fails on Windows
Product: FriBidi Reporter: Ryan Pavlik <hebc0c602>
Component: generalAssignee: Behdad Esfahbod <freedesktop>
Status: NEW --- QA Contact:
Severity: normal    
Priority: medium    
Version: unspecified   
Hardware: Other   
OS: Windows (All)   
i915 platform: i915 features:

Description Ryan Pavlik 2008-01-09 17:57:38 UTC
I'm using the latest MinGW and MSYS 1.0.1.  Untarring the distributed tarball gives an error 13 when it concludes, but it does appear to work.

(I just tried the 0.10.8 tarball, and I am getting the same build error but without the tar error.)

I configured with ./configure --prefix=/mingw, then I ran make
 gcc -DHAVE_CONFIG_H -I. -I. -I. -g -O2 -Wall -pedantic -fno-strict-aliasing -MT fribidi_utils.lo -MD -MP -MF .deps/fribidi_utils.Tpo -c fribidi_utils.c  -DDLL_EXPORT -DPIC -o .libs/fribidi_utils.o
fribidi_utils.c:304: error: failure in redeclaration of 'fribidi_is_char_rtl': dllimport'd symbol lacks external linkage.
fribidi_utils.c:304: confused by earlier errors, bailing out
make[1]: *** [fribidi_utils.lo] Error 1
make[1]: Leaving directory `/c/src/fribidi-0.10.8'
make: *** [all] Error 2

If you need more information, please let me know.  I am working on getting this compiled for use in the TRUNK version of AbiWord.
Comment 1 Ryan Pavlik 2008-01-09 20:33:03 UTC
I actually can't get any version to build, even back to 0.10.4.  This same error occurs in 0.10.7 through 0.10.9, with different errors prior.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.