Bug 140

Summary: AM_INIT_AUTOMAKE requires two paramaters.
Product: xorg Reporter: Ian Leitch <port001>
Component: Server/GeneralAssignee: Keith Packard <keithp>
Status: CLOSED NOTOURBUG QA Contact:
Severity: normal    
Priority: high    
Version: unspecified   
Hardware: x86 (IA32)   
OS: Linux (All)   
Whiteboard:
i915 platform: i915 features:

Description Ian Leitch 2003-11-12 11:52:16 UTC
running ./autogen.sh --prefix/opt/fdo in Xproto, Xdmcp etc, bombs out with:

automake-1.5: configure.ac: `AM_INIT_AUTOMAKE' must be used
[...]
autoreconf-2.58: automake failed with exit status: 1

configure.ac contains:
AM_INIT_AUTOMAKE([dist-bzip2])

AM_INIT_AUTOMAKE requires:
e.g AM_INIT_AUTOMAKE([dist-bzip2], [6.6]) where 6.6 is the version number. 

I'm using automake-1.7.8 and autoconf-2.58.

Regards,
Ian.
Comment 1 Matthew Lyszczek 2003-11-13 06:25:54 UTC
Enter 

export WANT_AUTOCONF_2_5=1 and export WANT_AUTOMAKE=1.7

before you compile
Comment 2 St├ęphane Loeuillet 2004-07-26 06:45:42 UTC
i see this as a packaging issue. it is not even an official gentoo ebuild
(breakmygentoo package ??)

comment 1 should help. if it doesn't, try newer ebuilds

closing it as it has great chances to be distro specific
Comment 3 Ian Leitch 2004-07-26 08:34:03 UTC
yeh sorry about this report, I obviously didn't have enough coffee in me at the
time ;) 
Comment 4 Jeremy Huddleston Sequoia 2011-09-27 10:19:26 UTC
Mass update: Close all bugs resolved over one year ago.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.