Bug 14892

Summary: 2.6.24 kernel : AGP 4X hangs xorg
Product: xorg Reporter: Sebastien Valette <sebastien.valette>
Component: Driver/RadeonAssignee: xf86-video-ati maintainers <xorg-driver-ati>
Status: RESOLVED DUPLICATE QA Contact: Xorg Project Team <xorg-team>
Severity: normal    
Priority: medium CC: sebastien.valette
Version: unspecified   
Hardware: x86 (IA32)   
OS: Linux (All)   
i915 platform: i915 features:
Description Flags
Xorg log none

Description Sebastien Valette 2008-03-07 13:31:56 UTC
Created attachment 14937 [details]


I am currently running Ubuntu 7.10, with the radeon driver from current git, and AGP X4 hangs xorg within a short time (less than one minute) after login.

I am using a self-compiled kernel, and all previous versions I compiled (2.6.22-rt, 2.6.23-rt) ran fine. The realtime part dooes not seem o be the culprit as this problem also happens with Ubuntu Hardy Alpha 5 (which runs 2.6.24 and radeon driver version 6.8.

The interesting xorg log line that appears when using the AGP X4 mode:

(II) RADEON(0): Damage tracking initialized for page flipping.
Comment 1 Sebastien Valette 2008-03-07 13:48:09 UTC
Created attachment 14939 [details]
Xorg log

here is the full Xorg log
Comment 2 Sebastien Valette 2008-03-07 14:25:31 UTC
finally, I tried to get a gdb backtrace, without success. 

The ssh connection to the computer is still alive after the hang, but trying to kill Xorg, get a backtrace, restart GDM etc... always fails and finally hangs my ssh connection....

Final note : this is not a complete hang, as the mouse still moves on the screen, but no reaction to any click.

Comment 3 Alex Deucher 2008-03-08 08:58:17 UTC
does this patch help?
Comment 4 Sebastien Valette 2008-03-08 09:17:42 UTC
(In reply to comment #3)
> does this patch help?
> http://www.botchco.com/alex/xorg/entervt.diff

It still hangs. After the hang, I tried to switch terminal, but the screen went black.

Comment 5 Sebastien Valette 2008-04-29 13:24:06 UTC
seen on #radeon IRC logs:

13:35 #radeon: < ghepeu> ok, I think I got a reproduceable lockup
13:35 #radeon: < ghepeu> unrelated to my previous problems, I think, but it's something
13:35 #radeon: < ghepeu> celestia 1.5.0, gtk/gnome interface
13:36 #radeon: < ghepeu> navigation menu -> go to object
13:36 #radeon: < ghepeu> lockup

this lockup also occurs on my machine, and it is the first time it triggers even when using AGP 1x
Comment 6 Sebastien Valette 2008-05-21 17:36:18 UTC
I stumbled onto this thread:


pluging an usb mouse in my laptop allows me to run with AGP 4x without any locks. (the Celestia freeze problem excepted)

Is it of any help?
Comment 7 Alex Deucher 2008-05-21 21:57:23 UTC

*** This bug has been marked as a duplicate of bug 12934 ***

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.