Bug 19188

Summary: some i865 chipsets completely unworkable with xorg 7.3/7.4 on current intel driver
Product: xorg Reporter: slogger <slogger>
Component: Driver/intelAssignee: Gordon Jin <gordon.jin>
Status: RESOLVED DUPLICATE QA Contact: Xorg Project Team <xorg-team>
Severity: critical    
Priority: medium Keywords: NEEDINFO
Version: 7.4 (2008.09)   
Hardware: x86 (IA32)   
OS: Linux (All)   
Whiteboard:

Description slogger 2008-12-19 13:37:56 UTC
I've tried using a dell with an i865 graphics chipset and 1 DVI out on several distros (foresight, arch, ubuntu, using various versions of xorg from 7.3 and 7.4 series) and on all distros the graphics are unusable with the intel driver copackaged.

The basic error message is "failed to open display intel(0)"
It ocurs no matter what way you configure xorg.conf, and it ocurs with autoconfiguration.

The issue, I believe, is that the driver for intel thinks that it must have a VGA or TMDS video out, however the computer I'm using, a dell optiplex sx270, only has a single DVI video output, which, even when forced in xorg to be used as TMDS-1, fails to register properly as a TMDS panel with the driver for some reason. Xorg then fails to launch. Without forcing it to be TMDS, it doesn't detect a connected display at all. I'm guessing that most i865 graphics don't have DVI outputs, hence why this error occurs, but I don't really know for sure. All I know is that it appears impossible to get the graphics working with the intel driver on computers with this particular combination on newer xorg-intel drivers.
Comment 1 Eric Anholt 2008-12-19 16:21:09 UTC
Is a DVO driver being detected for the chipset driving your DVI?  If not, can you pop the machine open and find what it is?  Generally specs for these chipsets are publicly available and it's a matter of a couple of days of hacking by someone with hardware.

(Attaching Xorg.0.log would have prevented the need for the question. Please attach that and dmesg in the future :) )
Comment 2 Michael Fu 2008-12-21 20:44:18 UTC
please refer to http://intellinuxgraphics.org/how_to_report_bug.html for how to report a good bug and provide necessary information.. thanks!
Comment 3 Gordon Jin 2009-01-20 01:20:49 UTC
Without further info, I'll assume this is DVO issue as bug#12882.

*** This bug has been marked as a duplicate of bug 12882 ***