Bug 21403

Summary: Syndaemon -t option not working
Product: xorg Reporter: Baptiste Lafontaine <baptiste33>
Component: Input/synapticsAssignee: Peter Hutterer <peter.hutterer>
Status: RESOLVED FIXED QA Contact:
Severity: normal    
Priority: medium    
Version: 7.4 (2008.09)   
Hardware: All   
OS: Linux (All)   
Whiteboard:
i915 platform: i915 features:

Description Baptiste Lafontaine 2009-04-25 05:49:07 UTC
Binary package hint: xfree86-driver-synaptics

I'm using jaunty, up to date version.

When I start syndaemon with "syndaemon -i 1", syndaemon disable the touchpad for 1 second everytime I type
When I start syndaemon with "syndaemon -i 1 -d", syndaemon doesn't disable the touchpad at all. With the "-t" parameter it is supposed to block only scrolling or taping, but it doesn't work here.

Ask for any extra information necessary.

Is there any way to fix it ?

Thanks

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
NonfreeKernelModules: nvidia
Package: xserver-xorg-input-synaptics 0.99.3-2ubuntu4
ProcEnviron:
 PATH=(custom, user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
ProcVersion: Linux version 2.6.28-11-generic (buildd@palmer) (gcc version 4.3.3 (Ubuntu 4.3.3-5ubuntu4) ) #42-Ubuntu SMP Fri Apr 17 01:57:59 UTC 2009
SourcePackage: xfree86-driver-synaptics
Uname: Linux 2.6.28-11-generic i686
Comment 1 Baptiste Lafontaine 2009-04-25 07:05:22 UTC
I've made a mistake, the second command I've typed is : "syndaemon -i 1 -t" (not -d)

(In reply to comment #0)
> Binary package hint: xfree86-driver-synaptics
> 
> I'm using jaunty, up to date version.
> 
> When I start syndaemon with "syndaemon -i 1", syndaemon disable the touchpad
> for 1 second everytime I type
> When I start syndaemon with "syndaemon -i 1 -d", syndaemon doesn't disable the
> touchpad at all. With the "-t" parameter it is supposed to block only scrolling
> or taping, but it doesn't work here.
> 
> Ask for any extra information necessary.
> 
> Is there any way to fix it ?
> 
> Thanks
> 
> ProblemType: Bug
> Architecture: i386
> DistroRelease: Ubuntu 9.04
> NonfreeKernelModules: nvidia
> Package: xserver-xorg-input-synaptics 0.99.3-2ubuntu4
> ProcEnviron:
>  PATH=(custom, user)
>  LANG=fr_FR.UTF-8
>  SHELL=/bin/bash
> ProcVersion: Linux version 2.6.28-11-generic (buildd@palmer) (gcc version 4.3.3
> (Ubuntu 4.3.3-5ubuntu4) ) #42-Ubuntu SMP Fri Apr 17 01:57:59 UTC 2009
> SourcePackage: xfree86-driver-synaptics
> Uname: Linux 2.6.28-11-generic i686
> 

Comment 2 Peter Hutterer 2009-04-26 04:04:04 UTC
Heh, looks like the -t flag hasn't been hooked up to anything for ages.
Bug confirmed, a patch would be appreciated.
Comment 3 Peter Hutterer 2009-04-27 17:12:25 UTC
disregard my last comment, I was just blind.
Comment 4 Baptiste Lafontaine 2009-04-27 21:50:30 UTC
Bug still confirmed ? 
Comment 5 Peter Hutterer 2009-04-29 19:40:42 UTC
I just tried it here and it seems to work fine with the version in git.
Can you try upgrading to 1.1 and testing with that one? there was a fair bit
of changes between 1.0 and 1.1
Comment 6 Baptiste Lafontaine 2009-05-01 02:39:10 UTC
Sorry but I don't know how to install this version.
Comment 7 Peter Hutterer 2009-05-03 04:22:31 UTC
git clone git://anongit.freedesktop.org/git/xorg/driver/xf86-input-synaptics

Then run ./autogen.sh --prefix=/usr, make and make install. This builds and installs the synaptics driver from git. It also installs synclient and syndaemon.

You will need your X sever's devel headers, best to install the xorg-dev package.
Comment 8 Baptiste Lafontaine 2009-05-06 01:57:30 UTC
I have errors during the make part (autogen and make log at the end).
Make version: 3.81
Xorg version : 7.4

Thanks

magnetik@magnetik-laptop:~/bin/xf86-input-synaptics$ ./autogen.sh --prefix=/usr
autoreconf: Entering directory `.'
autoreconf: configure.ac: not using Gettext
autoreconf: running: aclocal 
autoreconf: configure.ac: tracing
autoreconf: running: libtoolize --install --copy
libtoolize: Consider adding `AC_CONFIG_MACRO_DIR([m4])' to configure.ac and
libtoolize: rerunning libtoolize, to keep the correct libtool macros in-tree.
libtoolize: Consider adding `-I m4' to ACLOCAL_AMFLAGS in Makefile.am.
autoreconf: running: /usr/bin/autoconf
autoreconf: running: /usr/bin/autoheader
autoreconf: running: automake --add-missing --copy --no-force
autoreconf: Leaving directory `.'
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking whether to enable maintainer-specific portions of Makefiles... yes
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking for style of include used by make... GNU
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables... 
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking dependency style of gcc... gcc3
checking for a sed that does not truncate output... /bin/sed
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for fgrep... /bin/grep -F
checking for ld used by gcc... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for BSD- or MS-compatible name lister (nm)... /usr/bin/nm -B
checking the name lister (/usr/bin/nm -B) interface... BSD nm
checking whether ln -s works... yes
checking the maximum length of command line arguments... 1572864
checking whether the shell understands some XSI constructs... yes
checking whether the shell understands "+="... yes
checking for /usr/bin/ld option to reload object files... -r
checking for objdump... objdump
checking how to recognize dependent libraries... pass_all
checking for ar... ar
checking for strip... strip
checking for ranlib... ranlib
checking command to parse /usr/bin/nm -B output from gcc object... ok
checking how to run the C preprocessor... gcc -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking for dlfcn.h... yes
checking for objdir... .libs
checking if gcc supports -fno-rtti -fno-exceptions... no
checking for gcc option to produce PIC... -fPIC -DPIC
checking if gcc PIC flag -fPIC -DPIC works... yes
checking if gcc static flag -static works... yes
checking if gcc supports -c -o file.o... yes
checking if gcc supports -c -o file.o... (cached) yes
checking whether the gcc linker (/usr/bin/ld) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... no
checking for gcc... (cached) gcc
checking whether we are using the GNU C compiler... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking for gcc option to accept ISO C89... (cached) none needed
checking dependency style of gcc... (cached) gcc3
checking which optional backends will be build... eventcomm
checking if XINPUT is defined... no
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for XORG... yes
checking for XORG16... yes
checking for XRECORD... no
checking for XI... yes
checking for ANSI C header files... (cached) yes
./configure: line 12710: XORG_MANPAGE_SECTIONS: command not found
./configure: line 12711: XORG_RELEASE_VERSION: command not found
configure: creating ./config.status
config.status: creating Makefile
config.status: creating src/Makefile
config.status: creating man/Makefile
config.status: creating tools/Makefile
config.status: creating fdi/Makefile
config.status: creating include/Makefile
config.status: creating xorg-synaptics.pc
config.status: creating config.h
config.status: config.h is unchanged
config.status: executing depfiles commands
config.status: executing libtool commands
magnetik@magnetik-laptop:~/bin/xf86-input-synaptics$ make
make  all-recursive
make[1]: entrant dans le répertoire « /home/magnetik/bin/xf86-input-synaptics »
Making all in include
make[2]: entrant dans le répertoire « /home/magnetik/bin/xf86-input-synaptics/include »
make[2]: Rien à faire pour « all ».
make[2]: quittant le répertoire « /home/magnetik/bin/xf86-input-synaptics/include »
Making all in src
make[2]: entrant dans le répertoire « /home/magnetik/bin/xf86-input-synaptics/src »
/bin/bash ../libtool --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I. -I.. -I../include/    -g -O2 -I/usr/include/xorg -I/usr/include/pixman-1    -I../src -MT synaptics.lo -MD -MP -MF .deps/synaptics.Tpo -c -o synaptics.lo synaptics.c
libtool: compile:  gcc -DHAVE_CONFIG_H -I. -I.. -I../include/ -g -O2 -I/usr/include/xorg -I/usr/include/pixman-1 -I../src -MT synaptics.lo -MD -MP -MF .deps/synaptics.Tpo -c synaptics.c  -fPIC -DPIC -o .libs/synaptics.o
synaptics.c:150: erreur: ‘PACKAGE_VERSION_MAJOR’ undeclared here (not in a function)
synaptics.c:150: erreur: ‘PACKAGE_VERSION_MINOR’ undeclared here (not in a function)
synaptics.c:150: erreur: ‘PACKAGE_VERSION_PATCHLEVEL’ undeclared here (not in a function)
synaptics.c:2201: erreur fatale: ouverture du fichier de dépendances .deps/synaptics.Tpo: Permission non accordée
compilation terminée.
make[2]: *** [synaptics.lo] Erreur 1
make[2]: quittant le répertoire « /home/magnetik/bin/xf86-input-synaptics/src »
make[1]: *** [all-recursive] Erreur 1
make[1]: quittant le répertoire « /home/magnetik/bin/xf86-input-synaptics »
make: *** [all] Erreur 2
magnetik@magnetik-laptop:~/bin/xf86-input-synaptics$ 
Comment 9 Peter Hutterer 2009-05-06 17:13:56 UTC
looks like the xorg-macros package is missing. just install it and run
again.
Comment 10 Peter Hutterer 2009-08-16 22:35:08 UTC
can't reproduce and no updates for 3 months. closing as fixed since it works with git.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.