Bug 27749

Summary: cairo-pattern.c:831: cairo_pattern_destroy: Assertion `((*&(&pattern->ref_count)->ref_count) > 0)' failed
Product: poppler Reporter: Pascal Terjan <pterjan>
Component: cairo backendAssignee: poppler-bugs <poppler-bugs>
Status: RESOLVED WORKSFORME QA Contact:
Severity: normal    
Priority: medium    
Version: unspecified   
Hardware: Other   
OS: All   
Whiteboard:
i915 platform: i915 features:

Description Pascal Terjan 2010-04-20 04:47:06 UTC
When scrolling on the attached PDF in evince I often get a crash on following assert:

evince: cairo-pattern.c:831: cairo_pattern_destroy: Assertion `((*&(&pattern->ref_count)->ref_count) > 0)' failed.

I report this against poppler as I don't think evince uses cairo directly.

I am not sure it is related to this specific PDF as I can display any page if I scroll slowly.

If I open it and immediately scroll to the end with page down, then to the beginning, it crashes at some point. Sometimes it happens when scrolling up and down through the first pages.

Once I even got 2 assertions:
evince: cairo-pattern.c:831: cairo_pattern_destroy: Assertion `((*&(&pattern->ref_count)->ref_count) > 0)' failed.
evince: cairo-pattern.c:773: cairo_pattern_reference: Assertion `((*&(&pattern->ref_count)->ref_count) > 0)' failed.
Multiple segmentation faults occurred; can't display error dialog
Comment 1 Pascal Terjan 2010-04-20 04:50:20 UTC
The PDF is too big, you can get it on http://adsl.free.fr/cgv/CGV_Forfait_Freebox_01012010.pdf
Comment 2 Carlos Garcia Campos 2010-04-20 05:26:52 UTC
I can't reproduce it. What poppler and cairo versions are you using?
Comment 3 Pascal Terjan 2010-04-20 05:28:12 UTC
poppler 0.12.4
cairo 1.9.6
Comment 4 Pascal Terjan 2010-04-20 06:40:20 UTC
I can not reproduce with cairo 1.8.8.
Comment 5 Carlos Garcia Campos 2010-04-20 07:51:33 UTC
Could you try with cairo from git master?
Comment 6 Pascal Terjan 2010-04-20 08:08:52 UTC
With cairo master I could not get it to crash, the interface often stops refreshing for 10 to 30s while loading pages if I scroll fast but it no longer crashes.
Comment 7 MichaƂ Grzybowski 2014-05-23 17:39:14 UTC
I cannot reproduce the bug under poppler 0.24.5 with cairo backend/