Bug 31732

Summary: [RADEON:KMS:RS780:R600C-R600G] X crashes with "X: radeon_texture.c:682: radeon_store_teximage: Assertion `0' failed."
Product: Mesa Reporter: Alex Schuster <wonko>
Component: Drivers/DRI/R600Assignee: Default DRI bug account <dri-devel>
Status: RESOLVED FIXED QA Contact:
Severity: major    
Priority: medium    
Version: unspecified   
Hardware: x86-64 (AMD64)   
OS: Linux (All)   
i915 platform: i915 features:
Attachments: /etc/X11/xorg.conf
Xorg.log with gallium enables

Description Alex Schuster 2010-11-18 08:05:16 UTC
Created attachment 40386 [details]

Since I upgraded to KDE 4.5.3 (which also included some minor X.org updates), X crashes about once per day. I cannot reproduce this, the crashes seem random, but they only happen when I click somewhere.

I do not find anything in Xorg.0.log, except for an enourmous amount of "__glXDRIbindTexImage: Failed to register texture offset override" messages, I get several per second all the time.

But in /var/log/kdm.log I see one more line that apparently gets added when the crash happens:
X: radeon_texture.c:682: radeon_store_teximage: Assertion `0' failed.

I have a Radeon HD 3200 on board. My system is Gentoo Linux, and I run xorg-server-1.7.7-r1. I did not select the version in the 'Version:' input list, as I have no clue what versioning scheme that is. My radeon driver has version 6.13.2.

I know that there are newer Xorg releases, but the last time I tried 1.8 and 1.9, KDE crashed either when I moved the mouse to the panel or after no longer than 5 minutes. I will give this a try again soon, though.

The whole system has just been re-compiled with gcc 4.5.1, using -march=k8-sse3 -mfpmath=sse -O2.

So, any ideas what this is? Would it help if I re-compiled the whole Xorg stuff with debug enabled?
Comment 1 Alex Schuster 2010-11-18 08:06:49 UTC
Created attachment 40387 [details]
Comment 2 Alex Deucher 2010-11-18 10:19:25 UTC
This is a 3D driver issue.  You might try r600 gallium as an alternative.
Comment 3 Alex Schuster 2010-11-18 15:11:25 UTC
Okay. I did not ever hera about this gallium stuff, but I see Gentoo has support for it, when I upgrade to mesa-8.9. So I did. Um, how can I see that gallium is really active? I do not see it being mentioned in Xorg.log. Do I have to set some option in xorg.conf?
Comment 4 Alex Deucher 2010-11-18 15:37:08 UTC
check the renderer string in glxinfo
Comment 5 Alex Schuster 2010-11-18 16:42:16 UTC
Okay, so it is not active:"OpenGL renderer string: Mesa DRI R600 (RS780 9610) 20090101  TCL". No gallium in there.

Do I have to activate it? Or is it a matter of compile options? I have to ask the Gentoo devs then.
Comment 6 Alex Schuster 2010-11-19 03:59:59 UTC
Created attachment 40408 [details]
Xorg.log with gallium enables

I found out how to enable gallium mode for mesa. But it does not work at all, X crashes instantly after starting. I'll try newer X.org versions then.
Comment 7 Alex Deucher 2010-11-19 08:02:25 UTC
Gallium only works with KMS (kernel modesetting) and you are using UMS (userspace modesetting).  Enabling KMS might fix the 3D issue either the classic 3D driver or the gallium 3D driver.
Comment 8 Alex Schuster 2010-11-19 11:44:02 UTC
Okay, so I compiled kernel 2.6.36-tuxonice-r1 with KMS enabled. During boot, very soon after I entered my LUKS passphrae, the screen blanks. It comes back when X has started. X and direct rendering sort of work, but syslog shows some kernel nullpointer dereferences, I get only 50 frames with glxgears - quake3 is not playable at all.

When I activated gallium again and restarted X, I I got a blank screen only. I deactivated gallium and restarted X (I had entered a command that would do this automatically after 2 minutes), and I got the KDM login screen, but no mouse or keyboard.

BTW, with and without KVM, with and without gallium, I cannot switch to a text console most of the time. Surprisingly, at this moment it just works, no idea why.

I will avoid KVM for a while, and try newer X.org versions again. Or the fglrx driver, but that did not seem to work either when I tried it some days ago. But I did not reboot, I only unloaded the radeon module, maybe that was the problem. I had fglrx running before I switched to radeon 2 months ago (as I never had any success with the radeon driver before), but that seems to have some memory leak, and my system was very slow. So I was happy when radeon finally seemed to work. I had many artifacts when scrolling, especially when KDE4's desktop effects were enabled, that went away with my the latest update of X.org. But from then on I had the random crashes, today I had two already.
Comment 9 Jerome Glisse 2011-02-09 08:01:58 UTC
Do you still have this issue with more recent kernel + mesa ?
Comment 10 Alex Schuster 2011-02-09 17:19:21 UTC
Whoops, thanks for reminding me. I was using the fglrx driver, it was very stable, but somehow it seems that there is a memory problem, my system was swapping a lot after a day of being logged into KDE4.

So I tried the radeon driver again. And it seems to work now, I did not have a crash since. No __glXDRIbindTexImage messaegs any more. There are some slight graphics distortions, mostly when scrolling stuff. But this effect does not always happen and had been much, much worse half a year ago, so I do not care much.
Oh, now that I try it I see that Quake3 is really slow, about 5 FPS. Nexuiz has 10 FPS and is also unplayable. That's bad. KDE4 desktop effets are okay though. X uses about 20% CPU when I have them enabled, that's a little high, but I think it was the same with fglrx.

I am now running xorg-server 1.7.7-r1, mesa 7.10, radeon 6.14.0. This gallium stuff is disabled.
Comment 11 Jerome Glisse 2012-02-22 10:03:41 UTC
Closing, reopen if this is still an issue with r600g (gallium) from mesa 8.0 or newer.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.