Bug 3608

Summary: Server crash when two successive calls to glXMakeCurrent are done
Product: xorg Reporter: Daniel Stone <daniel>
Component: Server/Ext/GLXAssignee: Xorg Project Team <xorg-team>
Status: RESOLVED DUPLICATE QA Contact:
Severity: critical    
Priority: high    
Version: 6.7.0   
Hardware: x86 (IA32)   
OS: Linux (All)   
Whiteboard:
i915 platform: i915 features:

Description FreeDesktop Bugzilla Database Corruption Fix User 2005-06-23 04:07:54 UTC
When using glX on a Pixmap with indirect rendering, the second call to the
function glXMakeCurrent crashes the X server with signal 11. Does not seem to
appear with direct rendering.

Visual was TrueColor, Pixmap made on the root window.
Comment 1 FreeDesktop Bugzilla Database Corruption Fix User 2005-06-23 04:12:19 UTC
Created attachment 2943 [details]
pure cairo test case (incomplete)

I've removed all tests of correct return of values for clarity. Tests were made
on a TrueColor visual
Comment 2 FreeDesktop Bugzilla Database Corruption Fix User 2005-06-23 04:13:17 UTC
Created attachment 2944 [details] [review]
trivial patch
Comment 3 Adam Jackson 2005-06-25 14:22:29 UTC
this sounds familiar.  is it reproducible with 6.8.2?
Comment 4 Adam Jackson 2005-06-27 15:40:11 UTC
knew this sounded familiar.

there are no further maintenance releases planned on the 6.7 branch.  upgrade to
6.8.2, or apply the patch listed in bug #719.

*** This bug has been marked as a duplicate of 719 ***

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.