Bug 39026

Summary: Recent Documents list does not work
Product: LibreOffice Reporter: Cor Nouws <cno>
Component: LibreofficeAssignee: Not Assigned <libreoffice-bugs>
Status: CLOSED FIXED QA Contact:
Severity: normal    
Priority: high CC: cno, jeffdchang, pedlino, ssanders, sunbird, yfjiang
Version: Master old -3.6Keywords: regression
Hardware: x86-64 (AMD64)   
OS: Windows (All)   
Whiteboard:
Bug Depends on:    
Bug Blocks: 37361    

Description Cor Nouws 2011-07-07 01:35:11 UTC
1 start Office
2. create and save Writer document.
3. Close the office and restart
4. File > Recent documents > Empty
Comment 1 Jeffrey 2011-07-07 08:17:52 UTC
Not reproducible on LibreOffice 3.4  340m1(Build:12) for OpenSuse Linux. But...

It is reproducible on the master.

For non-master: Followed the steps exactly, opened a new document and the file was in the recent files list.

For master: Followed the steps exactly, no recent documents.

I do not know if this is a problem with the master because it is only used for writing the code for. This are just my two cents.
Comment 2 Rainer Bielefeld Retired 2011-07-19 05:55:10 UTC
[Reproducible] with Master "LibO-dev 3.4.5  – WIN7  Home Premium  (64bit) English UI 
[(Build ID:d337f79-a24c961-2865670-9752b71-7f8fd43
	2fdd60d-fd28b6a-fd7bf20-aa369cb-28da3fb
	6a9633a-931d089-ecd263f-c9b55e9-b31b807
	82ff335-599f7e9-bc6a545-1926fdf)]"
Comment 3 Cor Nouws 2011-08-16 01:49:28 UTC
Did a little test:
- start with fresh user profile 
- open document
- close the office
- investigate registrymodifications.xcu
This with 3.4.2 and 35Master

Result:
the used document is not *written* to the registrymodifications.xcu

Then copy / paste recent document info * from 342 registrymodifications.xcu to 35Master registrymodifications.xcu

Result:
35Master does show the recent used document

Conculsion: the information is not written to/in the registrymodifications.xcu

  *)   <item oor:path="/org.openoffice.Office.Histories/Histories/org.openoffice.Office.Histories:HistoryInfo['PickList']/ItemList"> etc
Comment 4 Michael Meeks 2011-08-19 01:42:26 UTC
On Linux, we should be integrating with ~/.recently-used.xbel - so - I suspect there is some different code-path here; Cor - are you testing on Windows ? :-)
Comment 5 Cor Nouws 2011-08-19 01:45:16 UTC
No, have some Win7 thing in virtualbox since recent, but try to avoid ;-)
Comment 6 Cor Nouws 2011-08-19 02:31:57 UTC
whoops, see that Rainer confirmed it for Win7 64 bits :-D
Comment 7 Caolán McNamara 2011-08-19 06:51:27 UTC
SfxPickList::Notify should be called when the document is closed
Comment 8 Caolán McNamara 2011-08-19 07:07:13 UTC
Fixed with http://cgit.freedesktop.org/libreoffice/core/commit/?id=23eb3939a750fbfd3157bd7d3777ae3ec0282b02

Should be a master-only issue, i.e. shouldn't affect 3.4.X.
Comment 9 Cor Nouws 2011-08-19 14:27:45 UTC
OK in Build ID: 35913b9-4eb4f62-260b7c1
Comment 10 Rainer Bielefeld Retired 2011-08-29 00:34:52 UTC
Yes, works fine with Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) English UI [(Build ID: f952331-4eb4f62-09af278)]"
Comment 11 Björn Michaelsen 2011-12-23 13:26:35 UTC
Since all new unconfirmed bugs start in state UNCONFIRMED now and old unconfirmed bugs were moved to NEEDINFO with a explanatory comment, all bugs promoted above those bug states to NEW and later are automatically confirmed making the CONFIRMED whiteboard status redundant. Thus it will be removed.
Comment 12 Leon Stringer 2012-02-15 06:28:42 UTC
This appears to have regressed. I'm seeing this in LibreOffice 3.5.0rc3/Build ID: 7e68ba2-a744ebf-1f241b7-c506db1-7d53735 on Windows 7 SP1 (64-bit) exactly as initially reported.
Comment 13 Meatwad 2012-02-15 06:49:39 UTC
Broken here on 3.5 RC3, 64-bit on Linux Mint 12 x64 as well.
Comment 14 Cor Nouws 2012-02-15 07:17:08 UTC
works fine on Ubuntu and Windows7 (both 32 bits)
Pls don't touch the version field - it's there for the initial report
Comment 15 Scott M. Sanders 2012-02-15 16:17:07 UTC
*** Bug 44321 has been marked as a duplicate of this bug. ***
Comment 16 Caolán McNamara 2012-02-16 02:07:59 UTC
yuck, so this multi-month fixed bug got reopened and various things marked as duplicates of it and its not clear those are duplicates and its not clear that its the same bug.
Comment 17 Jan Holesovsky 2012-02-16 02:30:30 UTC
Scott - please reopen bugs (and set them to "regression") _only_ when the original report regresses.  Your bug report sounds unrelated, setting this one back to FIXED.
Comment 18 Pedro 2012-02-29 03:17:57 UTC
Doesn't work again in 3.5.1RC1 under Win XP Pro x86 SP3 and other OSes
http://ask.libreoffice.org/question/254/no-recent-documents-list-

This is a regression.
Comment 19 Rainer Bielefeld Retired 2012-02-29 03:51:01 UTC
This was an OS ALL issue!

I do not have any idea concerning the reasons, can only say that I do not see the problem with  "LibreOffice 3.5.1.1 German UI/Locale [Build-ID: 45a2874-aa8c38d-dff3b9c-def3dbd-62463c8] on German WIN7 Home Premium (64bit) after Update from 3.5.0
and also not with  "LibreOffice 3.5.1.1 German UI/Locale [Build-ID: 45a2874-aa8c38d-dff3b9c-def3dbd-62463c8] on German WIN XP (32bit VirtualBox), I am not sure from where I updated, I believe 3.5.0

@Pedro:
What information do you have that this is the same bug that has been Fixed with
http://cgit.freedesktop.org/libreoffice/core/commit/?id=23eb3939a750fbfd3157bd7d3777ae3ec0282b02 and not an other one only showing the same symptoms?

If you are not sure please submit a new Bug and for your suspect refer to the old fixed bug in the report.
Comment 20 Pedro 2012-02-29 04:00:52 UTC
(In reply to comment #19)
> This was an OS ALL issue!

Yes, you are right. Sorry :)

> @Pedro:
> What information do you have that this is the same bug that has been Fixed with
> http://cgit.freedesktop.org/libreoffice/core/commit/?id=23eb3939a750fbfd3157bd7d3777ae3ec0282b02
> and not an other one only showing the same symptoms?
> 
> If you are not sure please submit a new Bug and for your suspect refer to the
> old fixed bug in the report.

Apparently it is a different bug (although from a user perspective it is the same)
https://bugs.freedesktop.org/show_bug.cgi?id=46074
Seems that it is already fixed although it wasn't included in 3.5.1 RC1.
Hopefully it will be fixed in RC2 :)
Comment 21 sunbird@riseup.net 2012-05-30 07:26:02 UTC
I know this has been closed and reopened a number of times, but I am still seeing this on a fresh install of Ubuntu 12.04 AMD64 running LibreOffice 3.5.3.2 
Build ID: 350m1(Build:2). 

Please advise if you need more info or if this is fixed here and should be reported downstream.

Thanks!
Comment 22 tommy27 2012-05-30 11:21:55 UTC
@ sunbird@riseup.net

LibO 3.5.4 is out.

please retest with current version.
Comment 23 sunbird@riseup.net 2012-05-31 07:02:12 UTC
Hi,

I updated to LibreOffice 3.5.4.2 Build ID: 350m1(Build:2) and can confirm the issue persists.

Thanks,

Devin
Comment 24 Cor Nouws 2012-07-07 05:59:25 UTC
Works fine in 3.5.3 and ever later.
So if you still have a problem, it's not this bug ;-)
Comment 25 Cor Nouws 2012-07-07 06:00:46 UTC
and close .