Bug 40181

Summary: [845G] GPU Hang on First Login with Display Manager
Product: DRI Reporter: P. J. McDermott <pjm>
Component: DRM/IntelAssignee: Default DRI bug account <dri-devel>
Severity: major    
Priority: medium CC: ben, chris, jbarnes
Version: unspecified   
Hardware: x86 (IA32)   
OS: Linux (All)   
i915 platform: i915 features:
Description Flags
Output of dmesg
i915_error_state none

Description P. J. McDermott 2011-08-17 14:55:05 UTC
Created attachment 50334 [details]
Output of dmesg

On a friend's PC I installed Debian Wheezy GNU/Linux last week.  We booted the system and tried to log in using KDM, but as the fourth icon in KDE's splash screen faded in, the screen went black.  The cursor remained visible and responsive and the welcome music played, so I knew the system and X server didn't completely lock up.  I switched to a virtual terminal and restarted the KDM service.  KDM showed up on tty7 again and we logged in.  This time, the splash screen completed and the desktop was displayed just fine.

I found that the machine's i915 GPU reproducibly hangs on the first display manager login attempt after boot, but so far never on subsequent attempts.  I've tried this with Linux 3.0.0 and 2.6.32, and it seems like an old bug rather than a regression.

$ uname -a
Linux johnny 3.0.0-1-686-pae #1 SMP Sun Jul 24 14:27:32 UTC 2011 i686 GNU/Linux

I'm attaching the output of `dmesg`, the X server log, and $DEBUGFS/dri/0/i915_error_state.  If there's any other information I can provide or steps my friend or I can take to help resolve this, please let me know.  Thanks!

Also reported on Debian BTS:
Comment 1 P. J. McDermott 2011-08-17 14:56:37 UTC
Created attachment 50335 [details]
Comment 2 P. J. McDermott 2011-08-17 15:01:06 UTC
Created attachment 50336 [details]

I copied everything in $DEBUGFS/dri/, so if any other file(s) would help, let me know.
Comment 3 Chris Wilson 2011-08-17 15:19:27 UTC
Short story, don't even think of using the GPU on the 845G. There's a fundamental silicon bug that the workaround for has been lost in the mists of time and continues to cause misery for everyone unfortunate to encounter the 845G.
Comment 4 P. J. McDermott 2011-08-17 19:03:11 UTC
(In reply to comment #3)

Thanks for the response.  The GPU only hangs on the first login attempt though; after that it seems to work fine.  Is this particular issue a hardware error?

Is there any way (like some Xorg configuration options or Linux boot options) we can try to use the GPU safely?  It seems like a shame to give up on a machine that otherwise seems to work well enough.
Comment 5 Eugeni Dodonov 2011-09-08 15:55:46 UTC
This issue is affecting a hardware component which is not being actively worked on anymore.

Moving the assignee to the dri-devel list as contact, to give this issue a better coverage.
Comment 6 Chris Wilson 2012-04-14 06:41:39 UTC
Another of our favourite 845g bug.

*** This bug has been marked as a duplicate of bug 26345 ***

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.