Bug 51403

Summary: Sentelic two finger scrolling/tapping incompatible
Product: xorg Reporter: Jamie Kitson <jamie>
Component: Input/synapticsAssignee: Peter Hutterer <peter.hutterer>
Status: RESOLVED WONTFIX QA Contact:
Severity: normal    
Priority: medium CC: peter.hutterer
Version: unspecified   
Hardware: x86-64 (AMD64)   
OS: Linux (All)   
Whiteboard:
i915 platform: i915 features:
Attachments:
Description Flags
Description
none
Two finger scrolling
none
Two finger tap none

Description Jamie Kitson 2012-06-25 03:02:27 UTC
With my Sentelic touchpad two finger scrolling and two finger tapping interfere with each other. ie, if you disable one, the other works as expected. I tried to report this against the kernel driver but they said that the kernel doesn't deal with scrolling/tapping.

https://bugzilla.kernel.org/show_bug.cgi?id=43591
Comment 1 Peter Hutterer 2012-06-25 18:57:47 UTC
Please grab mtview from https://github.com/whot/mtview and check if the data that comes from the touchpad looks sane (no weird jumps, etc.)

If so, please record the device data with utouch-evemu and attach both the description and event file here. Try to get as short a recording as possible to reproduce.
Comment 2 Jamie Kitson 2012-06-26 14:53:48 UTC
mtview looks fine, but for some reason I am now unable to enable double finger tapping, meaning that I cannot recreate the bug.
Comment 3 Jamie Kitson 2012-06-27 13:13:22 UTC
Created attachment 63530 [details]
Description

Output of 

evemu-describe /dev/input/event7
Comment 4 Jamie Kitson 2012-06-27 13:15:09 UTC
Created attachment 63531 [details]
Two finger scrolling

Output of

evemu-record /dev/input/event7

while two finger scrolling

Issue is that scroll doesn't happen until I lift my fingers off the touchpad.
Comment 5 Jamie Kitson 2012-06-27 13:15:47 UTC
Created attachment 63532 [details]
Two finger tap

Two finger tapping doesn't work either.
Comment 6 Jamie Kitson 2012-06-27 13:16:32 UTC
After a cold start today the touchpad was playing up again.
Comment 7 Jamie Kitson 2012-06-27 13:37:41 UTC
I think I've narrowed it down to horizontal and vertical two finger scrolling that are interfering with each other. If I enable both then it's erratic, if I only enable vertical it's ok.

Two finger taping still doesn't work though.
Comment 8 Jamie Kitson 2012-06-28 02:09:10 UTC
This is possibly an issue with the driver: https://bugzilla.kernel.org/show_bug.cgi?id=43591#c5
Comment 9 Peter Hutterer 2016-11-28 04:40:03 UTC
This is a mass change of bugs. Bugs assigned to me that haven't been updated in the last 3 years are closed as WONTFIX, because, well, let's at least be honest about it.

Please do not re-open unless you have a really good reason to do so (e.g. you're fixing it yourself). If it hasn't been fixed in the last 3 years, it probably won't be fixed anytime soon either. Sorry.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.