Bug 51459

Summary: Shaky connection: continuous disconnects under network load
Product: Telepathy Reporter: Matteo Settenvini <matteo>
Component: gabbleAssignee: Telepathy bugs list <telepathy-bugs>
Status: NEW --- QA Contact: Telepathy bugs list <telepathy-bugs>
Severity: normal    
Priority: medium    
Version: unspecified   
Hardware: Other   
OS: All   
Whiteboard:
i915 platform: i915 features:

Description Matteo Settenvini 2012-06-26 13:30:55 UTC
Dear developers,

of late (a couple of months, at the moment I am running telepathy-gabble 0.16.0 but this applies to a couple of the last releases) I am getting a lot of disconnect events while using Empathy. 

These happen randomly, but are especially frequent when the network connection is under load (a lot of outgoing / incoming connections, such as those given by p2p systems like Yacy or running a Tor relay, help to trigger the issue more than a single connection eating a lot of bandwidth). They can be as frequent as one per 1-2 minutes.

This is annoying especially when having a conversation with someone, as connection with the server is lost and you have to wait for it to be re-established (which might take up to 10-15 seconds) before your messages are delivered.

I am seeing this also with the Jabber server, but it is far more frequent with the Google Talk ones.

How can I help you diagnose the issue?

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.