Bug 54051

Summary: via p4n800 with openchrome 0.3.0 xorg 7.7 crashes at startup - Segmentation fault
Product: xorg Reporter: Sergey Schwartz <svschwartz>
Component: Driver/openchromeAssignee: Openchrome development list <openchrome-devel>
Status: RESOLVED FIXED QA Contact:
Severity: blocker    
Priority: medium CC: xavier
Version: 7.7 (2012.06)   
Hardware: x86 (IA32)   
OS: Linux (All)   
i915 platform: i915 features:
Description Flags
Xorg log
Xorg crashed log with openchrome v0.3.0
Xorg log with ForcePanel=yes none

Description Sergey Schwartz 2012-08-25 11:49:45 UTC
Evaluating ubuntu 12.10 alpha on Via c7 platform. Initially worked fine using VBE mode for xorg driver and grub_gfx_payload=keep. After installing latest updates of ubuntu Xorg didn't work anymore.
Comment 1 Xavier Bachelot 2012-08-28 19:02:02 UTC
Can you please provide the xorg log with the crash ?
Anyway, I suspect this is already fixed by this commit : http://cgit.freedesktop.org/openchrome/xf86-video-openchrome/commit/?id=131175a7163a9189d70ed3118b45eaceb27898c0
Comment 2 Xavier Bachelot 2012-09-05 11:52:14 UTC
openchrome 0.3.1 has been released. I believe it should fix this issue. Can you please confirm ?
Comment 3 Sergey Schwartz 2012-09-05 13:33:36 UTC
Hi Xavier,

It looks like ubuntu 12.10 doesn't have the updated version yet.
Should I build the new version from source code or I can wait for ubuntu maintainers to build it? 

Thanks for support,
Comment 4 Xavier Bachelot 2012-09-05 13:45:02 UTC
It depends on how fast you want to confirm this is actually fixed or not. I'm not surprised Ubuntu doesn't have an updated package yet, I've uploaded the new release less than 24 hours ago ;-)

If you want to build from source, you might want to look at this : http://www.openchrome.org/trac/wiki/Installation#Installfromareleasetarball
Comment 5 Sergey Schwartz 2012-09-06 06:51:01 UTC
Created attachment 66704 [details]
Xorg log
Comment 6 Sergey Schwartz 2012-09-06 06:51:22 UTC
Hi Xavier,

I've managed to build openchrome 0.3.1 driver and now after X is started the screen gets black and I can't even get console (Ctrl+Alt+F1). I've checked Xorg.0.log(attached) but couldn't find any error message. Could it be something special with my system using VBE mode ?

Comment 7 Sergey Schwartz 2012-09-06 07:01:07 UTC
Created attachment 66710 [details]
Xorg crashed log with openchrome v0.3.0
Comment 8 Sergey Schwartz 2012-09-06 07:01:29 UTC
Created attachment 66711 [details]
Comment 9 Bartosz Kosiorek 2012-09-06 08:15:19 UTC
Try to disable VBE mode, and attach Xorg.0.log from openchrome 0.3.1
Comment 10 Xavier Bachelot 2012-09-06 08:37:45 UTC
Ok, so the 0.3.0 crash is gone and it was the breakage I suspected.
Now, let's address the other issue. What is your screen and how is it connected to the board ? Why do you use VBE ? What happens if you remove the X conf, which basically will just not force VBE mode ?
Comment 11 Xavier Bachelot 2012-09-06 08:39:24 UTC
@Bartosz : you were quicker than me ;-) The X log from 0.3.1 with VBE is in comment 5.
Comment 12 Sergey Schwartz 2012-09-06 08:50:25 UTC

I don't actually know how the display is connected. The PC is a monoblock.
Initially it never worked without VBE mode.

Comment 13 Xavier Bachelot 2012-09-06 09:37:15 UTC
What is the exact brand and model of the hardware ? Also, if you have a link to the manufacturer website, it could help.
Comment 14 Xavier Bachelot 2012-09-06 11:44:11 UTC
Rather than using VBE, try to force LVDS panel detection with Option "ForcePanel"
Comment 15 Sergey Schwartz 2012-09-06 12:02:20 UTC

PC specs are here http://www.wincomm.com.tw/product/pdf/WLP-6821-15.pdf

Besides VBE in xorg.conf I have modified grub configuration:

This was supposed to make smooth handover from plymouth to xorg.

UPD: X now start using "ForcePanel", but Unity is so slow.

Comment 16 Xavier Bachelot 2012-09-06 13:07:43 UTC
Great to hear it works. The LVDS detection code is currently not as good as it could be. Please provide the xorg log, I'd like to take a look.

About 3D being slow, that is expected. The unichrome 3D driver has been dropped from Mesa because it is not yet ported to DRI2, so you are running on software rendering over LLVM pipe. Currently, the only way to improve the desktop experience would be to use another desktop manager which is not making such heavy use of 3D.
Comment 17 Sergey Schwartz 2012-09-07 05:48:57 UTC
Created attachment 66763 [details]
Xorg log with ForcePanel=yes
Comment 18 Sergey Schwartz 2012-09-07 05:54:52 UTC
Morning Xavier,

Please find attached Xorg.0.log of a working openbox session with ForcePanel=yes.
OpenBox has no perfomance issues.

I've just updated the pc with apt-get and noticed that xserver-xorg-video-openchrome 0.3.1 was installed. That is pretty fast I guess :).

Comment 19 Xavier Bachelot 2012-09-07 14:22:41 UTC
Closing the bug now you're all set.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.