Bug 55

Summary: segfault in FcTestDestroy
Product: fontconfig Reporter: Marcel Pol <mpol>
Component: libraryAssignee: Keith Packard <keithp>
Status: RESOLVED FIXED QA Contact:
Severity: normal    
Priority: high    
Version: 2.1   
Hardware: Other   
OS: Linux (All)   
i915 platform: i915 features:

Description Marcel Pol 2003-03-26 08:51:14 UTC
When I run abiword, and quit, it segfaults for me. This happenbs when I exit from the menu, or  
when I close the window (in enlightenment 16.5).  
My version of Abiword is 1.1.4, compiled on current Mandrake Cooker, which is the same as  
Mandrake 9.1.   
Some versions of software installed:  
Hardware is a Abitt BP6 with dual Celeron 500Mhz.  
I'm not sure what debugging info is needed, but I compiled abiword with debug, just as  
fontconfig, and ran it through gdb. After it segfaulted, I ran "bt" in gdb.  
(gdb) run  
Starting program: /usr/bin/abiword  
[New Thread 16384 (LWP 22529)]  
(process:22529): Gdk-WARNING **: locale not supported by Xlib  
(process:22529): Gdk-WARNING **: can not set locale modifiers  
Program received signal SIGSEGV, Segmentation fault.  
[Switching to Thread 16384 (LWP 22529)]  
FcTestDestroy (test=0x0) at fcxml.c:63  
63          if (test->next)  
(gdb) bt  
#0  FcTestDestroy (test=0x0) at fcxml.c:63  
#1  0x085683f8 in ?? ()  
#2  0x00000056 in ?? ()  
Comment 1 Keith Packard 2003-03-26 08:53:33 UTC
I believe this is fixed in current CVS, please give that a try.
Comment 2 Marcel Pol 2003-03-29 11:05:14 UTC
Thank you, I compiled the library from today's cvs, and it didn't segfault on it. 

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.