Bug 55596

Summary: weston-launch causes graphical corruption / lockup
Product: Mesa Reporter: Kevin N. <vekinn>
Component: Drivers/DRI/nouveauAssignee: Nouveau Project <nouveau>
Status: RESOLVED FIXED QA Contact:
Severity: major    
Priority: medium CC: blei42, darxus
Version: git   
Hardware: x86-64 (AMD64)   
OS: Linux (All)   
Whiteboard:
i915 platform: i915 features:

Description Kevin N. 2012-10-03 21:55:31 UTC
Using the nouveau linux-2.6 branch and git mesa/libdrm

When I run weston-launch 1&> output
The screen displays white and black blocks with garbled images and is unresponsive.  I can not switch tty nor ctrl+alt+backspace.  I shutdown with ACPI power button.

dmesg does not appear to show any errors and the output of weston-launch appears normal.

The same happens on regular 3.5 and 3.6 kernels with nouveau built in.
Comment 1 Kevin N. 2012-10-03 21:58:40 UTC
The ACPI power button does a soft shutdown that works normally.
Comment 2 Darxus 2012-10-03 22:03:46 UTC
Related bug open for weston:  https://bugs.freedesktop.org/show_bug.cgi?id=54576
Comment 4 Marcin Slusarz 2012-10-25 18:57:08 UTC
Above patch had hit Linus' tree 2 days ago. It will be part of Linux 3.7-rc3. 
Thanks for reporting.
Comment 5 Darxus 2012-10-25 20:21:10 UTC
Great, thanks.  I'll add that to the wayland build docs.  Looks like the mainline commit is:  https://github.com/torvalds/linux/commit/2c14575f99ddd5b8384c5b460687ceba181900d8

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.