Bug 562

Summary: Error activating XKB configuration
Product: xorg Reporter: Matthew East <matthew.east>
Component: App/xkbcompAssignee: Xorg Project Team <xorg-team>
Status: RESOLVED DUPLICATE QA Contact:
Severity: normal    
Priority: high    
Version: 6.7.0   
Hardware: x86 (IA32)   
OS: Linux (All)   
Whiteboard:
i915 platform: i915 features:

Description Matthew East 2004-04-27 20:29:03 UTC
I am running Fedora v. 1.92 (Core 2 Test 3) and recently updated all components,
incuding all xorg components. Since doing this, I now receive an error message
when starting gnome:

Error activating XKB configuration.
Probably internal X server problem.

X server version data:
The X.Org Foundation
60700000

If you report this situation as a bug, please include:
- The result of xprop -root | grep XKB
- The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb

Here are the results of those:

[matt@localhost matt]$ xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "xfree86", "pc105", "gb", "", ""
_XKB_RULES_NAMES(STRING) = "xfree86", "pc105", "gb", "", ""

[matt@localhost matt]$ gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb
 layouts = [gb]
 model = pc105
 overrideSettings = false
 options = []

I hope that you will be able to help me with this.

Many thanks, yours, Matthew East
Comment 1 St├ęphane Loeuillet 2004-04-27 20:37:48 UTC
dupe of http://freedesktop.org/cgi-bin/bugzilla/show_bug.cgi?id=544
(and many others)

change 'xfree86' to 'xorg' in config file
Comment 2 St├ęphane Loeuillet 2004-06-07 02:19:40 UTC

*** This bug has been marked as a duplicate of 472 ***

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.