Bug 64475

Summary: Euro Track Simulator II game slow in cabin with r600g and radeonsi
Product: Mesa Reporter: commiethebeastie
Component: Drivers/Gallium/r600Assignee: Default DRI bug account <dri-devel>
Status: RESOLVED NOTOURBUG QA Contact:
Severity: normal    
Priority: medium CC: commiethebeastie, grantipak, step2back+freedesktop, v10lator
Version: git   
Hardware: x86-64 (AMD64)   
OS: Linux (All)   
Whiteboard:
i915 platform: i915 features:
Bug Depends on: 27222    
Bug Blocks:    
Attachments: Euro Truck Simulator screenshot
GALLIUM_HUD
R600_DEBUG=dump_on_error,sb,ps,vs,hyperz
FPS in cab
Outside the cab car
60 fps in shop (in other menus too)
12 fps in shop inside cab

Description commiethebeastie 2013-05-11 16:31:15 UTC
Created attachment 79172 [details]
Euro Truck Simulator screenshot

I tried to run the game with

STEAM_RUNTIME="1" R600_LLVM=0 R600_HYPERZ=0 steam
Driver      "radeon"
Option "SwapbuffersWait" "on"
Option "ColorTiling" "off"
Option "ColorTiling2D" "off"
Option "EnablePageFlip" "on"
Option "AccelMethod" "EXA"

and

STEAM_RUNTIME="1" R600_LLVM=1 R600_HYPERZ=1 R600_DEBUG=sb steam
Driver      "radeon"
Option "SwapbuffersWait" "off"
Option "ColorTiling" "on"
Option "ColorTiling2D" "on"
Option "EnablePageFlip" "off"
Option "AccelMethod" "EXA"

options

But all times the game runs slowly and with low brightness. In the mirrors is visible to normal brightness. Also I can put apitrace file here.

direct rendering: Yes
OpenGL renderer string: Gallium 0.4 on AMD BARTS
OpenGL core profile version string: 3.1 (Core Profile) Mesa 9.2.0 (git-5471e39)
OpenGL core profile shading language version string: 1.40

Linux localhost 3.9.0-next-20130509 #1 SMP PREEMPT Thu May 9 12:49:14 MSK 2013 x86_64 AMD FX(tm)-8120 Eight-Core Processor AuthenticAMD GNU/Linux
Comment 1 Andreas Boll 2013-05-31 13:09:52 UTC
Could you attach a screenshot of the game using the gallium hud

e.g GALLIUM_HUD="cpu0+cpu1+cpu2+cpu3:100,cpu:100,fps;draw-calls,requested-VRAM+requested-GTT,primitives-generated"

Have you tried to set the cpu-governor to performance?
Are you using the high power state of you gpu?
Comment 2 commiethebeastie 2013-06-29 11:59:28 UTC
Created attachment 81676 [details]
GALLIUM_HUD
Comment 3 commiethebeastie 2013-06-29 12:00:22 UTC
Yes, governor is performance, power_profile is high.
Comment 4 florian.will 2013-11-01 22:06:20 UTC
Just adding some more data, I hope it's not entirely useless for you:

I experience this/a similar issue with HD 6870 and Kernel 3.11, with radeon.dpm and the "performance" CPU governor enabled. I get only ~10-15 FPS while catalyst renders the same scene at 40+ FPS (and probably even more in windows).

Light reflection seems to be wrong which makes the scene look pretty dark compared to how catalyst renders it. The HUD mirrors are fine, while "in-game" mirrors are rendered incorrectly, as you can see from commiethebeastie's screenshot. If you're interested, I can add my screenshot. It's not as dark as the one posted already, but still looks incorrect.

I really don't know a lot about graphics etc., but I could imagine that there is some trouble with compiling shaders..
Comment 5 Alex Deucher 2013-11-04 14:12:09 UTC
*** Bug 71156 has been marked as a duplicate of this bug. ***
Comment 6 commiethebeastie 2014-03-01 09:12:39 UTC
With Intel HD4000 this game works perfectly. The scene does not look dark, but I also can not adjust the brightness.
Comment 7 Alex Deucher 2014-03-02 17:08:07 UTC
The dark rendering is probably a duplicate of bug 75226.  You might try the patches there.
Comment 8 commiethebeastie 2014-03-04 17:42:14 UTC
With 75226 patches scene became lighter.
Comment 9 commiethebeastie 2014-03-04 17:47:14 UTC
Created attachment 95106 [details]
R600_DEBUG=dump_on_error,sb,ps,vs,hyperz
Comment 10 commiethebeastie 2014-03-06 10:40:55 UTC
After the last git update scene no longer a dark. But in cab game works very slow with low graphics settings.
Comment 11 commiethebeastie 2014-03-06 10:41:56 UTC
Created attachment 95221 [details]
FPS in cab
Comment 12 commiethebeastie 2014-03-06 10:43:57 UTC
Created attachment 95222 [details]
Outside the cab car
Comment 13 Dieter N├╝tzel 2014-03-06 12:49:43 UTC
Have you retested radeonsi with R600_DEBUG=hyperz?
It is disabled on radeonsi currently per default.
Comment 14 commiethebeastie 2014-03-06 15:21:55 UTC
Notebook:

echo $R600_DEBUG
hyperz

01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Mars [Radeon HD 8730M] [1002:6601] (rev ff)
Comment 15 commiethebeastie 2014-03-06 15:22:57 UTC
PC:

echo $R600_DEBUG
hyperz

05:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Barts PRO [Radeon HD 6850] [1002:6739]
Comment 16 Stepan Bakshaev 2014-03-08 06:10:07 UTC
(In reply to comment #10)
> After the last git update scene no longer a dark. But in cab game works very
> slow with low graphics settings.

I add with any settings. I shot screen in shop. There are truck, room and nothing more. Outside is 60 fps, but inside 12 only.
Comment 17 Stepan Bakshaev 2014-03-08 06:11:31 UTC
Created attachment 95339 [details]
60 fps in shop (in other menus too)
Comment 18 Stepan Bakshaev 2014-03-08 06:12:30 UTC
Created attachment 95340 [details]
12 fps in shop inside cab

env R600_DEBUG=hyperz GALLIUM_HUD="fps"
Comment 20 commiethebeastie 2014-08-02 21:04:38 UTC
Fixed by 1.11 patch.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.