Bug 65273

Summary: [drm] Freeze, GPU hung
Product: Mesa Reporter: Philipp √úberbacher <murks>
Component: Drivers/DRI/i915Assignee: Ian Romanick <idr>
Status: RESOLVED MOVED QA Contact:
Severity: normal    
Priority: medium    
Version: 9.1   
Hardware: x86 (IA32)   
OS: Linux (All)   
Whiteboard:
i915 platform: i915 features:
Attachments: event capture
xrandr --verbose

Description Philipp √úberbacher 2013-06-02 22:06:26 UTC
Chipset is whatever is in the i3-2350M processor, HD3000 or whatever it's called.
system architecture: i686
libdrm: 2.4.45
mesa: 9.1.3
xf86-video-intel: 2.21.8
X.Org X Server: 1.14.1, Build Operating System: Linux 3.8.7
uname -r: 3.9.4-1-ARCH
Linux distribution: Arch Linux
Reproducable: not really, so far it only happened to me while playing games. It happens rarely and without obvious triggering event.

Last entry:
...
Jun 02 20:49:41 eeyore devmon[1128]: partition:      [1]
Jun 02 23:12:45 eeyore kernel: [drm:i915_hangcheck_hung] *ERROR* Hangcheck timer elapsed... GPU hung
Jun 02 23:12:45 eeyore kernel: [drm] capturing error event; look for more information in/sys/kernel/debug/dri/0/i915_error_state
Jun 02 23:12:57 eeyore systemd-logind[1132]: Power key pressed.
Jun 02 23:12:57 eeyore systemd-logind[1132]: Powering Off...
...

$cat /sys/kernel/debug/dri/0/i915_error_state
no error state collected

What happens is quite simple, the whole system seems to be frozen, almost nothing reacts, certainly nothing that could help me to collect further information. The problem seems to be present since a while, it caused me to report this: https://bugs.freedesktop.org/show_bug.cgi?id=61411.
However, the first few times I played relatively demanding games and the laptop got rather warm, this time the game was far less demanding and the machine was not warmer than usual.

If there's any further information I can provide to help fix this, please tell me.
Comment 1 Brian Baligad 2013-08-16 09:55:22 UTC
Created attachment 84132 [details]
event capture

These are the contents of /sys/kernel/debug/dri/0/i915_error_state after the gpu hung event occurred.
Comment 2 Brian Baligad 2013-08-16 10:12:18 UTC
Created attachment 84134 [details]
xrandr --verbose
Comment 3 Brian Baligad 2013-08-16 10:20:26 UTC
Bug description:
I seem to be having the same issue.  This occurred several times in a short period while using chromium on a second monitor.  I set the secondary monitor up with: xrandr --output eDP1 --right-of HDMI1

System environment:
-- chipset: i7-4700MQ with the HD 4600 gpu
-- system architecture: 64-bit (x86_64)
-- xf86-video-intel: 2.21.14-2
-- xserver: 1.14.2-2
-- mesa: 9.1.6-1
-- libdrm: 2.4.46-2
-- kernel: 3.10.6-2-ARCH
-- Linux distribution: Arch
-- Machine or mobo model: Toshiba Satellite P70-A [PSPLNU-01Q006] 
-- Display connector: hdmi 

dmesg:
[drm:i915_hangcheck_hung] *ERROR* Hangcheck timer elapsed... GPU hung
[drm] capturing error event; look for more information in /sys/kernel/debug/dri/0/i915_error_state
[drm:kick_ring] *ERROR* Kicking stuck wait on blitter ring

I attached the contents of i915_error_state
Comment 4 Brian Baligad 2013-08-20 06:14:32 UTC
Dual head display seemed to work fine earlier this month when I installed this system. In the last week or so I run into the same issues anytime the second display is connected.
[  356.614203] [drm:i915_hangcheck_hung] *ERROR* Hangcheck timer elapsed... GPU hung
[  356.614208] [drm] capturing error event; look for more information in /sys/kernel/debug/dri/0/i915_error_state
[  356.621884] [drm:kick_ring] *ERROR* Kicking stuck wait on blitter ring
[  452.710408] Watchdog[966]: segfault at 0 ip 00007ff58f002938 sp 00007ff57ca5f010 error 6 in chromium[7ff58e229000+503a000]
[  458.656344] [drm:i915_hangcheck_hung] *ERROR* Hangcheck timer elapsed... GPU hung
[  458.656380] [drm:kick_ring] *ERROR* Kicking stuck wait on blitter ring
[  470.681128] Watchdog[1146]: segfault at 0 ip 00007fc67a291938 sp 00007fc667cee010 error 6 in chromium[7fc6794b8000+503a000]
[  473.721812] [drm:i915_hangcheck_hung] *ERROR* Hangcheck timer elapsed... GPU hung
[  483.709854] [drm:i915_hangcheck_hung] *ERROR* Hangcheck timer elapsed... GPU hung
[  483.709868] [drm:kick_ring] *ERROR* Kicking stuck wait on blitter ring
[  541.776618] [drm:i915_hangcheck_hung] *ERROR* Hangcheck timer elapsed... GPU hung
[  541.776654] [drm:kick_ring] *ERROR* Kicking stuck wait on blitter ring
[  553.800507] Watchdog[1201]: segfault at 0 ip 00007f83ca2c6938 sp 00007f83b7d23010 error 6 in chromium[7f83c94ed000+503a000]
[  556.808672] [drm:i915_hangcheck_hung] *ERROR* Hangcheck timer elapsed... GPU hung
[  556.808693] [drm:kick_ring] *ERROR* Kicking stuck wait on blitter ring
Comment 5 Brian Baligad 2013-08-20 08:32:48 UTC
Correction: I just realized that it's fine as long as I don't put Chromium on the second display.  My statement "seemed to work fine earlier this month" was actually due to that.
Comment 6 Rex Dieter 2014-07-07 19:05:06 UTC
It would appear some related action is going on in bug #54226
Comment 7 Adam Jackson 2019-09-18 19:37:25 UTC
https://gitlab.freedesktop.org/mesa/mesa/issues/728

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.