Bug 69729

Summary: HDMI audio stopped working on HD 3470 (RV620/M82)
Product: DRI Reporter: Paul Bodenbenner <paul.bodenbenner>
Component: DRM/RadeonAssignee: Default DRI bug account <dri-devel>
Status: RESOLVED FIXED QA Contact:
Severity: normal    
Priority: medium CC: pasqual.milvaques
Version: unspecified   
Hardware: x86-64 (AMD64)   
OS: Linux (All)   
i915 platform: i915 features:
Description Flags
possible fix
possible fix
3.12rc4 none

Description Paul Bodenbenner 2013-09-23 19:07:31 UTC
Using Arch Linux 64 bit on HD 3470 (RV620/M82). With kernel 3.10.10 HDMI audio did work and with no other package changed, audio over HDMI doesn't work anymore with kernel 3.11.1.
Comment 1 Paul Bodenbenner 2013-09-23 19:09:04 UTC
Created attachment 86409 [details]
Comment 2 Paul Bodenbenner 2013-09-23 19:09:25 UTC
Created attachment 86410 [details]
Comment 3 Paul Bodenbenner 2013-09-23 19:09:53 UTC
Created attachment 86411 [details]
Comment 4 Paul Bodenbenner 2013-09-23 19:10:11 UTC
Created attachment 86412 [details]
Comment 5 Paul Bodenbenner 2013-09-23 19:11:32 UTC
Created attachment 86413 [details]
Comment 6 Paul Bodenbenner 2013-09-23 19:11:49 UTC
Created attachment 86414 [details]
Comment 7 Alex Deucher 2013-09-23 19:31:32 UTC
Possibly a duplicate of bug 69675.  Does reverting e6e792092e816bea0797995c886fb057c91d4546 fix it?
Comment 8 Paul Bodenbenner 2013-09-23 19:39:03 UTC
I am not using any of those modes...
Comment 9 Alex Deucher 2013-09-23 19:46:52 UTC
Nevermind, I found the problem.  Patch forthcoming.
Comment 10 Alex Deucher 2013-09-23 19:49:19 UTC
Created attachment 86417 [details] [review]
possible fix

This patch should fix it.
Comment 11 Paul Bodenbenner 2013-09-23 22:31:20 UTC
Thank you very much for your fast answering (again).
I patched it against kernel 3.11.1 and now I can hear some sound. Unfortunately it will be played very fast, so the voice is very "high".
I tried different streams / media without any difference and also with radeon.dpm=0 and 1.
Comment 12 Alex Deucher 2013-09-23 22:36:41 UTC
Does reverting e6e792092e816bea0797995c886fb057c91d4546 fix the playback?
Comment 13 Paul Bodenbenner 2013-09-23 23:53:25 UTC
Created attachment 86425 [details]
Comment 14 Paul Bodenbenner 2013-09-23 23:57:05 UTC
Tried to undo commit e6e792092e816bea0797995c886fb057c91d4546 from version 3.11.1 and the result seems ok for me. To be sure I attached the resulting file.
Unfortunately by using this file that didn't make any difference. Playback is still too fast.
Any other ideas?
Comment 15 Alex Deucher 2013-09-24 13:42:38 UTC
Probably best to bisect and manually apply attachment 86417 [details] [review] before testing each step.
Comment 16 Paul Bodenbenner 2013-09-24 21:49:10 UTC
Compiled 3.11-rc4 including your attached patch and HDMI audio seems to be working fine.
Compiling rc6 now...
Comment 17 Paul Bodenbenner 2013-09-24 22:48:00 UTC
Interesting..., rc6 has the bug already.
Let's see if rc5 is still working...
Comment 18 Paul Bodenbenner 2013-09-25 09:07:18 UTC
Beginning with rc5 the problem occurs.
Hope that helps a bit.
Comment 19 Alex Deucher 2013-09-25 16:10:01 UTC
Created attachment 86570 [details] [review]
possible fix

Does this patch fix the playback problems?
Comment 20 Paul Bodenbenner 2013-09-25 18:17:02 UTC
Nice, nice, nice...
Patch worked on rc5. So it seems to be solved.
For being sure I will apply both patches also on 3.11.1 and give feedback.
Comment 21 Paul Bodenbenner 2013-09-25 20:20:08 UTC
Works also on 3.11.1. So Bug is solved for me.
Thanks a lot!
Comment 22 Paul Bodenbenner 2013-09-26 00:17:01 UTC
Bad news. On 3.12rc2 those patches don't work anymore. Same problem like at starting this crq. HDMI audio seems to be totally disabled...
Comment 23 Alex Deucher 2013-09-26 00:57:14 UTC
(In reply to comment #22)
> Bad news. On 3.12rc2 those patches don't work anymore. Same problem like at
> starting this crq. HDMI audio seems to be totally disabled...

In 3.12 you can enable audio on the fly with xrandr.  E.g.,

xrandr --output HDMI-0 --set audio auto
Comment 24 Paul Bodenbenner 2013-09-26 10:08:14 UTC
(In reply to comment #23)
> (In reply to comment #22)
> > Bad news. On 3.12rc2 those patches don't work anymore. Same problem like at
> > starting this crq. HDMI audio seems to be totally disabled...
> In 3.12 you can enable audio on the fly with xrandr.  E.g.,
> xrandr --output HDMI-0 --set audio auto

Perfect, that did the trick.
So everything is working like a charm with those both patches.
Thanks for your good and fast work!
Comment 25 pasqual milvaques 2013-10-01 22:18:26 UTC
Is there any provision about when the patches will be included in the stable kernel? 3.11.3 is out today and doesn't contain the fix

Comment 26 Alex Deucher 2013-10-01 22:25:01 UTC
Fix went into 3.12 this week.  Should show up in the 3.11 stable series any time now.

Comment 27 Paul Bodenbenner 2013-10-06 21:39:41 UTC
I have seen that the patches are already included in kernel 3.11.4. Unfortunately it doesn't work even though by using kernel parameter radeon.audio=1. Seems again that HDMI is not enabled.
Comment 28 Paul Bodenbenner 2013-10-06 21:54:15 UTC
For sure, with kernel 3.12rc3 it does still work perfectly...
Comment 29 Rafał Miłecki 2013-10-07 05:24:12 UTC
Are you sure you tested 3.11.4? It should work just like 3.12-rc3.

Can you install radeontool and provide output of "avivotools regs hdmi" command when:

1) Playing audio with 3.11.4 (remember about radeon.audio=1)
2) Playing audio with 3.12-rc3
Comment 30 Paul Bodenbenner 2013-10-07 08:46:13 UTC
Created attachment 87222 [details]
Comment 31 Paul Bodenbenner 2013-10-07 08:46:53 UTC
Created attachment 87223 [details]
Comment 32 Paul Bodenbenner 2013-10-07 08:50:10 UTC
Yes, I am using 3.11.4 from Arch testing repository and also enabled HDMI in kernel boot line.
Just a side note: Upgraded to 3.12rc4 already...
Comment 33 Paul Bodenbenner 2013-10-07 09:02:06 UTC
For sure 3.11.4 is already in the stable repository.
Comment 34 Rafał Miłecki 2013-10-07 09:50:31 UTC
Paul: OK, you're right. It was a mistake in backporting the fix.

Reported: http://permalink.gmane.org/gmane.linux.kernel.stable/66333
Comment 35 Paul Bodenbenner 2013-10-07 19:28:32 UTC
Fine, sorry I thought already about a failure during patching, but I was too busy to look at it...

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.